summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD39
2 files changed, 35 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e6832e0939c..5df83657cbb3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fish-git
pkgdesc = User friendly shell intended mostly for interactive use.
- pkgver = 3.1.0.r242.gcebfaa778
+ pkgver = 3.1.2.r2055.gc633ce7e7
pkgrel = 1
epoch = 2
url = http://fishshell.com
@@ -9,12 +9,19 @@ pkgbase = fish-git
arch = x86_64
arch = arm
license = GPL2
+ checkdepends = expect
makedepends = cmake
makedepends = python-sphinx
makedepends = git
+ depends = glibc
+ depends = gcc-libs
depends = ncurses
- optdepends = python: fish_update_completions and other tools
+ depends = pcre2
+ optdepends = python: man page completion parser / web config tool
+ optdepends = pkgfile: command-not-found hook
+ optdepends = wl-clipboard: clipboard integration
optdepends = xsel: clipboard integration
+ optdepends = xclip: clipboard integration
provides = fish
provides = fish-shell
conflicts = fish
diff --git a/PKGBUILD b/PKGBUILD
index 21f799397dbe..b1800160ecce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,26 @@
# Contributor: Eric Belanger <eric@archlinux.org>
# Contributor: Jan Fader <jan.fader@web.de>
# Contributor: Stephen Drodge <stephen.drodge@gmail.com>
+# Contributor: akiirui (AUR)
# Maintainer: SanskritFritz (gmail)
pkgname=fish-git
_gitname="fish-shell"
-pkgver=3.1.0.r242.gcebfaa778
+pkgver=3.1.2.r2055.gc633ce7e7
pkgrel=1
epoch=2
pkgdesc="User friendly shell intended mostly for interactive use."
arch=('i686' 'x86_64' 'arm')
url="http://fishshell.com"
license=("GPL2")
-depends=('ncurses')
-optdepends=('python: fish_update_completions and other tools'
- 'xsel: clipboard integration')
+depends=('glibc' 'gcc-libs' 'ncurses' 'pcre2')
+optdepends=('python: man page completion parser / web config tool'
+ 'pkgfile: command-not-found hook'
+ 'wl-clipboard: clipboard integration'
+ 'xsel: clipboard integration'
+ 'xclip: clipboard integration')
makedepends=('cmake' 'python-sphinx' 'git')
+checkdepends=('expect')
provides=('fish' 'fish-shell')
conflicts=('fish' 'fish-shell')
install='fish.install'
@@ -28,17 +33,25 @@ pkgver() {
git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
-build() {
- cd "$srcdir/$_gitname"
- mkdir -p build
- cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_SYSCONFDIR=/etc -DCMAKE_BUILD_TYPE=Release ..
- make
+check() {
+ cd "$_gitname"
+ make -C build test
+}
+build() {
+ cd "$_gitname"
+ export CXXFLAGS+=" ${CPPFLAGS}"
+ cmake \
+ -B build \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc \
+ -DCMAKE_BUILD_TYPE=None \
+ -DBUILD_DOCS=True \
+ -Wno-dev
+ make -C build
}
package() {
- cd "$srcdir/$_gitname/build"
- make DESTDIR="$pkgdir" install
-
+ cd "$_gitname"
+ make -C build DESTDIR="$pkgdir" install
}