summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0287e09730cf..eccd55859310 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fish-git
pkgdesc = User friendly shell intended mostly for interactive use.
- pkgver = 3.0.2.r711.g77e71cfcb
- pkgrel = 2
+ pkgver = 3.0.2.r801.g318fe3c04
+ pkgrel = 1
epoch = 2
url = http://fishshell.com
install = fish.install
@@ -10,9 +10,8 @@ pkgbase = fish-git
arch = arm
license = GPL2
makedepends = cmake
- makedepends = doxygen
+ makedepends = python-sphinx
makedepends = git
- makedepends = ncurses
depends = ncurses
optdepends = python: fish_update_completions and other tools
optdepends = xsel: clipboard integration
diff --git a/PKGBUILD b/PKGBUILD
index 8a44840b4a61..da71d66fdbcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
pkgname=fish-git
_gitname="fish-shell"
-pkgver=3.0.2.r711.g77e71cfcb
-pkgrel=2
+pkgver=3.0.2.r801.g318fe3c04
+pkgrel=1
epoch=2
pkgdesc="User friendly shell intended mostly for interactive use."
arch=('i686' 'x86_64' 'arm')
@@ -16,7 +16,7 @@ license=("GPL2")
depends=('ncurses')
optdepends=('python: fish_update_completions and other tools'
'xsel: clipboard integration')
-makedepends=('cmake' 'doxygen' 'git' 'ncurses')
+makedepends=('cmake' 'python-sphinx' 'git')
provides=('fish' 'fish-shell')
conflicts=('fish' 'fish-shell')
install='fish.install'
@@ -25,7 +25,6 @@ md5sums=('SKIP')
pkgver() {
cd "$_gitname"
-# git log -1 --format="%cd" --date=short | sed 's|-|.|g'
git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
@@ -42,7 +41,4 @@ package() {
cd "$srcdir/$_gitname/build"
make DESTDIR="$pkgdir" install
- # https://github.com/fish-shell/fish-shell/issues/5719
-# mv "$pkgdir/usr/local/share/fish/"* "$pkgdir/usr/share/fish"
-# rmdir "$pkgdir/usr/local/share/fish" "$pkgdir/usr/local/share" "$pkgdir/usr/local"
}