summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
2 files changed, 34 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a7835824372..fb87545245b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,28 @@
pkgbase = fish-git
- pkgdesc = User friendly shell intended mostly for interactive use (gitorius.org legacy version).
- pkgver = 2012.01.31
+ pkgdesc = User friendly shell intended mostly for interactive use.
+ pkgver = 2.2.0.r278.ge70ed96
pkgrel = 1
- epoch = 1
- url = http://gitorious.org/fish-shell
+ epoch = 2
+ url = http://fishshell.com
install = fish.install
arch = i686
arch = x86_64
+ arch = arm
license = GPL
license = LGPL
license = BSD
license = MIT
makedepends = doxygen
makedepends = git
- depends = ncurses
+ makedepends = ncurses
depends = bc
- optdepends = python2: make_completions script
+ optdepends = python: fish_update_completions and other tools
+ optdepends = pkgfile: for command-not-found handler
provides = fish
+ provides = fish-shell
conflicts = fish
- source = git://gitorious.org/fish-shell/fish-shell.git
+ conflicts = fish-shell
+ source = git://github.com/fish-shell/fish-shell.git
md5sums = SKIP
pkgname = fish-git
diff --git a/PKGBUILD b/PKGBUILD
index 820cca606412..5d9725d80507 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,45 @@
# Contributor: Abhishek Dasgupta <abhidg@gmail.com>
# Contributor: Eric Belanger <eric@archlinux.org>
# Contributor: Jan Fader <jan.fader@web.de>
-# Contributor: SanskritFritz (gmail)
+# Contributor: Stephen Drodge <stephen.drodge@gmail.com>
+# Maintainer: SanskritFritz (gmail)
pkgname=fish-git
_gitname="fish-shell"
-pkgver=2012.01.31
+pkgver=2.2.0.r278.ge70ed96
pkgrel=1
-epoch=1
-pkgdesc="User friendly shell intended mostly for interactive use (gitorius.org legacy version)."
-arch=('i686' 'x86_64')
-url="http://gitorious.org/fish-shell"
+epoch=2
+pkgdesc="User friendly shell intended mostly for interactive use."
+arch=('i686' 'x86_64' 'arm')
+url="http://fishshell.com"
license=("GPL" "LGPL" "BSD" "MIT")
-depends=('ncurses' 'bc')
-optdepends=('python2: make_completions script')
-makedepends=('doxygen' 'git')
-provides=('fish')
-conflicts=('fish')
-install=fish.install
-source=("git://gitorious.org/fish-shell/fish-shell.git")
+depends=('bc')
+optdepends=('python: fish_update_completions and other tools'
+ 'pkgfile: for command-not-found handler')
+makedepends=('doxygen' 'git' 'ncurses')
+provides=('fish' 'fish-shell')
+conflicts=('fish' 'fish-shell')
+install='fish.install'
+source=("git://github.com/fish-shell/fish-shell.git")
md5sums=('SKIP')
pkgver() {
cd "$_gitname"
- git log -1 --format="%cd" --date=short | sed 's|-|.|g'
+# git log -1 --format="%cd" --date=short | sed 's|-|.|g'
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cd $srcdir/$_gitname
+ cd "$srcdir/$_gitname"
+
autoconf
- ./configure --prefix=/usr --sysconfdir=/etc --docdir=/usr/share/doc/fish --without-xsel
+ ./configure --prefix=/usr --sysconfdir=/etc --docdir=/usr/share/doc/fish
make
}
package() {
- cd $srcdir/$_gitname
+ cd "$srcdir/$_gitname"
make DESTDIR="$pkgdir" install
- install -D -m644 user_doc/html/license.html "$pkgdir/usr/share/licenses/fish/license.html"
-
- install -m755 make_completions.py "$pkgdir/usr/bin/make_completions"
- sed -i "s/python/python2/" "$pkgdir/usr/bin/make_completions"
+ # Workaround for file conflict:
+ rm "$pkgdir/usr/share/fish/completions/docker.fish"
}