summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07165ed895ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = fishnet-bin
+ pkgdesc = Distributed Stockfish analysis for lichess.org
+ pkgver = 2.3.3
+ pkgrel = 1
+ url = https://github.com/niklasf/fishnet
+ arch = x86_64
+ license = GPL
+ provides = fishnet
+ conflicts = fishnet
+ source = https://github.com/niklasf/fishnet/releases/download/v2.3.3/fishnet-x86_64-unknown-linux-gnu
+ sha256sums = 96da117146757e5fdc58f821e60bf495a33833b18bf43905a05a1a233cf4e250
+
+pkgname = fishnet-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..79469ecd97a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: João Figueiredo <islandc0der@chaotic.cx>
+
+pkgname=fishnet-bin
+pkgver=2.3.3
+pkgrel=1
+pkgdesc='Distributed Stockfish analysis for lichess.org'
+arch=(x86_64)
+url='https://github.com/niklasf/fishnet'
+license=(GPL)
+conflicts=(${pkgname%-bin})
+provides=(${pkgname%-bin})
+source=("$url/releases/download/v$pkgver/fishnet-$arch-unknown-linux-gnu")
+sha256sums=('96da117146757e5fdc58f821e60bf495a33833b18bf43905a05a1a233cf4e250')
+
+package() {
+ install -Dm755 fishnet-$arch-unknown-linux-gnu "$pkgdir/usr/bin/fishnet"
+}