summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD80
2 files changed, 50 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16c0ea7c2aec..7d37892be024 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = flacon-git
pkgdesc = Extracts individual tracks from one big audio file containing the entire album of music and saves them as separate audio files. (Git Version)
- pkgver = 9.5.1.31.g79ffe9c
+ pkgver = 11.3.0.25.g64bc4f4
pkgrel = 1
url = http://flacon.github.io
arch = x86_64
license = LGPL2.1
+ checkdepends = yaml-cpp
checkdepends = faac
checkdepends = flac
checkdepends = lame
@@ -17,12 +18,13 @@ pkgbase = flacon-git
checkdepends = sox
makedepends = git
makedepends = cmake
- makedepends = qt5-tools
- depends = qt5-base
+ makedepends = qt6-tools
+ depends = gcc-libs
+ depends = glibc
+ depends = qt6-base
depends = uchardet
depends = taglib
depends = hicolor-icon-theme
- depends = desktop-file-utils
optdepends = faac: For AAC support
optdepends = flac: For FLAC support
optdepends = lame: For MP3 support
diff --git a/PKGBUILD b/PKGBUILD
index 99f73a221b52..b1e96a2295d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,52 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=flacon-git
-pkgver=9.5.1.31.g79ffe9c
+pkgver=11.3.0.25.g64bc4f4
pkgrel=1
pkgdesc="Extracts individual tracks from one big audio file containing the entire album of music and saves them as separate audio files. (Git Version)"
arch=('x86_64')
url='http://flacon.github.io'
license=('LGPL2.1')
-depends=('qt5-base'
- 'uchardet'
- 'taglib'
- 'hicolor-icon-theme'
- 'desktop-file-utils'
- )
-makedepends=('git'
- 'cmake'
- 'qt5-tools'
- )
-optdepends=('faac: For AAC support'
- 'flac: For FLAC support'
- 'lame: For MP3 support'
- 'mac: For APE support'
- 'mp3gain: For MP3 Replay Gain support'
- 'vorbis-tools: For OGG support'
- 'opus-tools: For OPUS support'
- 'ttaenc: For TrueAudio support'
- 'vorbisgain: For OGG Replay Gain support'
- 'wavpack: For WavPack support'
- 'alacenc-git: For ALAC Support'
- 'sox: for SOX support'
- )
-checkdepends=('faac'
- 'flac'
- 'lame'
- 'mac'
- 'vorbis-tools'
- 'opus-tools'
- 'ttaenc'
- 'wavpack'
- 'alacenc-git'
- 'sox'
- )
+depends=(
+ 'gcc-libs' # libgcc_s.so libstdc++.so
+ 'glibc' # libc.so libm.so
+ 'qt6-base' # libQt6Core.so libQt6Gui.so libQt6Network.so libQt6Widgets.so
+ 'uchardet' # libuchardet.so
+ 'taglib' # libtag.so
+ 'hicolor-icon-theme'
+)
+makedepends=(
+ 'git'
+ 'cmake'
+ 'qt6-tools'
+)
+optdepends=(
+ 'faac: For AAC support'
+ 'flac: For FLAC support'
+ 'lame: For MP3 support'
+ 'mac: For APE support'
+ 'mp3gain: For MP3 Replay Gain support'
+ 'vorbis-tools: For OGG support'
+ 'opus-tools: For OPUS support'
+ 'ttaenc: For TrueAudio support'
+ 'vorbisgain: For OGG Replay Gain support'
+ 'wavpack: For WavPack support'
+ 'alacenc-git: For ALAC Support'
+ 'sox: for SOX support'
+)
+checkdepends=(
+ 'yaml-cpp'
+ 'faac'
+ 'flac'
+ 'lame'
+ 'mac'
+ 'vorbis-tools'
+ 'opus-tools'
+ 'ttaenc'
+ 'wavpack'
+ 'alacenc-git'
+ 'sox'
+)
conflicts=('flacon')
provides=('flacon')
source=('git+https://github.com/flacon/flacon.git')
@@ -56,7 +62,9 @@ build() {
cmake -S flacon -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DBUILD_TESTS=Yes
+ -DBUILD_TESTS=ON \
+ -DUSE_QT6=ON \
+ -DUSE_QT5=OFF
cmake --build build
}