summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD32
-rw-r--r--pillow-import.patch16
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e5d5d494041
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = flacsync
+ pkgdesc = Recursively mirror a directory tree of FLAC audio files to AAC/OGG
+ pkgver = 0.3.2
+ pkgrel = 4
+ url = https://github.com/cmcginty/flacsync
+ arch = any
+ license = GPL
+ makedepends = python2-distribute
+ depends = python2
+ depends = python-imaging
+ depends = mutagen
+ depends = flac
+ optdepends = neroaacenc: AAC encoding
+ optdepends = neroaactag: AAC tagging
+ optdepends = vorbis-tools: OGG Vorbis encoding and tagging
+ optdepends = lame: MP3 encoding
+ source = https://github.com/cmcginty/flacsync/raw/master/dist/flacsync-0.3.2.tar.gz
+ source = pillow-import.patch
+ md5sums = 0985d3d00a28332734c286b7b6fda537
+ md5sums = 1840daf694b5ad95e91d3012317a0897
+ sha1sums = 8faecca0e5eb0c2f9d0ccd4be7b79148944df482
+ sha1sums = 3470ce6caa45abd854c0427c12e5fd844bbd84a7
+
+pkgname = flacsync
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3403cc5d0b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Constributor: intel <intel@ss4200>
+# Maintainer: Simon Legner <Simon.Legner@gmail.com>
+pkgname=flacsync
+pkgver=0.3.2
+pkgrel=4
+pkgdesc="Recursively mirror a directory tree of FLAC audio files to AAC/OGG"
+url="https://github.com/cmcginty/flacsync"
+arch=('any')
+license=('GPL')
+depends=('python2' 'python-imaging' 'mutagen' 'flac')
+makedepends=('python2-distribute')
+optdepends=('neroaacenc: AAC encoding'
+ 'neroaactag: AAC tagging'
+ 'vorbis-tools: OGG Vorbis encoding and tagging'
+ 'lame: MP3 encoding'
+)
+source=(https://github.com/cmcginty/flacsync/raw/master/dist/$pkgname-$pkgver.tar.gz pillow-import.patch)
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 < $srcdir/pillow-import.patch
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root=$pkgdir/ --optimize=1
+}
+
+sha1sums=('8faecca0e5eb0c2f9d0ccd4be7b79148944df482'
+ '3470ce6caa45abd854c0427c12e5fd844bbd84a7')
+md5sums=('0985d3d00a28332734c286b7b6fda537'
+ '1840daf694b5ad95e91d3012317a0897')
diff --git a/pillow-import.patch b/pillow-import.patch
new file mode 100644
index 000000000000..a910c47fc1e8
--- /dev/null
+++ b/pillow-import.patch
@@ -0,0 +1,16 @@
+diff --git a/flacsync/encoder.py b/flacsync/encoder.py
+index afdffc3..9822346 100644
+--- a/flacsync/encoder.py
++++ b/flacsync/encoder.py
+@@ -15,7 +15,10 @@ import os
+ import shutil
+ import subprocess as sp
+ import tempfile
+-import Image
++try:
++ import Image
++except ImportError:
++ import PIL.Image as Image
+
+ from . import util
+