summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e77fc106228
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = flap
+ pkgdesc = An XCB based window geometry tool with support for relative/per-monitor positioning and resizing.
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/shizy/flap
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = libxcb
+ source = https://github.com/shizy/flap/archive/1.1.tar.gz
+ md5sums = SKIP
+
+pkgname = flap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45e3be1c3061
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: shizy <shizukesa4 at gmail dot com>
+pkgname=flap
+pkgver=1.1
+pkgrel=1
+pkgdesc='An XCB based window geometry tool with support for relative/per-monitor positioning and resizing.'
+arch=('x86_64')
+url=https://github.com/shizy/flap
+license=('MIT')
+depends=('libxcb')
+makedepends=('git')
+source=("https://github.com/shizy/flap/archive/${pkgver}.tar.gz")
+md5sums=('SKIP')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ echo "$pkgdir"
+ cd "${pkgname}-${pkgver}"
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
+}