summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5502c63c580c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = flatpak-xdg-utils-git
+ pkgdesc = Utilities for containerized apps to launch programs outside the container
+ pkgver = 1.0.1.r7.g4fdd2e2
+ pkgrel = 1
+ url = https://github.com/flatpak/flatpak-xdg-utils
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv7h
+ arch = armv6h
+ arch = aarch64
+ license = GPL
+ source = git+https://github.com/flatpak/flatpak-xdg-utils.git
+ sha256sums = SKIP
+
+pkgname = flatpak-xdg-utils-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e5e507b4059f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+flatpak-xdg-utils/
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8883d09db494
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Devin Bayer <dev@doubly.so>
+pkgname=flatpak-xdg-utils-git
+pkgver=1.0.1.r7.g4fdd2e2
+pkgrel=1
+pkgdesc="Utilities for containerized apps to launch programs outside the container"
+arch=('i686' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
+url="https://github.com/flatpak/flatpak-xdg-utils"
+license=('GPL')
+depends=()
+makedepends=()
+source=('git+https://github.com/flatpak/flatpak-xdg-utils.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/flatpak-xdg-utils"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ meson --prefix /usr \
+ --buildtype=plain \
+ --bindir=/usr/libexec/flatpak-xdg-utils \
+ -Dinstalled_tests=true \
+ "$srcdir/flatpak-xdg-utils" build
+
+ ninja -Cbuild
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -Cbuild install
+ mkdir -p $pkgdir/usr/bin
+ ln -s /usr/libexec/flatpak-xdg-utils/flatpak-spawn $pkgdir/usr/bin/
+}