summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a32265aeaf7..bf240aa2a471 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = flexisip
pkgdesc = A general purpose SIP proxy with media capabilities
- pkgver = 2.0.0
+ pkgver = 2.0.3
pkgrel = 1
url = http://flexisip.org
install = flexisip.install
@@ -16,8 +16,8 @@ pkgbase = flexisip
depends = soci
depends = sofia-sip-bc>=1.13.41bc
depends = xerces-c
- source = flexisip-2.0.0.tar.gz::https://github.com/BelledonneCommunications/flexisip/archive/2.0.0-beta.tar.gz
- sha256sums = 679ce09120143a4dc363a38e9e41bd469a8ac589867b7d233d9fb0b036107092
+ source = flexisip-2.0.3.tar.gz::https://github.com/BelledonneCommunications/flexisip/archive/2.0.3.tar.gz
+ sha256sums = fba32d04aeb0ba4d5078199e3d0a75fe7357cb3cadb571dc032918730f34015a
pkgname = flexisip
diff --git a/PKGBUILD b/PKGBUILD
index a8578fbd3fb8..f27f708018f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,34 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=flexisip
-pkgver=2.0.0
+pkgver=2.0.3
pkgrel=1
pkgdesc="A general purpose SIP proxy with media capabilities"
arch=('x86_64')
url="http://flexisip.org"
license=('AGPL3')
groups=()
-depends=('belle-sip>=4.3' 'belr' 'hiredis' 'mediastreamer>=4.3' 'protobuf' 'soci' 'sofia-sip-bc>=1.13.41bc' 'xerces-c')
+depends=('bctoolbox' 'belle-sip>=4.3' 'belr' 'hiredis' 'liblinphone' 'mediastreamer>=4.3' 'protobuf' 'soci' 'sofia-sip-bc>=1.13.41bc' 'xerces-c')
makedepends=('cmake' 'xsd')
install='flexisip.install'
-source=("flexisip-$pkgver.tar.gz::https://github.com/BelledonneCommunications/flexisip/archive/$pkgver-beta.tar.gz")
+source=("flexisip-$pkgver.tar.gz::https://github.com/BelledonneCommunications/flexisip/archive/$pkgver.tar.gz")
noextract=()
-sha256sums=('679ce09120143a4dc363a38e9e41bd469a8ac589867b7d233d9fb0b036107092')
+sha256sums=('fba32d04aeb0ba4d5078199e3d0a75fe7357cb3cadb571dc032918730f34015a')
build() {
- cd "$pkgname-$pkgver-beta"
+ cd "$pkgname-$pkgver"
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DENABLE_REDIS=YES \
-DENABLE_PROTOBUF=YES \
- -DENABLE_PRESENCE=YES .
+ -DENABLE_PRESENCE=YES \
+ -DENABLE_CONFERENCE=YES .
make
}
package() {
- cd "$pkgname-$pkgver-beta"
+ cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
- for S in 'flexisip-presence' "flexisip-presence@" "flexisip-proxy" "flexisip-proxy@"; do
+ for S in flexisip-{presence,proxy,conference}{@,}; do
install -Dm0644 "scripts/$S.service" "$pkgdir/usr/lib/systemd/system/$S.service"
done;
}