summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
-rw-r--r--flexisip-presence.service12
-rw-r--r--flexisip.install12
-rw-r--r--flexisip.service11
5 files changed, 26 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 185186af9869..c44268226d4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = flexisip
pkgdesc = A general purpose SIP proxy with media capabilities
- pkgver = 1.0.10
- pkgrel = 4
+ pkgver = 1.0.12
+ pkgrel = 1
url = http://flexisip.org
- arch = i686
+ install = flexisip.install
arch = x86_64
license = AGPL3
makedepends = cmake
makedepends = git
depends = belle-sip-git
+ depends = belr
depends = hiredis
depends = mediastreamer-git
depends = ortp-git
@@ -17,12 +18,8 @@ pkgbase = flexisip
depends = sofia-sip-bc
depends = unixodbc
depends = xsd
- source = git+https://github.com/BelleDonneCommunications/flexisip.git#commit=d915601df292742c61b188d1184b376eabf47c83
- source = flexisip.service
- source = flexisip-presence.service
+ source = git+https://github.com/BelleDonneCommunications/flexisip.git
sha256sums = SKIP
- sha256sums = 5c16f7a064ad93d75b9bc4401a5c651ca303ff2b92452e86b9a53ef674db93e4
- sha256sums = 7f658cc393ef2feab587aaacc7cb62c1211620aa846c6b860c775272d698675c
pkgname = flexisip
diff --git a/PKGBUILD b/PKGBUILD
index e31909f2fa1d..92068d260eeb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,18 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=flexisip
-pkgver=1.0.10
-pkgrel=4
+pkgver=1.0.12
+pkgrel=1
pkgdesc="A general purpose SIP proxy with media capabilities"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://flexisip.org"
license=('AGPL3')
groups=()
-depends=('belle-sip-git' 'hiredis' 'mediastreamer-git' 'ortp-git' 'protobuf' 'soci' 'sofia-sip-bc' 'unixodbc' 'xsd')
+depends=('belle-sip-git' 'belr' 'hiredis' 'mediastreamer-git' 'ortp-git' 'protobuf' 'soci' 'sofia-sip-bc' 'unixodbc' 'xsd')
makedepends=('cmake' 'git')
-source=("git+https://github.com/BelleDonneCommunications/$pkgname.git#commit=d915601df292742c61b188d1184b376eabf47c83"
- "flexisip.service"
- "flexisip-presence.service")
+install='flexisip.install'
+source=("git+https://github.com/BelleDonneCommunications/$pkgname.git")
noextract=()
-sha256sums=('SKIP'
- '5c16f7a064ad93d75b9bc4401a5c651ca303ff2b92452e86b9a53ef674db93e4'
- '7f658cc393ef2feab587aaacc7cb62c1211620aa846c6b860c775272d698675c')
+sha256sums=('SKIP')
build() {
cd "$pkgname"
@@ -31,6 +28,6 @@ package() {
cd "$pkgname"
make DESTDIR="$pkgdir/" install
- install -Dm0644 "$srcdir/flexisip.service" "$pkgdir/usr/lib/systemd/system/flexisip.service"
- install -Dm0644 "$srcdir/flexisip-presence.service" "$pkgdir/usr/lib/systemd/system/flexisip.service"
+ install -Dm0644 "scripts/flexisip.service" "$pkgdir/usr/lib/systemd/system/flexisip.service"
+ install -Dm0644 "scripts/flexisip-presence.service" "$pkgdir/usr/lib/systemd/system/flexisip.service"
}
diff --git a/flexisip-presence.service b/flexisip-presence.service
deleted file mode 100644
index 92e23d655db7..000000000000
--- a/flexisip-presence.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=Flexisip presence server
-Documentation=http://www.linphone.org/technical-corner/flexisip/overview
-After=syslog.target network.service network.target redis.service mysqld.service
-
-[Service]
-Type=forking
-ExecStart=/usr/bin/flexisip --server presence --daemon --syslog --pidfile /run/flexisip-presence.pid
-
-[Install]
-WantedBy=multi-user.target
-
diff --git a/flexisip.install b/flexisip.install
new file mode 100644
index 000000000000..0397182b85cf
--- /dev/null
+++ b/flexisip.install
@@ -0,0 +1,12 @@
+post_upgrade() {
+ echo "
+In order to generate a default config file, you can use:
+
+mkdir -p /etc/flexisip
+flexisip --dump-all-default > /etc/flexisip/flexisip.conf
+"
+}
+
+post_install() {
+ post_upgrade
+}
diff --git a/flexisip.service b/flexisip.service
deleted file mode 100644
index f60024761147..000000000000
--- a/flexisip.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=Flexisip proxy server
-After=syslog.target network.service network.target redis.service mysqld.service
-
-[Service]
-Type=forking
-ExecStart=/usr/bin/flexisip --server proxy --daemon -p /run/flexisip.pid
-PIDFile=/run/flexisip.pid
-
-[Install]
-WantedBy=multi-user.target