summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--flexo.toml76
3 files changed, 3 insertions, 83 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1548b4bb87a..9a51131372d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = flexo-git
pkgdesc = A central pacman cache
- pkgver = 0.1.0.r61.gf75e159
+ pkgver = 0.1.0.r64.g64dfbc7
pkgrel = 1
url = https://github.com/nroi/flexo
install = flexo.install
@@ -18,12 +18,10 @@ pkgbase = flexo-git
source = sysuser.conf
source = flexo.install
source = flexo.service
- source = flexo.toml
sha256sums = SKIP
sha256sums = b6a618c66d3ffb9ad119b0497d2181cdd382ec870cc768606debed40716c1f4e
sha256sums = 662e8c6c4d024ec035c2c02d9298a8cb6062cfb30d02bfaecf17a9d3d9b35167
sha256sums = 0ba13ff1d92b51433635e1fbf5f1017e3e06b3e408be663acb1fbf65f344a3ad
- sha256sums = b1ec4badc2088ed46230dad406d44130089ff00a1e98ff5d178d6f9e1eb0a98d
pkgname = flexo-git
diff --git a/PKGBUILD b/PKGBUILD
index 904ab6e9eeba..8ef3657de071 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: nroi <nroi@mailbox.org>
pkgname=flexo-git
pkgrel=1
-pkgver=0.1.0.r61.gf75e159
+pkgver=1.0.6.r4.g95d4407
pkgdesc="A central pacman cache"
# TODO we haven't tested yet if this package can be built on ARM architectures.
arch=('x86_64' 'armv6h' 'armv7h' 'aarch64')
@@ -16,13 +16,11 @@ source=('git+https://github.com/nroi/flexo.git'
'sysuser.conf'
'flexo.install'
'flexo.service'
- 'flexo.toml'
)
sha256sums=('SKIP'
'b6a618c66d3ffb9ad119b0497d2181cdd382ec870cc768606debed40716c1f4e'
'662e8c6c4d024ec035c2c02d9298a8cb6062cfb30d02bfaecf17a9d3d9b35167'
'0ba13ff1d92b51433635e1fbf5f1017e3e06b3e408be663acb1fbf65f344a3ad'
- 'b1ec4badc2088ed46230dad406d44130089ff00a1e98ff5d178d6f9e1eb0a98d'
)
build() {
@@ -41,6 +39,6 @@ package() {
install -Dm644 "${pkgname%-git}/LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 "${srcdir}/flexo.service" "${pkgdir}/usr/lib/systemd/system/flexo.service"
install -Dm644 "${srcdir}/sysuser.conf" "${pkgdir}/usr/lib/sysusers.d/flexo.conf"
- install -Dm644 "${srcdir}/flexo.toml" "$pkgdir/etc/flexo/flexo.toml"
+ install -Dm644 "${pkgname%-git}/${pkgname%-git}/conf/flexo.toml" "$pkgdir/etc/flexo/flexo.toml"
install -Dm755 "${pkgname%-git}/${pkgname%-git}/target/release/flexo" "$pkgdir/usr/bin/flexo"
}
diff --git a/flexo.toml b/flexo.toml
deleted file mode 100644
index 8d442bcbfb9f..000000000000
--- a/flexo.toml
+++ /dev/null
@@ -1,76 +0,0 @@
-# Note that flexo relies on the directory structure that is created in
-# /var/cache/flexo during install. If you change this setting, copy the
-# contents to the new directory and make sure user flexo has read- and
-# write-access.
-cache_directory = "/var/cache/flexo/pkg"
-
-# After the mirrorlist was fetched from a remote JSON endpoint and the mirrors have
-# been tested and rated, the result (i.e., an ordered list of mirrors) will be persisted
-# on the local file system so that it can serve as a backup in case there is no internet
-# connectivity when flexo is started.
-mirrorlist_fallback_file = "/var/cache/flexo/state/mirrorlist"
-
-# The port to listen on.
-port = 7878
-
-# The selection method to choose a mirror. Valid values are:
-# "auto": Flexo will attempt to find suitable mirrors automatically.
-# With this method, performance tests are run on the official mirrors
-# to select only sufficiently fast mirrors.
-# "predefined": To only choose the mirrors defined for the variable
-# mirrors_predefined (see below).
-mirror_selection_method = "auto"
-
-
-# The meaning of this variable depends on the mirror_selection_method:
-# if mirror_selection_method = "auto", this list will be used as a fallback in
-# case flexo was not able to obtain a list of all official mirrors.
-# if mirror_selection_method = "predefined", flexo will only use mirrors from
-# this list.
-# This list must not be empty if mirror_selection_method has been set to "predefined".
-# Mirrors in this list should NOT include the $repo/os/$arch suffix, so you should add
-# something like "http://archlinux.mirror.org/" or "https://mirror.org/archlinux/".
-mirrors_predefined = []
-
-# Various settings that apply if mirror_selection_method has been set to "auto".
-[mirrors_auto]
- # The URI of the JSON endpoint that delivers information about all official mirrors.
- mirrors_status_json_endpoint = "https://www.archlinux.org/mirrors/status/json/"
- # The method to choose suitable mirrors automatically may not always work
- # perfectly. If one of the automatically chosen mirrors turns out to be slow or
- # unstable, add it to this list.
- mirrors_blacklist = [ ]
- # The maximum speed limit for all downloads. Leave it commented to allow
- # flexo to utilize all available bandwidth.
- # max_speed_limit = 102400
- # only use mirrors with HTTPS support.
- https_required = true
- # mirrors must support IPv4.
- ipv4 = true
- # mirrors must support IPv6. Notice that this setting does not force
- # connection establishment via IPv6, so having this setting enabled does not
- # cause any issues on IPv4-only clients.
- ipv6 = true
- # The maximum score allowed from a mirror. See
- # https://www.archlinux.org/mirrors/status/ for an explanation of this
- # metric.
- max_score = 2.5
- # The maximum number of mirrors to use and test for latency. Increasing this
- # number will also increase the startup time of flexo (due to the number of
- # latency tests), but it might also give you a faster mirror.
- num_mirrors = 8
- # Valid values for this setting include "sort" and "random". After the
- # mirrors have been filtered according to your chosen criteria (e.g. ipv6
- # supported, score not more than 2.5), you will most likely still have more
- # than num_mirrors mirrors. This setting determines the strategy for
- # choosing num_mirrors out of those mirrors. With "sort", the mirrors are
- # sorted by their score and the first num_mirrors mirrors are selected. With
- # "random", a random selection of num_mirrors are selected. Choose "sort"
- # if you want to increase the likelihood of having a fast and up-to-date
- # mirror. Choose "random" if you want to avoid to always use the same
- # mirror, and instead balance the load among many mirrors.
- mirrors_random_or_sort = "sort"
- # timeout, in milliseconds, when testing the mirrors' performance.
- # Mirros which exceed the timeout will not be considered further, regardless
- # of their score.
- timeout = 350