summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32ea3703952d..e994ca8c69ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
-# Generated by mksrcinfo v8
-# Sun Mar 5 14:41:25 UTC 2017
pkgbase = flicd
pkgdesc = Flic SDK for Linux
- pkgver = 0.4
- pkgrel = 4
+ pkgver = 2.0.3
+ pkgrel = 1
url = https://github.com/50ButtonsEach/fliclib-linux-hci
install = flicd.install
arch = i386
arch = x86_64
arch = armv6h
arch = armv6l
- arch = armv7l
arch = armv7h
+ arch = armv7l
+ arch = aarch64
license = unknown
- makedepends = make
backup = etc/flicd/db
- source = git+https://github.com/50ButtonsEach/fliclib-linux-hci#tag=0.4
+ source = git+https://github.com/50ButtonsEach/fliclib-linux-hci#tag=2.0.3
source = flicd.service
md5sums = SKIP
md5sums = 6144a880dd1975c63140f1754320812c
@@ -23,4 +21,3 @@ pkgbase = flicd
sha256sums = 89c7f1872e84eb87b4e02f331819fbd40dadfaa99a8a2d1e255f225c2b1c0617
pkgname = flicd
-
diff --git a/PKGBUILD b/PKGBUILD
index 2295099000e1..72225cf7d1fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
+# Maintainer: Jake Barnes <me+aur@jakebarn.es>
# Maintainer: Philipp Schmitt <philipp@schmitt.co>
-# GitHub: https://github.com/pschmitt/aur-flicd
pkgname=flicd
-pkgver=0.4
-pkgrel=4
+pkgver=2.0.3
+pkgrel=1
pkgdesc="Flic SDK for Linux"
-arch=('i386' 'x86_64' 'armv6h' 'armv6l' 'armv7l' 'armv7h')
+arch=('i386' 'x86_64' 'armv6h' 'armv6l' 'armv7h' 'armv7l' 'aarch64')
url="https://github.com/50ButtonsEach/fliclib-linux-hci"
license=('unknown')
-source=("git+https://github.com/50ButtonsEach/fliclib-linux-hci#tag=0.4"
+source=("git+https://github.com/50ButtonsEach/fliclib-linux-hci#tag=${pkgver}"
"flicd.service")
-makedepends=('make')
md5sums=('SKIP'
'6144a880dd1975c63140f1754320812c')
sha256sums=('SKIP'
@@ -25,7 +24,7 @@ build() {
package() {
local cpu_arch
case "$CARCH" in
- x86_64|i386)
+ x86_64|i386|aarch64)
cpu_arch="$CARCH" ;;
arm*)
cpu_arch=armv6l ;;
@@ -42,5 +41,3 @@ package() {
"${pkgdir}/usr/lib/systemd/system/flicd.service"
install -dDm 755 "${pkgdir}/etc/flicd"
}
-
-# vim:set ts=2 sw=2 et: