summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--010-flif-remove-apt-get-references.patch (renamed from flif-remove-apt-get-references-from-tools.patch)10
-rw-r--r--020-flif-fix-install.patch52
-rw-r--r--030-flif-use-arch-flags.patch26
-rw-r--r--LICENSE-CC0-1.0-Universal81
-rw-r--r--PKGBUILD49
-rw-r--r--flif-use-build-flags.patch48
7 files changed, 204 insertions, 90 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76b2bf991ac8..bb793c3482c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,28 @@
pkgbase = flif
pkgdesc = Free Lossless Image Format
- pkgver = 0.3
- pkgrel = 6
+ pkgver = 0.4
+ pkgrel = 1
url = https://github.com/FLIF-hub/FLIF/
arch = x86_64
license = LGPL3
license = Apache
- depends = gcc-libs
+ license = custom: CC0 1.0 Universal
+ makedepends = gdk-pixbuf2
+ makedepends = sdl2
depends = libpng
- depends = sdl2
+ optdepends = gdk-pixbuf2: for gdk-pixbuf loader
optdepends = imagemagick: for gif2flif tool
+ optdepends = sdl2: for viewflif tool
optdepends = apng-utils: for apng2flif tool
- source = flif-0.3.tar.gz::https://github.com/FLIF-hub/FLIF/archive/v0.3.tar.gz
- source = flif-use-build-flags.patch
- source = flif-remove-apt-get-references-from-tools.patch
- sha256sums = aa02a62974d78f8109cff21ecb6d805f1d23b05b2db7189cfdf1f0d97ff89498
- sha256sums = d8cdb93f4f1e63487d65d23c1c96bf79acff1277532cbcfd88ca05932655d871
- sha256sums = c516d92d4724e319af79bb1ac5d3dde81dac359fd4a02af1ee71239a49d58710
+ source = https://github.com/FLIF-hub/FLIF/archive/v0.4/flif-0.4.tar.gz
+ source = LICENSE-CC0-1.0-Universal
+ source = 010-flif-remove-apt-get-references.patch
+ source = 020-flif-fix-install.patch
+ source = 030-flif-use-arch-flags.patch
+ sha256sums = cc98313ef0dbfef65d72bc21f730edf2a97a414f14bd73ad424368ce032fdb7f
+ sha256sums = 9b99bfef33dc330e756e48d28be6c8470ac4fc5c2802bdb20dc9f4929a169abc
+ sha256sums = 4ee963275d0559b470f5869fe6effb76f11517dc98334d12a4d0f150ecd95b65
+ sha256sums = 7b72dec66d1bbb04597c37ac1715378609efc5076af8d3fffe296b3561ab334d
+ sha256sums = b7118224eedf510b215ba71e5c67744aa6616ac1baa854e09705e859772aff24
pkgname = flif
-
diff --git a/flif-remove-apt-get-references-from-tools.patch b/010-flif-remove-apt-get-references.patch
index 50430beabf13..a74e76363a6b 100644
--- a/flif-remove-apt-get-references-from-tools.patch
+++ b/010-flif-remove-apt-get-references.patch
@@ -1,6 +1,5 @@
-diff -Naurp a/tools/apng2flif b/tools/apng2flif
---- a/tools/apng2flif 2017-04-28 15:46:54.000000000 +0000
-+++ b/tools/apng2flif 2019-03-05 15:42:29.000000000 +0000
+--- a/tools/apng2flif
++++ b/tools/apng2flif
@@ -13,7 +13,6 @@ fi
if ! $APNGDIS 2>/dev/null |grep -q APNG
then
@@ -9,9 +8,8 @@ diff -Naurp a/tools/apng2flif b/tools/apng2flif
exit 1
fi
-diff -Naurp a/tools/gif2flif b/tools/gif2flif
---- a/tools/gif2flif 2017-04-28 15:46:54.000000000 +0000
-+++ b/tools/gif2flif 2019-03-05 15:42:29.000000000 +0000
+--- a/tools/gif2flif
++++ b/tools/gif2flif
@@ -13,7 +13,6 @@ fi
if ! $CONVERT -version 2>/dev/null >/dev/null
then
diff --git a/020-flif-fix-install.patch b/020-flif-fix-install.patch
new file mode 100644
index 000000000000..a31199e3f084
--- /dev/null
+++ b/020-flif-fix-install.patch
@@ -0,0 +1,52 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -77,29 +77,24 @@ pixbufloader: libpixbufloader-flif$(LIBE
+
+ install: flif libflif$(LIBEXT) install-libflif$(LIBEXT)
+ install -d $(PREFIX)/bin $(PREFIX)/share/man/man1
+- install -m 755 flif $(PREFIX)/bin
+- strip -x $(PREFIX)/bin/flif
++ install -m 755 -D flif -t $(PREFIX)/bin
+ install -m 644 ../doc/flif.1 $(PREFIX)/share/man/man1
+- install -m 755 ../tools/gif2flif $(PREFIX)/bin
+- install -m 755 ../tools/apng2flif $(PREFIX)/bin
++ install -m 755 -D ../tools/gif2flif -t $(PREFIX)/bin
++ install -m 755 -D ../tools/apng2flif -t $(PREFIX)/bin
+
+ install-viewflif:
+- install -m 755 viewflif $(PREFIX)/bin
+- strip -x $(PREFIX)/bin/viewflif
++ install -m 755 -D viewflif -t $(PREFIX)/bin
+
+ install-libflif$(LIBEXT): libflif$(LIBEXT)
+ install -d $(PREFIX)/lib
+ install -m 755 libflif$(LIBEXT) libflif$(LIBEXTV) $(PREFIX)/lib
+- strip -x $(PREFIX)/lib/libflif$(LIBEXT) \
+- $(PREFIX)/lib/libflif$(LIBEXTV)
+
+ # There is no prefix here because gdk-pixbuf will not search /usr/local for loadrs
+ # while it sucks, it's the truth
+ install-libpixbufloader-flif$(LIBEXT): libpixbufloader-flif$(LIBEXT) install-libflif$(LIBEXT)
+- install -c -d /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders
+- install -c -m 755 -s libpixbufloader-flif$(LIBEXT) /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/
+- gdk-pixbuf-query-loaders --update-cache
+- xdg-mime install --novendor flif-mime.xml
++ install -c -d $(PREFIX)/lib/gdk-pixbuf-2.0/2.10.0/loaders
++ install -c -m 755 -s libpixbufloader-flif$(LIBEXT) $(PREFIX)/lib/gdk-pixbuf-2.0/2.10.0/loaders/
++ install -m 644 -D flif-mime.xml -t $(PREFIX)/share/mime/packages
+
+ install-pixbufloader: install-libpixbufloader-flif$(LIBEXT)
+
+@@ -108,11 +103,8 @@ install-dev:
+ install -m 644 library/*.h $(PREFIX)/include
+
+ install-decoder: decoder
+- install -m 755 dflif $(PREFIX)/bin
+- strip -x $(PREFIX)/bin/dflif
++ install -m 755 -D dflif -t $(PREFIX)/bin
+ install -m 755 libflif_dec$(LIBEXT) libflif_dec$(LIBEXTV) $(PREFIX)/lib
+- strip -x $(PREFIX)/lib/libflif_dec$(LIBEXT) \
+- $(PREFIX)/lib/libflif_dec$(LIBEXTV)
+
+ magic:
+ if ! grep -q FLIF /etc/magic; then cat ../doc/flif.magic >> /etc/magic; fi
diff --git a/030-flif-use-arch-flags.patch b/030-flif-use-arch-flags.patch
new file mode 100644
index 000000000000..5e9f49930f87
--- /dev/null
+++ b/030-flif-use-arch-flags.patch
@@ -0,0 +1,26 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -46,12 +46,12 @@ flif: $(FILES_O) flif.o
+
+ # Command-line FLIF decoding tool - Apache2 (not built by default)
+ dflif: $(FILES_H) libflif_dec$(LIBEXT) flif.cpp
+- $(CXX) -std=gnu++11 $(CXXFLAGS) $(OPTIMIZATIONS) -DDECODER_ONLY -g0 -Wall flif.cpp $(LDFLAGS) -L. -lflif_dec -o dflif
++ $(CXX) -std=gnu++11 $(CXXFLAGS) $(CPPFLAGS) $(OPTIMIZATIONS) -DDECODER_ONLY -g0 -Wall flif.cpp $(LDFLAGS) -L. -lflif_dec -o dflif
+
+ # Decoder-only library - Apache2 (not built by default)
+ libflif_dec$(LIBEXT): $(FILES_H) $(FILES_CPP) library/flif_dec.h library/flif-interface-private_dec.hpp library/flif-interface_dec.cpp
+ echo $(OS)
+- $(CXX) -std=gnu++11 $(CXXFLAGS) $(LIB_OPTIMIZATIONS) -DDECODER_ONLY -g0 -Wall -shared -fPIC $(FILES_CPP) library/flif-interface_dec.cpp $(LDFLAGS) -Wl,$(SONAME),libflif_dec$(LIBEXTV) -o libflif_dec$(LIBEXTV)
++ $(CXX) -std=gnu++11 $(CXXFLAGS) $(CPPFLAGS) $(LIB_OPTIMIZATIONS) -DDECODER_ONLY -g0 -Wall -shared -fPIC $(FILES_CPP) library/flif-interface_dec.cpp $(LDFLAGS) -Wl,$(SONAME),libflif_dec$(LIBEXTV) -o libflif_dec$(LIBEXTV)
+ ln -sf libflif_dec$(LIBEXTV) libflif_dec$(LIBEXT)
+
+ # Decoder + encoder library - LGPL
+@@ -71,7 +71,7 @@ viewflif: libflif$(LIBEXT) viewflif.c
+ # The loader is LGPLed so there's no reason to use libflif_dec here
+ # -Werror=implicit-function-declaration is useful here to check for preprocessor dependency errors
+ libpixbufloader-flif$(LIBEXT): libflif$(LIBEXT) flif-pixbuf-loader.c
+- $(CC) -shared $(CFLAGS) -Ilibrary/ -fPIC -Wall -Werror=implicit-function-declaration $(shell pkg-config --cflags gdk-pixbuf-2.0) -o libpixbufloader-flif$(LIBEXT) flif-pixbuf-loader.c $(LDFLAGS) $(shell pkg-config --libs gdk-pixbuf-2.0) -L. -lflif
++ $(CC) -shared $(CFLAGS) $(CPPFLAGS) -Ilibrary/ -fPIC -Wall -Werror=implicit-function-declaration $(shell pkg-config --cflags gdk-pixbuf-2.0) -o libpixbufloader-flif$(LIBEXT) flif-pixbuf-loader.c $(LDFLAGS) $(shell pkg-config --libs gdk-pixbuf-2.0) -L. -lflif
+
+ pixbufloader: libpixbufloader-flif$(LIBEXT)
+
diff --git a/LICENSE-CC0-1.0-Universal b/LICENSE-CC0-1.0-Universal
new file mode 100644
index 000000000000..6bd3b99b469b
--- /dev/null
+++ b/LICENSE-CC0-1.0-Universal
@@ -0,0 +1,81 @@
+ Creative Commons Legal Code
+ CC0 1.0 Universal
+
+Statement of Purpose
+The laws of most jurisdictions throughout the world automatically confer exclusive Copyright and Related
+Rights (defined below) upon the creator and subsequent owner(s) (each and all, an "owner") of an original
+work of authorship and/or a database (each, a "Work").
+
+Certain owners wish to permanently relinquish those rights to a Work for the purpose of contributing to a
+commons of creative, cultural and scientific works ("Commons") that the public can reliably and without
+fear of later claims of infringement build upon, modify, incorporate in other works, reuse and redistribute
+as freely as possible in any form whatsoever and for any purposes, including without limitation
+commercial purposes. These owners may contribute to the Commons to promote the ideal of a free
+culture and the further production of creative, cultural and scientific works, or to gain reputation or greater
+distribution for their Work in part through the use and efforts of others.
+
+For these and/or other purposes and motivations, and without any expectation of additional consideration
+or compensation, the person associating CC0 with a Work (the "Affirmer"), to the extent that he or she is
+an owner of Copyright and Related Rights in the Work, voluntarily elects to apply CC0 to the Work and
+publicly distribute the Work under its terms, with knowledge of his or her Copyright and Related Rights in
+the Work and the meaning and intended legal effect of CC0 on those rights.
+
+1. Copyright and Related Rights. A Work made available under CC0 may be protected by copyright and
+related or neighboring rights ("Copyright and Related Rights"). Copyright and Related Rights include, but
+are not limited to, the following:
+
+ i.the right to reproduce, adapt, distribute, perform, display, communicate, and translate a Work;
+ ii.moral rights retained by the original author(s) and/or performer(s);
+ iii.publicity and privacy rights pertaining to a person's image or likeness depicted in a Work;
+ iv. rights protecting against unfair competition in regards to a Work, subject to the limitations in
+ paragraph 4(a), below;
+ v. rights protecting the extraction, dissemination, use and reuse of data in a Work;
+ vi. database rights (such as those arising under Directive 96/9/EC of the European Parliament and of
+ the Council of 11 March 1996 on the legal protection of databases, and under any national
+ implementation thereof, including any amended or successor version of such directive); and
+ vii. other similar, equivalent or corresponding rights throughout the world based on applicable law or
+ treaty, and any national implementations thereof.
+
+2. Waiver. To the greatest extent permitted by, but not in contravention of, applicable law, Affirmer hereby
+overtly, fully, permanently, irrevocably and unconditionally waives, abandons, and surrenders all of
+Affirmer's Copyright and Related Rights and associated claims and causes of action, whether now known
+or unknown (including existing as well as future claims and causes of action), in the Work (i) in all
+territories worldwide, (ii) for the maximum duration provided by applicable law or treaty (including future
+time extensions), (iii) in any current or future medium and for any number of copies, and (iv) for any
+purpose whatsoever, including without limitation commercial, advertising or promotional purposes (the
+"Waiver"). Affirmer makes the Waiver for the benefit of each member of the public at large and to the
+detriment of Affirmer's heirs and successors, fully intending that such Waiver shall not be subject to
+ revocation, rescission, cancellation, termination, or any other legal or equitable action to disrupt the quiet
+enjoyment of the Work by the public as contemplated by Affirmer's express Statement of Purpose.
+
+3. Public License Fallback. Should any part of the Waiver for any reason be judged legally invalid or
+ineffective under applicable law, then the Waiver shall be preserved to the maximum extent permitted
+taking into account Affirmer's express Statement of Purpose. In addition, to the extent the Waiver is so
+judged Affirmer hereby grants to each affected person a royalty-free, non transferable, non sublicensable,
+non exclusive, irrevocable and unconditional license to exercise Affirmer's Copyright and Related Rights
+in the Work (i) in all territories worldwide, (ii) for the maximum duration provided by applicable law or
+treaty (including future time extensions), (iii) in any current or future medium and for any number of
+copies, and (iv) for any purpose whatsoever, including without limitation commercial, advertising or
+promotional purposes (the "License"). The License shall be deemed effective as of the date CC0 was
+applied by Affirmer to the Work. Should any part of the License for any reason be judged legally invalid or
+ineffective under applicable law, such partial invalidity or ineffectiveness shall not invalidate the remainder
+of the License, and in such case Affirmer hereby affirms that he or she will not (i) exercise any of his or
+her remaining Copyright and Related Rights in the Work or (ii) assert any associated claims and causes
+of action with respect to the Work, in either case contrary to Affirmer's express Statement of Purpose.
+
+4. Limitations and Disclaimers.
+
+ a. No trademark or patent rights held by Affirmer are waived, abandoned, surrendered, licensed or
+ otherwise affected by this document.
+ b. Affirmer offers the Work as-is and makes no representations or warranties of any kind concerning
+ the Work, express, implied, statutory or otherwise, including without limitation warranties of title,
+ merchantability, fitness for a particular purpose, non infringement, or the absence of latent or other
+ defects, accuracy, or the present or absence of errors, whether or not discoverable, all to the
+ greatest extent permissible under applicable law.
+ c. Affirmer disclaims responsibility for clearing rights of other persons that may apply to the Work or
+ any use thereof, including without limitation any person's Copyright and Related Rights in the
+ Work. Further, Affirmer disclaims responsibility for obtaining any necessary consents, permissions
+ or other rights required for any use of the Work.
+ d. Affirmer understands and acknowledges that Creative Commons is not a party to this document
+ and has no duty or obligation with respect to this CC0 or use of the Work.
+
diff --git a/PKGBUILD b/PKGBUILD
index 7f4edecf5e24..aa6ad7cbfc91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,42 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer : Daniel Bermond <dbermond@archlinux.org>
# Contributor: John Jenkins <twodopeshaggy@gmail.com>
pkgname=flif
-pkgver=0.3
-pkgrel=6
+pkgver=0.4
+pkgrel=1
pkgdesc='Free Lossless Image Format'
arch=('x86_64')
url='https://github.com/FLIF-hub/FLIF/'
-license=('LGPL3' 'Apache')
-depends=('gcc-libs' 'libpng' 'sdl2')
+license=('LGPL3' 'Apache' 'custom: CC0 1.0 Universal')
+depends=('libpng')
optdepends=(
# official repositories:
+ 'gdk-pixbuf2: for gdk-pixbuf loader'
'imagemagick: for gif2flif tool'
+ 'sdl2: for viewflif tool'
# AUR:
'apng-utils: for apng2flif tool'
)
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/FLIF-hub/FLIF/archive/v${pkgver}.tar.gz"
- 'flif-use-build-flags.patch'
- 'flif-remove-apt-get-references-from-tools.patch')
-sha256sums=('aa02a62974d78f8109cff21ecb6d805f1d23b05b2db7189cfdf1f0d97ff89498'
- 'd8cdb93f4f1e63487d65d23c1c96bf79acff1277532cbcfd88ca05932655d871'
- 'c516d92d4724e319af79bb1ac5d3dde81dac359fd4a02af1ee71239a49d58710')
+makedepends=('gdk-pixbuf2' 'sdl2')
+source=("https://github.com/FLIF-hub/FLIF/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ 'LICENSE-CC0-1.0-Universal'
+ '010-flif-remove-apt-get-references.patch'
+ '020-flif-fix-install.patch'
+ '030-flif-use-arch-flags.patch')
+sha256sums=('cc98313ef0dbfef65d72bc21f730edf2a97a414f14bd73ad424368ce032fdb7f'
+ '9b99bfef33dc330e756e48d28be6c8470ac4fc5c2802bdb20dc9f4929a169abc'
+ '4ee963275d0559b470f5869fe6effb76f11517dc98334d12a4d0f150ecd95b65'
+ '7b72dec66d1bbb04597c37ac1715378609efc5076af8d3fffe296b3561ab334d'
+ 'b7118224eedf510b215ba71e5c67744aa6616ac1baa854e09705e859772aff24')
prepare() {
- cd "FLIF-${pkgver}"
-
- # use build flags
- patch -Np1 -i "${srcdir}/flif-use-build-flags.patch"
-
- # remove apt-get references from installed tools
- patch -Np1 -i "${srcdir}/flif-remove-apt-get-references-from-tools.patch"
+ patch -d "FLIF-${pkgver}" -Np1 -i "${srcdir}/010-flif-remove-apt-get-references.patch"
+ patch -d "FLIF-${pkgver}" -Np1 -i "${srcdir}/020-flif-fix-install.patch"
+ patch -d "FLIF-${pkgver}" -Np1 -i "${srcdir}/030-flif-use-arch-flags.patch"
}
build() {
- cd "FLIF-${pkgver}/src"
-
- make all decoder viewflif test-interface
-
+ make -C "FLIF-${pkgver}/src" all decoder viewflif pixbufloader test-interface
}
check() {
@@ -56,7 +56,6 @@ check() {
}
package() {
- cd "FLIF-${pkgver}/src"
-
- make PREFIX="${pkgdir}/usr" install{,-dev,-decoder,-viewflif}
+ make -C "FLIF-${pkgver}/src" PREFIX="${pkgdir}/usr" install{,-dev,-decoder,-viewflif,-pixbufloader}
+ install -D -m644 LICENSE-CC0-1.0-Universal -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
diff --git a/flif-use-build-flags.patch b/flif-use-build-flags.patch
deleted file mode 100644
index f4dc1331d357..000000000000
--- a/flif-use-build-flags.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff -Naurp a/src/Makefile b/src/Makefile
---- a/src/Makefile 2017-04-28 15:46:54.000000000 +0000
-+++ b/src/Makefile 2018-09-13 18:37:05.277277156 +0000
-@@ -1,6 +1,6 @@
- PREFIX := $(DESTDIR)/usr/local
--CXXFLAGS := $(shell pkg-config --cflags zlib libpng) -DLODEPNG_NO_COMPILE_PNG -DLODEPNG_NO_COMPILE_DISK
--LDFLAGS := $(shell pkg-config --libs libpng)
-+CXXFLAGS := $(CXXFLAGS) $(shell pkg-config --cflags zlib libpng) -DLODEPNG_NO_COMPILE_PNG -DLODEPNG_NO_COMPILE_DISK
-+LDFLAGS := $(LDFLAGS) $(shell pkg-config --libs libpng)
-
- OSNAME := $(shell uname -s)
- SONAME = -soname
-@@ -14,7 +14,7 @@ ifeq ($(OSNAME),Darwin)
- endif
-
- # for running interface-test
--export LD_LIBRARY_PATH=$(shell pwd):/usr/local/lib:$LD_LIBRARY_PATH
-+export LD_LIBRARY_PATH := $(shell pwd):/usr/local/lib:$(LD_LIBRARY_PATH)
-
- FILES_H := maniac/*.hpp maniac/*.cpp image/*.hpp transform/*.hpp flif-enc.hpp flif-dec.hpp common.hpp flif_config.h fileio.hpp io.hpp io.cpp config.h compiler-specific.hpp ../extern/lodepng.h
- FILES_CPP := maniac/chance.cpp maniac/symbol.cpp image/crc32k.cpp image/image.cpp image/image-png.cpp image/image-pnm.cpp image/image-pam.cpp image/image-rggb.cpp image/image-metadata.cpp image/color_range.cpp transform/factory.cpp common.cpp flif-enc.cpp flif-dec.cpp io.cpp ../extern/lodepng.cpp
-@@ -36,7 +36,7 @@ endif
-
- # Command-line FLIF encoding/decoding tool - LGPLv3
- flif: $(FILES_H) $(FILES_CPP) flif.cpp
-- $(CXX) -std=gnu++11 $(CXXFLAGS) $(OPTIMIZATIONS) -g0 -Wall $(FILES_CPP) flif.cpp $(LDFLAGS) -o flif
-+ $(CXX) -std=gnu++11 $(CXXFLAGS) $(CPPFLAGS) $(OPTIMIZATIONS) -g0 -Wall $(FILES_CPP) flif.cpp $(LDFLAGS) -o flif
-
- # Command-line FLIF decoding tool - Apache2 (not built by default)
- dflif: $(FILES_H) $(FILES_CPP) flif.cpp
-@@ -50,7 +50,7 @@ libflif_dec$(LIBEXT): $(FILES_H) $(FILES
-
- # Decoder + encoder library - LGPL
- libflif$(LIBEXT): $(FILES_H) $(FILES_CPP) library/*.h library/*.hpp library/*.cpp
-- $(CXX) -std=gnu++11 $(CXXFLAGS) $(LIB_OPTIMIZATIONS) -g0 -Wall -shared -fPIC $(FILES_CPP) library/flif-interface.cpp $(LDFLAGS) -Wl,$(SONAME),libflif$(LIBEXTV) -o libflif$(LIBEXTV)
-+ $(CXX) -std=gnu++11 $(CPPFLAGS) $(CXXFLAGS) $(LIB_OPTIMIZATIONS) -g0 -Wall -shared -fPIC $(FILES_CPP) library/flif-interface.cpp $(LDFLAGS) -Wl,$(SONAME),libflif$(LIBEXTV) -o libflif$(LIBEXTV)
- ln -sf libflif$(LIBEXTV) libflif$(LIBEXT)
-
- libflif.dbg$(LIBEXT): $(FILES_H) $(FILES_CPP) library/*.h library/*.hpp library/*.cpp
-@@ -59,7 +59,7 @@ libflif.dbg$(LIBEXT): $(FILES_H) $(FILES
-
- # Example application: simple FLIF viewer - public domain
- viewflif: libflif$(LIBEXT) viewflif.c
-- $(CC) -std=gnu11 -O3 -ggdb3 $(shell sdl2-config --cflags) -Wall -Ilibrary/ viewflif.c -L. -lflif $(shell sdl2-config --libs) -o viewflif
-+ $(CC) -std=gnu11 $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) -O3 -ggdb3 $(shell sdl2-config --cflags) -Wall -Ilibrary/ viewflif.c -L. -lflif $(shell sdl2-config --libs) -o viewflif
-
-
- install: flif libflif$(LIBEXT)