summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD24
3 files changed, 26 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6aa9168b4028..ba95a5d6589d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
# Generated by mksrcinfo v8
-# Sun Jul 12 22:07:43 UTC 2020
+# Tue Nov 23 22:46:49 UTC 2021
pkgbase = flopoco
pkgdesc = A generator of arithmetic cores (Floating-Point Cores, but not only) for FPGAs (but not only)
- pkgver = 4.1.2
+ pkgver = 4.1.3
pkgrel = 1
- url = http://flopoco.gforge.inria.fr/
+ url = https://flopoco.gitlabpages.inria.fr/flopoco/
arch = any
license = custom
makedepends = cmake
makedepends = boost
+ makedepends = git
depends = mpfr
depends = mpfi
depends = sollya
depends = gsl
depends = fplll
depends = libxml2
- source = https://gforge.inria.fr/frs/download.php/file/37213/flopoco-4.1.2.tgz
- md5sums = 425013cf0063284c27e5038bfff51efb
+ source = git+https://gitlab.inria.fr/flopoco/flopoco.git#branch=version4
+ md5sums = SKIP
pkgname = flopoco
diff --git a/.gitignore b/.gitignore
index a549098c4cf6..bf9c411344ab 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,6 @@
+flopoco
+
src
pkg
@@ -7,4 +9,5 @@ pkg
*.tar
*.tgz
*.xz
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
index 3c685a9a1fa4..0773552db8c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,38 @@
+# Maintainer: Adrien Prost-Boucle <adrien.prost-boucle@laposte.net>
pkgname=flopoco
-pkgver=4.1.2
+pkgver=4.1.3
pkgrel=1
pkgdesc="A generator of arithmetic cores (Floating-Point Cores, but not only) for FPGAs (but not only)"
arch=('any')
-url="http://flopoco.gforge.inria.fr/"
+url="https://flopoco.gitlabpages.inria.fr/flopoco/"
license=('custom')
depends=('mpfr' 'mpfi' 'sollya' 'gsl' 'fplll' 'libxml2')
-makedepends=('cmake' 'boost')
+makedepends=('cmake' 'boost' 'git')
-source=(https://gforge.inria.fr/frs/download.php/file/37213/flopoco-4.1.2.tgz)
-md5sums=('425013cf0063284c27e5038bfff51efb')
+source=('git+https://gitlab.inria.fr/flopoco/flopoco.git#branch=version4')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/flopoco"
+
+ # Flopoco version, from file VERSION
+ _distver=`cat VERSION`
+
+ echo $_distver
+}
build() {
- cd "$pkgname-$pkgver"
+ cd "${srcdir}/flopoco"
cmake -DCMAKE_INSTALL_PREFIX=/usr
make
./flopoco BuildAutocomplete
}
package() {
- cd "$pkgname-$pkgver"
+ cd "${srcdir}/flopoco"
install -D ./flopoco $pkgdir/usr/bin/flopoco
install -D ./bin2fp $pkgdir/usr/bin/flopoco_bin2fp