summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD89
-rw-r--r--causal.json6
-rw-r--r--pkg.install7
-rw-r--r--web.json7
6 files changed, 151 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f08dea0b8267
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = flow-causal
+ pkgdesc = flow causal studio
+ pkgver = 0.1.0
+ pkgrel = 1
+ epoch = 0
+ url = https://github.com/RalphBariz/flow
+ install = pkg.install
+ arch = i685
+ arch = x86_64
+ groups = flow
+ license = GPL3
+ makedepends = dub
+ makedepends = unzip
+ depends = dub
+ source = flow-base.zip::https://github.com/RalphBariz/flow-base/archive/0.1.0.zip
+ source = flow-util.zip::https://github.com/RalphBariz/flow-util/archive/0.1.0.zip
+ source = flow-alien.zip::https://github.com/RalphBariz/flow-alien/archive/0.1.0.zip
+ source = flow-causal.zip::https://github.com/RalphBariz/flow-causal/archive/0.1.0.zip
+ source = web.json
+ source = causal.json
+ md5sums = 4405289e93df0e71fc00abf1ce104ea0
+ md5sums = edd89037b2300464df3176d0f249c32a
+ md5sums = eb81517aeff6f13be25d4f9352ea0f54
+ md5sums = e75d7530f3bc1fa17909e7bdaf86ade6
+ md5sums = b92fb60eac286af67f3d9c811ae5959a
+ md5sums = 60705357a2f2d74107f5570ff41ac2d0
+
+pkgname = flow-causal
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b73905529f23
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8dbde31a004d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,89 @@
+# Maintainer: Your Name ralph.bariz@gmail.com
+pkgname=flow-causal
+pkgver=0.1.0
+pkgrel=1
+epoch=0
+pkgdesc="flow causal studio"
+arch=('i685' 'x86_64')
+url="https://github.com/RalphBariz/flow"
+license=('GPL3')
+groups=('flow')
+depends=('dub')
+makedepends=('dub' 'unzip')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=pkg.install
+changelog=
+source=("flow-base.zip::https://github.com/RalphBariz/flow-base/archive/$pkgver.zip"
+ "flow-util.zip::https://github.com/RalphBariz/flow-util/archive/$pkgver.zip"
+ "flow-alien.zip::https://github.com/RalphBariz/flow-alien/archive/$pkgver.zip"
+ "flow-causal.zip::https://github.com/RalphBariz/flow-causal/archive/$pkgver.zip"
+ "web.json"
+ "causal.json")
+noextract=()
+md5sums=('4405289e93df0e71fc00abf1ce104ea0'
+ 'edd89037b2300464df3176d0f249c32a'
+ 'eb81517aeff6f13be25d4f9352ea0f54'
+ 'e75d7530f3bc1fa17909e7bdaf86ade6'
+ 'b92fb60eac286af67f3d9c811ae5959a'
+ '60705357a2f2d74107f5570ff41ac2d0')
+validpgpkeys=()
+
+#prepare() {
+# cd "$pkgname-$pkgver"
+# patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
+#}
+
+#build() {
+# cd "$pkgname-$pkgver"
+# ./configure --prefix=/usr
+# make
+#}
+
+#check() {
+# cd "$pkgname-$pkgver"
+# make -k check
+#}
+
+package() {
+ # creating configuration
+ mkdir -p $pkgdir/etc/flow-causal/
+ cp -fr *.json $pkgdir/etc/flow-causal/
+
+ # compiling libraries
+ mkdir -p dub
+ cd dub
+
+ unzip -o -qq ../flow-base.zip
+ dub add-local flow-base-$pkgver
+
+ unzip -o -qq ../flow-util.zip
+ dub add-local flow-util-$pkgver
+
+ unzip -o -qq ../flow-alien.zip
+ dub add-local flow-alien-$pkgver
+
+ cd ..
+
+ # compiling app
+ unzip -o -qq flow-causal.zip
+ cd flow-causal-$pkgver
+ dub build --build release
+ cd bin
+
+ # putting everything to the right place
+ mkdir -p $pkgdir/usr/share/flow-causal/
+ mkdir -p $pkgdir/usr/bin/
+ cp -fr public $pkgdir/usr/share/flow-causal/
+ cp -fr flow-causal $pkgdir/usr/bin/
+
+ # removing library registrations
+ dub remove-local ../../dub/flow-base-$pkgver
+ dub remove-local ../../dub/flow-util-$pkgver
+ dub remove-local ../../dub/flow-alien-$pkgver
+}
diff --git a/causal.json b/causal.json
new file mode 100644
index 000000000000..f2d323a6e5db
--- /dev/null
+++ b/causal.json
@@ -0,0 +1,6 @@
+{
+ "dataType": "flow.causal.causal.CausalConfig",
+ "descriptionMemoryUrl": "/home/flow/causal/memory/description",
+ "descriptionMemoryFormat": 1,
+ "domain": "causal"
+}
diff --git a/pkg.install b/pkg.install
new file mode 100644
index 000000000000..8781552d1301
--- /dev/null
+++ b/pkg.install
@@ -0,0 +1,7 @@
+post_install() {
+ useradd -d /home/flow -m -r -s /usr/bin/nologin flow
+}
+
+pre_remove() {
+ userdel flow
+}
diff --git a/web.json b/web.json
new file mode 100644
index 000000000000..9685e84d2536
--- /dev/null
+++ b/web.json
@@ -0,0 +1,7 @@
+{
+ "dataType": "flow.util.web.WebConfig",
+ "port": 1234,
+ "listenerAmount": 10,
+ "root": "/usr/share/flow-causal/public",
+ "domain": "causal"
+}