summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD30
-rw-r--r--std.diff30
3 files changed, 18 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc5cd54fe838..bfbbd7e88697 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = flowee
pkgdesc = Flowee provides the shortest path to Bitcoin Cash
- pkgver = 2022.04.1
+ pkgver = 2024.02.0
pkgrel = 1
url = https://flowee.org/
install = flowee.install
@@ -18,10 +18,10 @@ pkgbase = flowee
provides = flowee-libs
backup = etc/flowee/flowee.conf
backup = etc/flowee/rest-service.conf
- source = https://gitlab.com/FloweeTheHub/thehub/-/archive/2022.04.1/thehub-2022.04.1.tar.gz
+ source = https://codeberg.org/Flowee/thehub/archive/2024.02.0.tar.gz
source = flowee.logrotate
source = flowee.conf
- sha256sums = 9bb35450ad11cb43841b29f266e0a3539af9fec1b8f079b9be8931c55a6e5acd
+ sha256sums = 082099f919d50db756f0e912895e78f9d9cab1fef5f6580f35c0d4882007daa3
sha256sums = 0438e1a44523aeb3bbecd60fd920ca7b2aacd267b5cf988ab77a44eb7c03929e
sha256sums = 59c1928ddb33fed1d4bf35df8fecd1dbdda0b308eac943503a2e3afb8c64bc89
diff --git a/PKGBUILD b/PKGBUILD
index 3e8353acd7da..9a58871f06ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tom Zander
pkgname=flowee
-pkgver=2022.04.1
+pkgver=2024.02.0
pkgrel=1
pkgdesc="Flowee provides the shortest path to Bitcoin Cash"
arch=('x86_64' 'aarch64')
@@ -13,20 +13,20 @@ optdepends=('miniupnpc')
provides=('flowee-hub' 'flowee-libs')
backup=("etc/flowee/flowee.conf" "etc/flowee/rest-service.conf")
install=flowee.install
-source=("https://gitlab.com/FloweeTheHub/thehub/-/archive/$pkgver/thehub-$pkgver.tar.gz"
+source=("https://codeberg.org/Flowee/thehub/archive/$pkgver.tar.gz"
"flowee.logrotate"
"flowee.conf")
-sha256sums=("9bb35450ad11cb43841b29f266e0a3539af9fec1b8f079b9be8931c55a6e5acd"
+sha256sums=("082099f919d50db756f0e912895e78f9d9cab1fef5f6580f35c0d4882007daa3"
"0438e1a44523aeb3bbecd60fd920ca7b2aacd267b5cf988ab77a44eb7c03929e"
"59c1928ddb33fed1d4bf35df8fecd1dbdda0b308eac943503a2e3afb8c64bc89")
build() {
mkdir -p build
cd build
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=$pkgdir/usr/ ../thehub-$pkgver
- echo '#define GIT_COMMIT_ID "738c66e41"' > include/build.h
- echo '#define BUILD_DATE "2022-05-03 19:48:34 +0200"' >> include/build.h
+ cmake -DCMAKE_BUILD_TYPE=Release -Dbuild_apps=ON -DCMAKE_INSTALL_PREFIX=$pkgdir/usr/ ../thehub
+ echo '#define GIT_COMMIT_ID "f62acbed"' > include/build.h
+ echo '#define BUILD_DATE "2024-02-27 19:43:19 +0100"' >> include/build.h
make
}
@@ -39,13 +39,13 @@ package() {
mv etc/flowee/flowee.conf etc/flowee/flowee-example.conf
install -Dm 664 "$srcdir/flowee.conf" -t "$pkgdir/etc/flowee"
install -Dm 644 "$srcdir/flowee.logrotate" "$pkgdir/etc/logrotate.d/flowee"
- install -Dm 664 "$srcdir/thehub-$pkgver/support/logs.conf" -t "$pkgdir/etc/flowee"
- install -Dm 644 "$srcdir/thehub-$pkgver/support/thehub.service" -t "$pkgdir/usr/lib/systemd/system"
- install -Dm 644 "$srcdir/thehub-$pkgver/support/indexer.service" -t "$pkgdir/usr/lib/systemd/system"
- install -Dm 664 "$srcdir/thehub-$pkgver/support/indexer.conf" -t "$pkgdir/etc/flowee"
- install -Dm 644 "$srcdir/thehub-$pkgver/support/indexer.service" -t "$pkgdir/usr/lib/systemd/system"
- install -Dm 644 "$srcdir/thehub-$pkgver/support/rest-service.conf" -t "$pkgdir/etc/flowee"
- install -Dm 644 "$srcdir/thehub-$pkgver/support/rest-service.service" -t "$pkgdir/usr/lib/systemd/system"
- install -Dm 644 "$srcdir/thehub-$pkgver/support/bitcore-proxy.service" -t "$pkgdir/usr/lib/systemd/system"
- install -Dm 644 "$srcdir/thehub-$pkgver/support/bitcore-proxy.conf" -t "$pkgdir/etc/flowee"
+ install -Dm 664 "$srcdir/thehub/support/logs.conf" -t "$pkgdir/etc/flowee"
+ install -Dm 644 "$srcdir/thehub/support/thehub.service" -t "$pkgdir/usr/lib/systemd/system"
+ install -Dm 644 "$srcdir/thehub/support/indexer.service" -t "$pkgdir/usr/lib/systemd/system"
+ install -Dm 664 "$srcdir/thehub/support/indexer.conf" -t "$pkgdir/etc/flowee"
+ install -Dm 644 "$srcdir/thehub/support/indexer.service" -t "$pkgdir/usr/lib/systemd/system"
+ install -Dm 644 "$srcdir/thehub/support/rest-service.conf" -t "$pkgdir/etc/flowee"
+ install -Dm 644 "$srcdir/thehub/support/rest-service.service" -t "$pkgdir/usr/lib/systemd/system"
+ install -Dm 644 "$srcdir/thehub/support/bitcore-proxy.service" -t "$pkgdir/usr/lib/systemd/system"
+ install -Dm 644 "$srcdir/thehub/support/bitcore-proxy.conf" -t "$pkgdir/etc/flowee"
}
diff --git a/std.diff b/std.diff
deleted file mode 100644
index 8c7bb27ffc99..000000000000
--- a/std.diff
+++ /dev/null
@@ -1,30 +0,0 @@
-commit c8ed2ec382672d579433c3d69685b604f6021401
-Author: TomZ <tom@flowee.org>
-Date: Sat Jan 22 23:25:53 2022 +0100
-
- Make compile
-
-diff --git a/libs/networkmanager/NetworkManager.h b/libs/networkmanager/NetworkManager.h
-index b42b6b3f2..38a5b4669 100644
---- a/libs/networkmanager/NetworkManager.h
-+++ b/libs/networkmanager/NetworkManager.h
-@@ -21,6 +21,7 @@
- #include <string>
- #include <cstdint>
- #include <vector>
-+#include <map>
-
- #include <boost/asio/io_service.hpp>
- #include <boost/asio/ip/tcp.hpp>
-diff --git a/libs/p2p/SyncChainAction.h b/libs/p2p/SyncChainAction.h
-index 44bbd1507..74b428af2 100644
---- a/libs/p2p/SyncChainAction.h
-+++ b/libs/p2p/SyncChainAction.h
-@@ -21,6 +21,7 @@
- #include "Action.h"
-
- #include <set>
-+#include <map>
-
- class SyncChainAction : public Action
- {