summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
-rw-r--r--testing_patch.diff20
3 files changed, 32 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19849b5aeec5..fa47c5e8d883 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = flowee
pkgdesc = Flowee Bitcoin products
- pkgver = 2020.03.3
+ pkgver = 2020.04.1
pkgrel = 1
url = https://flowee.org/
install = flowee.install
arch = x86_64
- license = GPL
+ license = GPL3
makedepends = boost
makedepends = cmake
makedepends = pkgconf
@@ -15,13 +15,15 @@ pkgbase = flowee
optdepends = miniupnpc
provides = flowee-hub
backup = etc/flowee/flowee.conf
- source = https://gitlab.com/FloweeTheHub/thehub/-/archive/2020.03.3/thehub-2020.03.3.tar.gz
+ source = https://gitlab.com/FloweeTheHub/thehub/-/archive/2020.04.1/thehub-2020.04.1.tar.gz
source = flowee.logrotate
source = flowee.conf
+ source = testing_patch.diff
source = logs.conf
- sha256sums = 5c5eab5d268b3405924c4fb1980124ebdf3cb7586c97e08b4337ed41e9815e4f
+ sha256sums = 0ce651e4fe2b68339629888f31846bdde889b9013b67425177379c356a579bef
sha256sums = aff02b3312c88113fe7316152c15f1545233dc8c2062ee8c36d2dbcad4a9f5bf
sha256sums = bc14acf0d1b4064553756a1e81c0b943e842296f2a2af6442e480b846392e6bc
+ sha256sums = b03221ef5cd56f22c6755bc617a8caed39a1dd603c0cc0fee8c05b53c4ddbdfe
sha256sums = 2c94fbbccd6981a22951e4696f72d26aa0b5f7ea32aa48e46a0b6ded909fc3db
pkgname = flowee
diff --git a/PKGBUILD b/PKGBUILD
index 359e55d7ced9..bb661ec229dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Tom Zander
pkgname=flowee
-pkgver=2020.03.3
+pkgver=2020.04.1
pkgrel=1
pkgdesc="Flowee Bitcoin products"
arch=('x86_64')
url="https://flowee.org/"
-license=('GPL')
+license=('GPL3')
depends=('boost-libs' 'libevent' 'openssl')
makedepends=('boost' 'cmake' 'pkgconf')
optdepends=('miniupnpc')
@@ -16,14 +16,17 @@ install=flowee.install
source=("https://gitlab.com/FloweeTheHub/thehub/-/archive/$pkgver/thehub-$pkgver.tar.gz"
"flowee.logrotate"
"flowee.conf"
+ "testing_patch.diff"
"logs.conf")
-sha256sums=("5c5eab5d268b3405924c4fb1980124ebdf3cb7586c97e08b4337ed41e9815e4f"
+sha256sums=("0ce651e4fe2b68339629888f31846bdde889b9013b67425177379c356a579bef"
"aff02b3312c88113fe7316152c15f1545233dc8c2062ee8c36d2dbcad4a9f5bf"
"bc14acf0d1b4064553756a1e81c0b943e842296f2a2af6442e480b846392e6bc"
+ "b03221ef5cd56f22c6755bc617a8caed39a1dd603c0cc0fee8c05b53c4ddbdfe"
"2c94fbbccd6981a22951e4696f72d26aa0b5f7ea32aa48e46a0b6ded909fc3db")
build() {
+ (cd thehub-$pkgver && patch -p1 -i ../testing_patch.diff)
mkdir -p build
cd build
cmake -Dbuild_tests=true -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=$pkgdir/usr/ ../thehub-$pkgver
diff --git a/testing_patch.diff b/testing_patch.diff
new file mode 100644
index 000000000000..36fa2d800a48
--- /dev/null
+++ b/testing_patch.diff
@@ -0,0 +1,20 @@
+diff --git a/testing/CMakeLists.txt b/testing/CMakeLists.txt
+index 57a12d203..0d54841a9 100644
+--- a/testing/CMakeLists.txt
++++ b/testing/CMakeLists.txt
+@@ -29,7 +29,6 @@ if (${Qt5Core_FOUND})
+ add_subdirectory(networkmanager)
+ add_subdirectory(hashstorage)
+ add_subdirectory(blockvalidation)
+- add_subdirectory(api)
+
+ find_package(Qt5Network)
+ if (${Qt5Network_FOUND})
+@@ -47,7 +46,6 @@ if (${Qt5Core_FOUND})
+ test_networkmanager
+ test_hashstorage
+ test_blockvalidation
+- test_api
+ ${testHttp}
+ )
+ else ()