summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
-rw-r--r--flowee.conf3
-rw-r--r--flowee.install17
-rw-r--r--flowee.logrotate2
-rw-r--r--logs.conf4
6 files changed, 22 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd33e9efcbc2..a1684be6fd17 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
pkgbase = flowee
pkgdesc = Flowee the Hub
- pkgver = 0.1
+ pkgver = b46ad6f2b
pkgrel = 1
- url = http://flowee.org/
+ url = https://flowee.org/
install = flowee.install
- arch = i686
arch = x86_64
license = GPL
makedepends = boost
@@ -14,14 +13,14 @@ pkgbase = flowee
depends = openssl
provides = flowee-hub
backup = etc/flowee/flowee.conf
- source = git+https://github.com/floweethehub/hub.git#branch=master
+ source = git+https://gitlab.com/FloweeTheHub/thehub.git#branch=2019.02
source = flowee.logrotate
source = flowee.conf
source = logs.conf
sha256sums = SKIP
- sha256sums = d09fe561ed2b5fa0abf40bb5bfce0d6294b3747f97b94b473d040bda7b212985
- sha256sums = c02e66610a93f1f8b302b5409aa094ec8fd842698f2f7b54d8645bebae3da98b
- sha256sums = 635bf93ae346f7a8f4baf61d2d8316aa24647e87d23847876302330cb1e1191b
+ sha256sums = aff02b3312c88113fe7316152c15f1545233dc8c2062ee8c36d2dbcad4a9f5bf
+ sha256sums = bc14acf0d1b4064553756a1e81c0b943e842296f2a2af6442e480b846392e6bc
+ sha256sums = 3ec85358d1629a3d41e55710646be6b6a0cda322175779934439432615beba3c
pkgname = flowee
diff --git a/PKGBUILD b/PKGBUILD
index 175f9fbea787..4214746caad0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,43 @@
# Maintainer: Tom Zander
pkgname=flowee
-pkgver=ecc0613f
+pkgver=b46ad6f2b
pkgrel=1
pkgdesc="Flowee the Hub"
-arch=('i686' 'x86_64')
-url="http://flowee.org/"
+arch=('x86_64')
+url="https://flowee.org/"
license=('GPL')
depends=('boost-libs' 'libevent' 'openssl')
makedepends=('boost' 'cmake')
provides=('flowee-hub')
backup=("etc/flowee/flowee.conf")
install=flowee.install
-source=("git+https://github.com/floweethehub/hub.git#branch=master"
+source=("git+https://gitlab.com/FloweeTheHub/thehub.git#branch=2019.02"
"flowee.logrotate"
"flowee.conf"
"logs.conf")
sha256sums=('SKIP'
- "d09fe561ed2b5fa0abf40bb5bfce0d6294b3747f97b94b473d040bda7b212985"
- "c02e66610a93f1f8b302b5409aa094ec8fd842698f2f7b54d8645bebae3da98b"
- "635bf93ae346f7a8f4baf61d2d8316aa24647e87d23847876302330cb1e1191b")
+ "aff02b3312c88113fe7316152c15f1545233dc8c2062ee8c36d2dbcad4a9f5bf"
+ "bc14acf0d1b4064553756a1e81c0b943e842296f2a2af6442e480b846392e6bc"
+ "3ec85358d1629a3d41e55710646be6b6a0cda322175779934439432615beba3c")
pkgver() {
- cd "$srcdir/hub"
+ cd "$srcdir/thehub"
git rev-parse --short HEAD
}
build() {
mkdir -p build
cd build
- cmake -Dmark_release=true -Dbuild_tests=true -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=$pkgdir/usr/ ../hub
- make -j1 univalue
+ cmake -Dmark_release=true -Dbuild_tests=true -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=$pkgdir/usr/ ../thehub
+ make -j1 univalue leveldb
make
}
check() {
- ./build/testing/test/test_hub
+ cd build/testing
+ make check
}
package() {
@@ -48,5 +49,5 @@ package() {
mv etc/flowee/flowee.conf etc/flowee/flowee-example.conf
install -Dm 664 "$srcdir/flowee.conf" -t "$pkgdir/etc/flowee"
install -Dm 664 "$srcdir/logs.conf" -t "$pkgdir/etc/flowee"
- install -Dm 644 "$srcdir/hub/support/thehub.service" -t "$pkgdir/usr/lib/systemd/system"
+ install -Dm 644 "$srcdir/thehub/support/thehub.service" -t "$pkgdir/usr/lib/systemd/system"
}
diff --git a/flowee.conf b/flowee.conf
index 534dadbb8c23..193d7979cd52 100644
--- a/flowee.conf
+++ b/flowee.conf
@@ -2,6 +2,5 @@
datadir=/var/lib/flowee
pid=/var/lib/flowee/hub.pid
-# make the cookies go to /etc/flowee
+# make the cookie go to /etc/flowee
rpccookiefile=/etc/flowee/.cookie
-apicookiefile=/etc/flowee/api-cookie
diff --git a/flowee.install b/flowee.install
index 694e989c2540..761122092f39 100644
--- a/flowee.install
+++ b/flowee.install
@@ -8,9 +8,6 @@ post_install() {
_cnf="/etc/flowee"
if test ! -d "$_dir"; then
mkdir -m 750 "$_dir"
- # disable Copy-On-Write (btrfs directories only)
- # This avoids lots of known db-corruption issues
- _is_btrfs "$_dir" && chattr +C "$_dir"
fi
mkdir -p -m 770 "$_log"
chown -R $_bc_user:$_bc_group "$_dir" "$_cnf" "$_log"
@@ -33,17 +30,3 @@ _mkuser() {
echo "done"
}
}
-
-# ------------------------------------------------------------------------------
-# helper functions for disabling btrfs Copy-On-Write (CoW)
-# https://wiki.archlinux.org/index.php/Btrfs#Copy-On-Write_.28CoW.29
-# ------------------------------------------------------------------------------
-
-# check if dir is btrfs
-_is_btrfs() {
- if [[ $(findmnt --target $1 --output FSTYPE --noheadings) == 'btrfs' ]]; then
- return 0
- else
- return 1
- fi
-}
diff --git a/flowee.logrotate b/flowee.logrotate
index 299e0fa90458..bd6ef776012a 100644
--- a/flowee.logrotate
+++ b/flowee.logrotate
@@ -1,4 +1,4 @@
-/var/lib/flowee/debug.log
+/var/lib/flowee/hub.log
{
rotate 5
copytruncate
diff --git a/logs.conf b/logs.conf
index 95e0b40b23d5..46d25b5b93d6 100644
--- a/logs.conf
+++ b/logs.conf
@@ -1,5 +1,5 @@
# Flowee the Hub log config.
-# See for more details http://flowee.org/hub/log-config/
+# See for more details https://flowee.org/hub/log-config/
channel file
# timestamp option takes [time, millisecond, date]. Any combination allowed. None of these 3 for no timestamps
@@ -16,5 +16,3 @@ channel console
# quiet only shows critical and fatal
# info shows warning, info, critical and fatal
# debug shows everything.
-
-ALL quiet