summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f558b42961a..db73d5638bab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,6 +16,7 @@ pkgbase = flowee-git
provides = flowee-hub
provides = flowee-libs
backup = etc/flowee/flowee.conf
+ backup = etc/flowee/rest-service.conf
source = git+https://gitlab.com/FloweeTheHub/thehub.git#branch=master
source = flowee.logrotate
source = flowee.conf
diff --git a/PKGBUILD b/PKGBUILD
index 0b6f729577e8..7b0ee3d46cf7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ license=('GPL')
depends=('boost-libs' 'libevent' 'openssl')
makedepends=('boost' 'cmake' 'pkgconf')
provides=('flowee-hub' 'flowee-libs')
-backup=("etc/flowee/flowee.conf")
+backup=("etc/flowee/flowee.conf" "etc/flowee/rest-service.conf")
install=flowee.install
source=("git+https://gitlab.com/FloweeTheHub/thehub.git#branch=master"
"flowee.logrotate"
@@ -51,4 +51,6 @@ package() {
install -Dm 644 "$srcdir/thehub/support/thehub.service" -t "$pkgdir/usr/lib/systemd/system"
install -Dm 644 "$srcdir/thehub/support/indexer.service" -t "$pkgdir/usr/lib/systemd/system"
install -Dm 664 "$srcdir/thehub/support/indexer.conf" -t "$pkgdir/etc/flowee"
+ install -Dm 644 "$srcdir/thehub/support/rest-service.conf" -t "$pkgdir/etc/flowee"
+ install -Dm 644 "$srcdir/thehub/support/rest-service.service" -t "$pkgdir/usr/lib/systemd/system"
}