summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c908a4ae867..3eab78c38a78 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,19 @@
pkgbase = flrig
pkgdesc = Amateur (Ham) Radio Transceiver Control Program
pkgver = 1.4.4
- pkgrel = 1
+ pkgrel = 2
url = http://www.w1hkj.com/flrig-help/index.html
arch = armv7h
arch = i686
arch = x86_64
license = GPL
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = pkg-config
depends = fltk
depends = systemd-libs
- optdepends = hamradio-menus: XDG compliant menuing
+ depends = flxmlrpc>=1.0.1
+ depends = hamradio-menus
optdepends = fldigi: for digital mode interface
provides = flrig
conflicts = flrig-git
diff --git a/PKGBUILD b/PKGBUILD
index 9659cef76737..471d91013fc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,24 @@
pkgname=flrig
pkgver=1.4.4
-pkgrel=1
+pkgrel=2
pkgdesc="Amateur (Ham) Radio Transceiver Control Program"
arch=('armv7h' 'i686' 'x86_64')
url="http://www.w1hkj.com/flrig-help/index.html"
license=('GPL')
-depends=('fltk' 'systemd-libs')
-optdepends=('hamradio-menus: XDG compliant menuing'
- 'fldigi: for digital mode interface')
+depends=('fltk' 'systemd-libs' 'flxmlrpc>=1.0.1' 'hamradio-menus')
+optdepends=('fldigi: for digital mode interface')
+makedepends=('autoconf' 'automake' 'pkg-config')
provides=('flrig')
conflicts=('flrig-git')
source=(https://downloads.sourceforge.net/project/fldigi/$pkgname/$pkgname-$pkgver.tar.gz)
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+
+ autoreconf -i
+}
+
build() {
cd $srcdir/$pkgname-$pkgver