summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
-rwxr-xr-xflutter15
-rw-r--r--flutter.csh2
-rw-r--r--flutter.install3
-rw-r--r--flutter.sh2
6 files changed, 46 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7ca50e07afa..776524ddfe88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,23 @@
pkgbase = flutter
pkgdesc = Flutter is a new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android.
- pkgver = alpha
+ pkgver = beta
pkgrel = 1
- url = https://flutter.io/
+ url = https://flutter.io
arch = any
license = https://github.com/flutter/flutter/blob/master/LICENSE
+ depends = android-sdk
+ optdepends = android-studio
+ optdepends = intellij-idea-community-edition
+ optdepends = intellij-idea-ultimate-edition
provides = flutter
- source = flutter
+ source = flutter::git+https://github.com/flutter/flutter#branch=beta
+ source = flutter.install
+ source = flutter.sh
+ source = flutter.csh
sha256sums = SKIP
+ sha256sums = b8eb8c1a38e961984fe7d26fc83a86f6aa1b362c4187a1fef55ce5cbc68a8d84
+ sha256sums = 67fa3da8f8e9a1bcd2858989fe6d7fe9958fb3990e1c3148cd246c40b8980cb0
+ sha256sums = 7ef10d753cfaac52d243549764a793f44f8284a1f4b11715ccd2fa915b026a6f
pkgname = flutter
diff --git a/PKGBUILD b/PKGBUILD
index 07f1a8f33c1d..b74f3a133778 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,33 @@
-# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
+# Contributor: Philip Goto <philip.goto@gmail.com>
pkgname=flutter
-pkgver=alpha
+pkgver=beta
pkgrel=1
pkgdesc="Flutter is a new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android."
arch=('any')
-url="https://flutter.io/"
-license=('https://github.com/flutter/flutter/blob/master/LICENSE')
-provides=('flutter')
-source=("flutter")
-sha256sums=('SKIP')
+url="https://flutter.io"
+license=("https://github.com/flutter/flutter/blob/master/LICENSE")
+provides=(flutter)
+depends=(android-sdk)
+optdepends=(android-studio intellij-idea-community-edition intellij-idea-ultimate-edition)
+source=("${pkgname}::git+https://github.com/${pkgname}/${pkgname}#branch=${pkgver}"
+ "${pkgname}.install"
+ "${pkgname}.sh"
+ "${pkgname}.csh")
+sha256sums=('SKIP'
+ 'b8eb8c1a38e961984fe7d26fc83a86f6aa1b362c4187a1fef55ce5cbc68a8d84'
+ '67fa3da8f8e9a1bcd2858989fe6d7fe9958fb3990e1c3148cd246c40b8980cb0'
+ '7ef10d753cfaac52d243549764a793f44f8284a1f4b11715ccd2fa915b026a6f')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ bin/flutter doctor
+}
package() {
- install -dm 755 "${pkgdir}/usr/bin"
- install -m 755 "flutter" "${pkgdir}/usr/bin"
+ install -Dm755 "${pkgname}.sh" "${pkgdir}/etc/profile.d/${pkgname}.sh"
+ install -Dm755 "${pkgname}.csh" "${pkgdir}/etc/profile.d/${pkgname}.csh"
+ install -d "${pkgdir}/opt/${pkgname}/"
+ cp -ra "${srcdir}/${pkgname}" "${pkgdir}/opt/"
+ chown -R "${USER}":users "${pkgdir}/opt/${pgkname}"
}
diff --git a/flutter b/flutter
deleted file mode 100755
index c3b06cdb830f..000000000000
--- a/flutter
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/usr/bin/env sh
-
-FLUTTER_PATH=~/.flutter-sdk
-FLUTTER_GIT=https://github.com/flutter/flutter.git
-FLUTTER_BRANCH=alpha
-
-if ! [[ -x "$FLUTTER_PATH/bin/flutter" ]]
-then
- if ! git clone -b "$FLUTTER_BRANCH" "$FLUTTER_GIT" "$FLUTTER_PATH"
- then
- exit 1
- fi
-fi
-
-"$FLUTTER_PATH/bin/flutter" $@
diff --git a/flutter.csh b/flutter.csh
new file mode 100644
index 000000000000..fdb197131b7d
--- /dev/null
+++ b/flutter.csh
@@ -0,0 +1,2 @@
+setenv FLUTTER_HOME /opt/flutter
+setenv PATH ${PATH}:${FLUTTER_HOME}/bin:
diff --git a/flutter.install b/flutter.install
new file mode 100644
index 000000000000..1367a5ce48d2
--- /dev/null
+++ b/flutter.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo 'You need to source /etc/profile or relogin to add flutter to your path.'
+}
diff --git a/flutter.sh b/flutter.sh
new file mode 100644
index 000000000000..f7d00ec04a14
--- /dev/null
+++ b/flutter.sh
@@ -0,0 +1,2 @@
+export FLUTTER_HOME=/opt/flutter
+export PATH=$PATH:$FLUTTER_HOME/bin