summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
-rw-r--r--flutter.install35
3 files changed, 32 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34b9c0166a6d..41521c490cca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = flutter
pkgdesc = A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android.
pkgver = 3.3.2
- pkgrel = 1
+ pkgrel = 2
url = https://flutter.dev
install = flutter.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index a2baec586167..b7f66bad7502 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=flutter
pkgver=3.3.2
-pkgrel=1
+pkgrel=2
pkgdesc="A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android."
arch=("x86_64" "aarch64")
url="https://${pkgname}.dev"
@@ -19,9 +19,11 @@ source=(
"${pkgname}.sh"
"${pkgname}.csh"
)
-sha256sums=('a733a75ae07c42b2059a31fc9d64fabfae5dccd15770fa6b7f290e3f5f9c98e8'
- '1dea1952d386c43948b9970382c2da5b65b7870684b8ad2ad89124e873aa485a'
- '7ef10d753cfaac52d243549764a793f44f8284a1f4b11715ccd2fa915b026a6f')
+sha256sums=(
+ "a733a75ae07c42b2059a31fc9d64fabfae5dccd15770fa6b7f290e3f5f9c98e8"
+ "1dea1952d386c43948b9970382c2da5b65b7870684b8ad2ad89124e873aa485a"
+ "7ef10d753cfaac52d243549764a793f44f8284a1f4b11715ccd2fa915b026a6f"
+)
package() {
rm -rf "${srcdir}/${pkgname}/bin/cache" "${srcdir}/${pkgname}/.pub-cache"
diff --git a/flutter.install b/flutter.install
index 656de0ea1969..6f7c7f3d18d5 100644
--- a/flutter.install
+++ b/flutter.install
@@ -2,16 +2,31 @@ post_install() {
groupadd -f flutterusers
chgrp -R flutterusers /opt/flutter
chmod -R g+w /opt/flutter
- printf "$(tput setaf 4)Flutter was installed on $(tput setaf 2)/opt/flutter$(tput sgr0)\n"
- printf "$(tput setaf 4)$(tput sgr0)\n"
- printf "$(tput setaf 4)In case you encounter problems using Flutter as regular user, add your user into the group flutterusers:$(tput sgr0)\n"
- printf "$(tput setaf 2)gpasswd -a \${USER} flutterusers$(tput sgr0)\n"
- printf "$(tput setaf 4)$(tput sgr0)\n"
- printf "$(tput setaf 4)Re-login your terminal in to the group flutterusers:$(tput sgr0)\n"
- printf "$(tput setaf 2)newgrp flutterusers$(tput sgr0)\n"
- printf "$(tput setaf 4)$(tput sgr0)\n"
- printf "$(tput setaf 4)Run the following command to see if there are any dependencies you need to install to complete the setup (for verbose output, add the -v flag):$(tput sgr0)\n"
- printf "$(tput setaf 2)flutter doctor$(tput sgr0)\n"
+ tput setaf 0 2>/dev/null
+ if [[ "$?" == "0" ]]; then
+ tput sgr0
+ printf "$(tput setaf 4)Flutter was installed on $(tput setaf 2)/opt/flutter$(tput sgr0)\n"
+ printf "$(tput setaf 4)$(tput sgr0)\n"
+ printf "$(tput setaf 4)In case you encounter problems using Flutter as regular user, add your user into the group flutterusers:$(tput sgr0)\n"
+ printf "$(tput setaf 2)gpasswd -a \${USER} flutterusers$(tput sgr0)\n"
+ printf "$(tput setaf 4)$(tput sgr0)\n"
+ printf "$(tput setaf 4)Re-login your terminal in to the group flutterusers:$(tput sgr0)\n"
+ printf "$(tput setaf 2)newgrp flutterusers$(tput sgr0)\n"
+ printf "$(tput setaf 4)$(tput sgr0)\n"
+ printf "$(tput setaf 4)Run the following command to see if there are any dependencies you need to install to complete the setup (for verbose output, add the -v flag):$(tput sgr0)\n"
+ printf "$(tput setaf 2)flutter doctor$(tput sgr0)\n"
+ else
+ printf "Flutter was installed on /opt/flutter\n"
+ printf "\n"
+ printf "In case you encounter problems using Flutter as regular user, add your user into the group flutterusers:\n"
+ printf "gpasswd -a \${USER} flutterusers\n"
+ printf "\n"
+ printf "Re-login your terminal in to the group flutterusers:\n"
+ printf "newgrp flutterusers\n"
+ printf "\n"
+ printf "Run the following command to see if there are any dependencies you need to install to complete the setup (for verbose output, add the -v flag):\n"
+ printf "flutter doctor\n"
+ fi
}
post_upgrade() {