summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD22
-rw-r--r--flutter.install20
4 files changed, 19 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cef6fd023d1..df139fec2470 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = flutter-git
pkgdesc = A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android.
- pkgver = 1.4.19.r2.27b058a414
+ pkgver = 1.26.0.1.0.pre.r0.63062a6443
pkgrel = 1
url = https://flutter.io
install = flutter.install
@@ -8,22 +8,19 @@ pkgbase = flutter-git
license = custom
license = BSD
license = CCPL
- makedepends = git
makedepends = python
- makedepends = unzip
+ depends = git
depends = glu
depends = java-environment
- depends = lib32-libglvnd
+ depends = libglvnd
+ depends = unzip
optdepends = android-sdk
optdepends = android-studio
- optdepends = bash
optdepends = dart
- optdepends = git
optdepends = intellij-idea-community-edition
optdepends = intellij-idea-ultimate-edition
optdepends = perl
optdepends = python
- optdepends = sh
provides = flutter
conflicts = flutter
options = !emptydirs
diff --git a/.gitignore b/.gitignore
index 394e39541149..1a0eec92680d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
+flutter-*.pkg.tar.zst
flutter-*.pkg.tar.xz
flutter-*.log
PKGBUILD-namcap.log
diff --git a/PKGBUILD b/PKGBUILD
index a9a4c4549358..8e51bbf616ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,15 @@
# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
pkgname=flutter-git
-pkgver=1.4.19.r2.27b058a414
+pkgver=1.26.0.1.0.pre.r0.63062a6443
pkgrel=1
pkgdesc="A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android."
arch=("x86_64")
url="https://${pkgname%-git}.io"
license=("custom" "BSD" "CCPL")
-depends=("glu" "java-environment" "lib32-libglvnd")
-optdepends=(
- "android-sdk"
- "android-studio"
- "bash"
- "dart"
- "git"
- "intellij-idea-community-edition"
- "intellij-idea-ultimate-edition"
- "perl"
- "python"
- "sh"
-)
-makedepends=("git" "python" "unzip")
+depends=("git" "glu" "java-environment" "libglvnd" "unzip")
+optdepends=("android-sdk" "android-studio" "dart" "intellij-idea-community-edition" "intellij-idea-ultimate-edition" "perl" "python")
+makedepends=("python")
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
backup=("opt/${pkgname%-git}/packages/${pkgname%-git}_test/pubspec.yaml" "opt/${pkgname%-git}/packages/${pkgname%-git}/pubspec.yaml")
@@ -52,6 +41,7 @@ build() {
}
package() {
+ rm -rf "${srcdir}/${pkgname%-git}/bin/cache" "${srcdir}/${pkgname%-git}/.pub-cache"
install -Dm644 "${srcdir}/${pkgname%-git}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm755 "${srcdir}/${pkgname%-git}.sh" "${pkgdir}/etc/profile.d/${pkgname%-git}.sh"
install -Dm755 "${srcdir}/${pkgname%-git}.csh" "${pkgdir}/etc/profile.d/${pkgname%-git}.csh"
@@ -60,6 +50,6 @@ package() {
cp -ra "${srcdir}/${pkgname%-git}" "${pkgdir}/opt/"
find "${pkgdir}/opt/${pkgname%-git}" -type d -exec chmod a+rx {} +
find "${pkgdir}/opt/${pkgname%-git}" -type f -exec chmod a+r {} +
- chmod a+rw "${pkgdir}/opt/${pkgname%-git}/bin/cache/lockfile" "${pkgdir}/opt/${pkgname%-git}/version"
+ chmod a+rw "${pkgdir}/opt/${pkgname%-git}/version"
ln -s "/opt/${pkgname%-git}/bin/${pkgname%-git}" "${pkgdir}/usr/bin/${pkgname%-git}"
}
diff --git a/flutter.install b/flutter.install
index 38b040390344..8e5693109561 100644
--- a/flutter.install
+++ b/flutter.install
@@ -1,20 +1,15 @@
post_install() {
+ groupadd -f flutterusers
+ chgrp -R flutterusers /opt/flutter
+ chmod -R g+w /opt/flutter
printf "$(tput setaf 4)Flutter was installed on $(tput setaf 2)/opt/flutter$(tput sgr0)\n"
printf "$(tput setaf 4)$(tput sgr0)\n"
- printf "$(tput setaf 4)You need to source $(tput setaf 2)/etc/profile$(tput setaf 4) or relogin to add flutter to your path.$(tput sgr0)\n"
+ printf "$(tput setaf 4)If you intend to use it as a regular user, add your user into the group flutterusers:$(tput sgr0)\n"
+ printf "$(tput setaf 2)gpasswd -a <user> flutterusers$(tput sgr0)\n"
printf "$(tput setaf 4)$(tput sgr0)\n"
- printf "$(tput setaf 4)This folder has root permissions, so keep in mind to run flutter as root,$(tput sgr0)\n"
- printf "$(tput setaf 4)otherwise you will not be able to modify anything in this directory.$(tput sgr0)\n"
+ printf "$(tput setaf 4)You need to source $(tput setaf 2)/etc/profile$(tput setaf 4) or relogin to add flutter to your path.$(tput sgr0)\n"
printf "$(tput setaf 4)$(tput sgr0)\n"
- printf "$(tput setaf 4)If you intend to use it as a regular user, create the Flutter users group:$(tput sgr0)\n"
- printf "$(tput setaf 2)groupadd flutterusers$(tput sgr0)\n"
- printf "$(tput setaf 4)Add your user into this group:$(tput sgr0)\n"
- printf "$(tput setaf 2)gpasswd -a <user> flutterusers$(tput sgr0)\n"
- printf "$(tput setaf 4)Change folder's group.$(tput sgr0)\n"
- printf "$(tput setaf 2)chown -R :flutterusers /opt/flutter$(tput sgr0)\n"
- printf "$(tput setaf 4)Change permissions of the folder so the user that was just added to the group will be able to write in it:$(tput sgr0)\n"
- printf "$(tput setaf 2)chmod -R g+w /opt/flutter$(tput sgr0)\n"
- printf "$(tput setaf 4)Re-login your terminal in to the newly created group:$(tput sgr0)\n"
+ printf "$(tput setaf 4)Re-login your terminal in to the group flutterusers:$(tput sgr0)\n"
printf "$(tput setaf 2)newgrp flutterusers$(tput sgr0)\n"
}
@@ -23,6 +18,7 @@ post_upgrade() {
}
post_remove() {
+ groupdel flutterusers
printf "$(tput setaf 4)If you had added/modified files or permissions in folder /opt/flutter is possible you need to delete it manually.$(tput sgr0)\n"
printf "$(tput setaf 2)rm -rf /opt/flutter$(tput sgr0)\n"
}