summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
-rw-r--r--c-plus-plus-17.patch28
-rw-r--r--styles.patch64
4 files changed, 109 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00762aaf5c8f..12e8ae92bbc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fluxbox-wm
pkgdesc = A lightweight and highly-configurable window manager build without toolbar and slit support
- pkgver = 1.3.7+205+g1d19662c
+ pkgver = 1.3.7
pkgrel = 2
url = http://www.fluxbox.org/
arch = x86_64
@@ -19,11 +19,15 @@ pkgbase = fluxbox-wm
provides = fluxbox
conflicts = fluxbox
options = !makeflags
- source = git+https://github.com/fluxbox/fluxbox.git#commit=1d19662c8975e881b4fa6465a8305be3ea5282ee
+ source = git+https://github.com/fluxbox/fluxbox.git#commit=88a74ff1cde22be3e894498ffd88934dc92dfef0
source = window-menu.patch
+ source = styles.patch
+ source = c-plus-plus-17.patch
source = fluxbox.desktop
sha256sums = SKIP
sha256sums = 9caa2179d17517034c19cc237f817dfb26da1a4cbdc6ed298a1b2bea14ccf0f7
+ sha256sums = d09736de789b3926a0642e381c4a30499a03c7ac99ffb6c981921910c392de07
+ sha256sums = a743324fb0c684be44fbcb3ff626f604057fce42fe1dda774515c1b24efbf418
sha256sums = 2148a90aca653b596e9632264dbdbd8c7e673d732e4b04eee66a8ac1e68b3c5d
pkgname = fluxbox-wm
diff --git a/PKGBUILD b/PKGBUILD
index bdb433bdb0c2..33f9ac724f25 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
pkgname=fluxbox-wm
_pkgname=fluxbox
-_commit='1d19662c8975e881b4fa6465a8305be3ea5282ee'
-pkgver=1.3.7+205+g1d19662c
+_commit='88a74ff1cde22be3e894498ffd88934dc92dfef0'
+pkgver=1.3.7
pkgrel=2
-pkgdesc='A lightweight and highly-configurable window manager build without toolbar and slit support'
+pkgdesc='A lightweight and highly-configurable window manager build without toolbar, systray and slit support'
arch=('x86_64')
url='http://www.fluxbox.org/'
license=('MIT')
@@ -18,9 +18,13 @@ optdepends=('xorg-xmessage: for using the fbsetbg and fluxbox-generate_menu util
options=('!makeflags')
source=("git+https://github.com/${_pkgname}/${_pkgname}.git#commit=${_commit}"
'window-menu.patch'
+ 'styles.patch'
+ 'c-plus-plus-17.patch'
'fluxbox.desktop')
sha256sums=('SKIP'
'9caa2179d17517034c19cc237f817dfb26da1a4cbdc6ed298a1b2bea14ccf0f7'
+ 'd09736de789b3926a0642e381c4a30499a03c7ac99ffb6c981921910c392de07'
+ 'a743324fb0c684be44fbcb3ff626f604057fce42fe1dda774515c1b24efbf418'
'2148a90aca653b596e9632264dbdbd8c7e673d732e4b04eee66a8ac1e68b3c5d')
pkgver() {
@@ -31,6 +35,8 @@ pkgver() {
prepare() {
cd "${_pkgname}"
patch -Np1 < ../window-menu.patch
+ patch -Np1 < ../styles.patch
+ patch -Np1 < ../c-plus-plus-17.patch
autoreconf -fi
}
@@ -43,8 +49,8 @@ build() {
--enable-xft \
--enable-xinerama \
--disable-slit \
- --disable-toolbar
- # no more disable-systray option
+ --disable-toolbar \
+ --disable-systray
make
}
diff --git a/c-plus-plus-17.patch b/c-plus-plus-17.patch
new file mode 100644
index 000000000000..37e450b08f16
--- /dev/null
+++ b/c-plus-plus-17.patch
@@ -0,0 +1,28 @@
+http://git.fluxbox.org/fluxbox.git/patch/?id=22866c4d30f5b289c429c5ca88d800200db4fc4f
+https://bugs.gentoo.org/732782
+
+From 22866c4d30f5b289c429c5ca88d800200db4fc4f Mon Sep 17 00:00:00 2001
+From: John Sennesael <john@aminking.com>
+Date: Mon, 2 Nov 2015 15:14:32 -0600
+Subject: fixes bug #1138
+
+---
+ util/fluxbox-remote.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/util/fluxbox-remote.cc b/util/fluxbox-remote.cc
+index 59852e6..504015b 100644
+--- a/util/fluxbox-remote.cc
++++ b/util/fluxbox-remote.cc
+@@ -73,7 +73,7 @@ int main(int argc, char **argv) {
+ if (strcmp(cmd, "result") == 0) {
+ XTextProperty text_prop;
+ if (XGetTextProperty(disp, root, &text_prop, atom_result) != 0
+- && text_prop.value > 0
++ && text_prop.value != 0
+ && text_prop.nitems > 0) {
+
+ printf("%s", text_prop.value);
+--
+cgit v0.11.2
+
diff --git a/styles.patch b/styles.patch
new file mode 100644
index 000000000000..a3ac517c0013
--- /dev/null
+++ b/styles.patch
@@ -0,0 +1,64 @@
+diff --git a/data/styles/Artwiz b/data/styles/Artwiz
+index f413761a..153b20b1 100644
+--- a/data/styles/Artwiz
++++ b/data/styles/Artwiz
+@@ -110,5 +110,5 @@ background.modY: 4
+ background.color: rgb:10/18/20
+ background.colorTo: rgb:30/38/40
+
+-*Font: -*-lucidatypewriter-medium-r-*-*-*-100-*-*-*-*-*-*
+-!*Font: vera-7
++!*Font: -*-lucidatypewriter-medium-r-*-*-*-100-*-*-*-*-*-*
++*Font: vera-7
+diff --git a/data/styles/BlueNight b/data/styles/BlueNight
+index 1e77343f..1e5e86ee 100644
+--- a/data/styles/BlueNight
++++ b/data/styles/BlueNight
+@@ -52,7 +52,7 @@ menu.title: Flat Gradient CrossDiagonal
+ menu.title.color: #80949d
+ menu.title.colorTo: #4e5a67
+ menu.title.textColor: #ffffff
+-menu.title.font: -*-lucida-bold-r-*-*-11-*-*-*-*-*-*-*
++!menu.title.font: -*-lucida-bold-r-*-*-11-*-*-*-*-*-*-*
+ menu.title.justify: Left
+
+ menu.hilite: Flat Gradient CrossDiagonal
+@@ -138,3 +138,4 @@ bevelWidth: 1
+ borderWidth: 1
+ borderColor: #000000
+
++*.font: lucidasans-10
+diff --git a/data/styles/Makro b/data/styles/Makro
+index 28d14f80..313c3ccf 100644
+--- a/data/styles/Makro
++++ b/data/styles/Makro
+@@ -104,7 +104,7 @@ window.justify: Left
+
+ toolbar.font: -*-helvetica-medium-r-*-*-11-*-*-*-*-*-iso8859-*
+ window.font: -*-helvetica-bold-r-*-*-11-*-*-*-*-*-iso8859-*
+-menu.title.font: -*-helvetica-bold-r-*-*-11-*-*-*-*-*-iso8859-*
++!menu.title.font: -*-helvetica-bold-r-*-*-11-*-*-*-*-*-iso8859-*
+ menu.frame.font: -*-helvetica-medium-r-*-*-10-*-*-*-*-*-iso8859-*
+
+ borderColor: rgb:10/10/10
+@@ -114,4 +114,4 @@ borderWidth: 1
+ handleWidth: 3
+
+ background: flat
+-background.color: rgb:9A/9A/90
+\ No newline at end of file
++background.color: rgb:9A/9A/90
+diff --git a/data/styles/MerleyKay b/data/styles/MerleyKay
+index ae491e34..dc528e90 100644
+--- a/data/styles/MerleyKay
++++ b/data/styles/MerleyKay
+@@ -121,8 +121,7 @@ window.justify: Center
+ window.tab.font: -*-clean-medium-r-*-*-12-*-*-*-*-60-iso8859-*
+ toolbar.font: -*-lucida-bold-r-*-*-*-100-*-*-*-*-*-*
+ window.font: -*-helvetica-medium-r-normal-*-12-*-*-*-*-*-iso8859-*
+-#menu.title.font: -*-lucida-bold-r-*-*-*-100-*-*-*-*-*-*
+-menu.title.font: -*-lucida-bold-r-*-*-*-100-*-*-*-*-*-*
++!menu.title.font: -*-lucida-bold-r-*-*-*-100-*-*-*-*-*-*
+ menu.frame.font: -*-lucida-medium-r-*-*-*-100-*-*-*-*-*-*
+
+ borderColor: rgb:00/00/00