summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD37
-rw-r--r--fluxbox.desktop6
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a31eed4205f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = fluxbox-wm
+ pkgdesc = A lightweight and highly-configurable window manager compiled without slit toolbar and systemtray
+ pkgver = 1.3.7
+ pkgrel = 2
+ url = http://www.fluxbox.org
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = libxft
+ depends = libxpm
+ depends = libxinerama
+ depends = libxrandr
+ depends = imlib2
+ depends = fribidi
+ optdepends = xorg-xmessage: for using the fbsetbg and fluxbox-generate_menu utilities
+ provides = fluxbox
+ conflicts = fluxbox
+ conflicts = fluxbox-noslit
+ options = !makeflags
+ source = http://downloads.sourceforge.net/sourceforge/fluxbox/fluxbox-1.3.7.tar.xz
+ source = fluxbox.desktop
+ sha1sums = c53940f5b70dfad39f4a3fa6b0e95072c2b3e9db
+ sha1sums = f3f83b8ce84d79c2f8670ef687e0dd89ab0552b8
+
+pkgname = fluxbox-wm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91de7a56f909
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Black_Codec <orso.f.regna@gmail.com>
+# $Id: PKGBUILD 231195 2015-02-09 20:22:56Z eric $
+# Original Maintainer: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname=fluxbox-wm
+_pkgname=fluxbox
+pkgver=1.3.7
+pkgrel=2
+pkgdesc="A lightweight and highly-configurable window manager compiled without slit toolbar and systemtray"
+arch=('i686' 'x86_64')
+url="http://www.fluxbox.org"
+license=('MIT')
+provides=('fluxbox')
+conflicts=('fluxbox' 'fluxbox-noslit')
+depends=('libxft' 'libxpm' 'libxinerama' 'libxrandr' 'imlib2' 'fribidi')
+optdepends=('xorg-xmessage: for using the fbsetbg and fluxbox-generate_menu utilities')
+options=('!makeflags')
+source=(http://downloads.sourceforge.net/sourceforge/${_pkgname}/${_pkgname}-${pkgver}.tar.xz
+ fluxbox.desktop)
+sha1sums=('c53940f5b70dfad39f4a3fa6b0e95072c2b3e9db'
+ 'f3f83b8ce84d79c2f8670ef687e0dd89ab0552b8')
+
+build() {
+ cd ${_pkgname}-${pkgver}
+ ./configure --prefix=/usr \
+ --enable-xft --enable-xinerama \
+ --enable-imlib2 --enable-nls \
+ --disable-slit --disable-toolbar --disable-systray
+ make
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 "${srcdir}/fluxbox.desktop" "${pkgdir}/usr/share/xsessions/fluxbox.desktop"
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
diff --git a/fluxbox.desktop b/fluxbox.desktop
new file mode 100644
index 000000000000..418d29acbc7e
--- /dev/null
+++ b/fluxbox.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=XSession
+Exec=/usr/bin/startfluxbox
+TryExec=/usr/bin/startfluxbox
+Name=fluxbox