summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 25 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0afa6acac94..c4ea257eb14b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
-pkgbase = xflux-gui-git
+pkgbase = fluxgui-git
pkgdesc = Better lighting for Linux. Open source GUI for xflux
- pkgver = v1.2.0.r4.g23ac6af
- pkgrel = 2
- url = https://justgetflux.com/linux.html
+ pkgver = v1.2.0.r16.gc80145d
+ pkgrel = 1
+ url = https://github.com/xflux-gui/fluxgui
arch = any
license = MIT
makedepends = git
@@ -12,10 +12,10 @@ pkgbase = xflux-gui-git
depends = libindicator-gtk2
depends = libappindicator-gtk3
depends = python-xdg
- provides = xflux-gui=v1.2.0.r4.g23ac6af
- conflicts = xflux-gui
- source = git://github.com/xflux-gui/xflux-gui.git
+ provides = fluxgui
+ conflicts = fluxgui
+ source = git+https://github.com/xflux-gui/fluxgui.git
md5sums = SKIP
-pkgname = xflux-gui-git
+pkgname = fluxgui-git
diff --git a/PKGBUILD b/PKGBUILD
index 5301258fbe94..1e307059ee7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
-# Maintainer: dracorp aka Piotr Rogoza <piotr dot r dot public at gmail dot com>
-
-pkgname=xflux-gui-git
-pkgver=v1.2.0.r4.g23ac6af
-pkgrel=2
+pkgname=fluxgui-git
+pkgver=v1.2.0.r16.gc80145d
+pkgrel=1
pkgdesc='Better lighting for Linux. Open source GUI for xflux'
arch=(any)
-url='https://justgetflux.com/linux.html'
+url='https://github.com/xflux-gui/fluxgui'
license=(MIT)
-provides=(xflux-gui=$pkgver)
-conflicts=(xflux-gui)
+# provides=(xflux-gui=$pkgver)
+# conflicts=(xflux-gui)
+conflicts=(${pkgname%-git})
+provides=(${pkgname%-git})
depends=(
hicolor-icon-theme
python-pexpect
@@ -20,25 +20,23 @@ libappindicator-gtk3
python-xdg
)
makedepends=(git)
-source=('git://github.com/xflux-gui/xflux-gui.git')
-_gitname='xflux-gui'
+source=("git+$url.git")
md5sums=('SKIP')
pkgver(){
- if [ -d "$srcdir"/$_gitname ]; then
- cd "$srcdir"/$_gitname
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" )
- fi
+ cd ${pkgname%-git}
+ set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build(){
- cd "$srcdir/$_gitname"
+ cd ${pkgname%-git}
python setup.py build
}
package(){
- cd "$srcdir/$_gitname"
+ cd ${pkgname%-git}
+ python setup.py build
python setup.py install --root="$pkgdir"
- install -Dm755 LICENSE $pkgdir/usr/share/licenses/xflux-gui-git/LICENSE
+ install -Dm755 LICENSE $pkgdir/usr/share/licenses/${pkgname}/LICENSE
rm -f "${pkgdir}/usr/share/glib-2.0/schemas/gschemas.compiled"
}