summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD24
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d29eef33f9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = flv2x264
+ pkgdesc = flv to avi converter
+ pkgver = 0.2.a1
+ pkgrel = 1
+ url = https://github.com/3ed/flv2x264
+ arch = any
+ license = GPL2
+ depends = ffmpeg
+ depends = bash
+ optdepends = libx264: h264 support
+ optdepends = libtheora: ogg/theora support
+ optdepends = libvpx: vp8 support
+ optdepends = faac: aac support
+ optdepends = libvorbis: ogg/vorbis support
+ optdepends = lame: mp3 support
+ source = flv2x264-0.2.a1.tar.gz::https://github.com/3ed/flv2x264/archive/v0.2.a1.tar.gz
+ sha256sums = 14f7e252d6c0234f7d508d3bbb21a43e99fdb60c1294ee2203c1ab1bea6f71d0
+
+pkgname = flv2x264
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..225f704fc61c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Mantainer: 3ED <krzysztof1987 at gmail>
+
+pkgname=flv2x264
+pkgver=0.2.a1
+pkgrel=1
+pkgdesc="flv to avi converter"
+arch=('any')
+license=('GPL2')
+depends=('ffmpeg' 'bash')
+optdepends=('libx264: h264 support'
+ 'libtheora: ogg/theora support'
+ 'libvpx: vp8 support'
+ 'faac: aac support'
+ 'libvorbis: ogg/vorbis support'
+ 'lame: mp3 support')
+url="https://github.com/3ed/flv2x264"
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/3ed/flv2x264/archive/v${pkgver}.tar.gz)
+sha256sums=('14f7e252d6c0234f7d508d3bbb21a43e99fdb60c1294ee2203c1ab1bea6f71d0')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -dm755 "$pkgdir/usr/bin"
+ install -m0755 bin/flv2x264 "$pkgdir/usr/bin/flv2x264"
+}