summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
2 files changed, 49 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c93715105434..332cbbd7bc0f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,35 @@
pkgbase = flycast
pkgdesc = A multi-platform Sega Dreamcast, Naomi and Atomiswave emulator
- pkgver = 2.0
+ pkgver = 2.1
pkgrel = 1
url = https://github.com/flyinghead/flycast
arch = x86_64
arch = i686
license = GPL2
- makedepends = git
makedepends = cmake
+ makedepends = git
makedepends = python
makedepends = systemd
+ depends = alsa-lib
+ depends = hicolor-icon-theme
depends = libgl
depends = libzip
- depends = zlib
- depends = alsa-lib
provides = flycast
provides = reicast
conflicts = flycast
- source = flycast::git+https://github.com/flyinghead/flycast.git#tag=v2.0
+ source = flycast::git+https://github.com/flyinghead/flycast.git#tag=V2.1
source = SDL::git+https://github.com/libsdl-org/SDL
+ source = Vulkan-Headers::git+https://github.com/KhronosGroup/Vulkan-Headers
+ source = VulkanMemoryAllocator::git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator
+ source = breakpad::git+https://github.com/flyinghead/mingw-breakpad
+ source = glslang::git+https://github.com/KhronosGroup/glslang
source = libchdr::git+https://github.com/rtissera/libchdr
source = luabridge::git+https://github.com/vinniefalco/LuaBridge
- source = breakpad::git+https://github.com/flyinghead/mingw-breakpad
+ source = oboe::git+https://github.com/google/oboe
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 077cba5fa488..eb753c52dd6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,36 @@
_pkgname=flycast
pkgname="$_pkgname"
-pkgver=2.0
+pkgver=2.1
+_tag="V$pkgver"
pkgrel=1
pkgdesc='A multi-platform Sega Dreamcast, Naomi and Atomiswave emulator'
arch=('x86_64' 'i686')
url="https://github.com/flyinghead/flycast"
license=('GPL2')
-depends=('libgl' 'libzip' 'zlib' 'alsa-lib')
-makedepends=('git' 'cmake' 'python' 'systemd')
+depends=(
+ 'alsa-lib'
+ 'hicolor-icon-theme'
+ 'libgl'
+ 'libzip'
+)
+makedepends=(
+ 'cmake'
+ 'git'
+ 'python'
+ 'systemd'
+)
provides=("$_pkgname" reicast)
conflicts=("$_pkgname")
source=(
- "$_pkgname"::"git+$url.git#tag=v$pkgver"
+ "$_pkgname"::"git+$url.git#tag=$_tag"
"SDL"::"git+https://github.com/libsdl-org/SDL"
+ "Vulkan-Headers"::"git+https://github.com/KhronosGroup/Vulkan-Headers"
+ "VulkanMemoryAllocator"::"git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator"
+ "breakpad"::"git+https://github.com/flyinghead/mingw-breakpad"
+ "glslang"::"git+https://github.com/KhronosGroup/glslang"
"libchdr"::"git+https://github.com/rtissera/libchdr"
"luabridge"::"git+https://github.com/vinniefalco/LuaBridge"
- "breakpad"::"git+https://github.com/flyinghead/mingw-breakpad"
+ "oboe"::"git+https://github.com/google/oboe"
)
md5sums=(
'SKIP'
@@ -23,13 +38,26 @@ md5sums=(
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
)
prepare() {
cd "$srcdir/$_pkgname"
- # git submodule update --init --recursive
- for submodule in core/deps/{SDL,libchdr,luabridge,breakpad}; do
+ _submodules=(
+ 'core/deps/SDL'
+ 'core/deps/Vulkan-Headers'
+ 'core/deps/VulkanMemoryAllocator'
+ 'core/deps/breakpad'
+ 'core/deps/glslang'
+ 'core/deps/libchdr'
+ 'core/deps/luabridge'
+ 'core/deps/oboe'
+ )
+ for submodule in ${_submodules[@]} ; do
git submodule init ${submodule}
git submodule set-url ${submodule} "${srcdir}/${submodule##*/}"
git -c protocol.file.allow=always submodule update ${submodule}