summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b86d7fe505bb..0dc15c0aa498 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = focus-git
- pkgdesc = A desktop notification based app that keeps you focused
- pkgver = r42.7626df4
+ pkgdesc = A desktop notification based app that keeps you focused by notifying you of what you should be doing
+ pkgver = r52.c5e651b
pkgrel = 1
url = https://github.com/nagyation/Focus
arch = x86_64
@@ -8,6 +8,8 @@ pkgbase = focus-git
makedepends = git
depends = gtk2
depends = libnotify
+ depends = libappindicator-gtk3
+ depends = gtk-update-icon-cache
source = git+https://github.com/nagyation/Focus.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c9d754d63a28..bc3027534f86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: nagyation <mnagy1312@gmail.com>
pkgname=focus-git
_newpkgname=Focus
-pkgver=r42.7626df4
+pkgver=r52.c5e651b
pkgrel=1
-pkgdesc="A desktop notification based app that keeps you focused"
+pkgdesc="A desktop notification based app that keeps you focused by notifying you of what you should be doing"
arch=(x86_64)
url="https://github.com/nagyation/Focus"
license=('GPL')
-depends=('gtk2' 'libnotify')
+depends=('gtk2' 'libnotify' 'libappindicator-gtk3' 'gtk-update-icon-cache')
makedepends=('git')
source=("git+https://github.com/nagyation/Focus.git")
md5sums=('SKIP')
@@ -26,5 +26,6 @@ package() {
cd "$_newpkgname"
install -D -m644 "License.txt" "${pkgdir}/usr/share/licenses/${_newpkgname}/LICENSE"
install -D -m755 "focus" "${pkgdir}/usr/bin/focus"
- install -D -m755 "resources/focus_icon.png" "${pkgdir}/usr/share/focus/focus_icon.png"
+ install -D -m755 "icons/focus-icon.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/focus-icon.svg"
+ gtk-update-icon-cache -f -t /usr/share/icons/hicolor
}