summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b86d7fe505bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = focus-git
+ pkgdesc = A desktop notification based app that keeps you focused
+ pkgver = r42.7626df4
+ pkgrel = 1
+ url = https://github.com/nagyation/Focus
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = gtk2
+ depends = libnotify
+ source = git+https://github.com/nagyation/Focus.git
+ md5sums = SKIP
+
+pkgname = focus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9d754d63a28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: nagyation <mnagy1312@gmail.com>
+pkgname=focus-git
+_newpkgname=Focus
+pkgver=r42.7626df4
+pkgrel=1
+pkgdesc="A desktop notification based app that keeps you focused"
+arch=(x86_64)
+url="https://github.com/nagyation/Focus"
+license=('GPL')
+depends=('gtk2' 'libnotify')
+makedepends=('git')
+source=("git+https://github.com/nagyation/Focus.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_newpkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_newpkgname"
+ make
+}
+
+package() {
+ cd "$_newpkgname"
+ install -D -m644 "License.txt" "${pkgdir}/usr/share/licenses/${_newpkgname}/LICENSE"
+ install -D -m755 "focus" "${pkgdir}/usr/bin/focus"
+ install -D -m755 "resources/focus_icon.png" "${pkgdir}/usr/share/focus/focus_icon.png"
+}