summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD80
-rwxr-xr-xfofix-git.desktop2
-rwxr-xr-xfofix-git.install16
4 files changed, 58 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9055af30f67f..2b1c2e86bf3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,9 @@
-# Generated by makepkg 4.2.0
-# Tue Feb 24 01:52:02 UTC 2015
pkgbase = fofix-git
- pkgdesc = fretsonfire X (FoFiX). Highly improved version of Frets on Fire (GIT Version)
+ pkgdesc = Frets on Fire X (FoFiX). Highly improved version of Frets on Fire (Git Version)
pkgver = v4.0.0alpha1.607.g3fe0f93
pkgrel = 1
epoch = 1
- url = http://code.google.com/p/fofix/
+ url = https://github.com/fofix/fofix
install = fofix-git.install
arch = i686
arch = x86_64
@@ -29,7 +27,7 @@ pkgbase = fofix-git
source = fofix-git.desktop
source = fofix-git.png
source = git+http://github.com/fofix/fofix.git
- md5sums = b7f141bb1045159e5075ecdb3f59adff
+ md5sums = 7ad2bde66aea003e1cc152b7650453ea
md5sums = f886a7fdfa7592b50aa9f62901910e03
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 09a0d00231b6..7cbaa7ec8735 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,68 @@
# Maintainer: François Magimel <magimel.francois@gmail.com>
# Contributor: Austin <doorknob60 at gmail dot com>
+
+_gitname=fofix
pkgname=fofix-git
pkgver=v4.0.0alpha1.607.g3fe0f93
epoch=1
pkgrel=1
-pkgdesc="fretsonfire X (FoFiX). Highly improved version of Frets on Fire (GIT Version)"
+pkgdesc="Frets on Fire X (FoFiX). Highly improved version of Frets on Fire (Git Version)"
arch=('i686' 'x86_64')
-url="http://code.google.com/p/fofix/"
+url="https://github.com/fofix/fofix"
license=('GPL')
groups=('games')
-depends=('ffmpeg' 'python2' 'python2-pygame' 'python2-opengl'
-'python2-numpy'
-'python2-imaging' 'pyogg' 'pyvorbis' 'python2-pysqlite' 'libffi' 'cython2' 'soundtouch' 'glu')
+depends=(
+ 'ffmpeg'
+ 'python2'
+ 'python2-pygame'
+ 'python2-opengl'
+ 'python2-numpy'
+ 'python2-imaging'
+ 'pyogg'
+ 'pyvorbis'
+ 'python2-pysqlite'
+ 'libffi'
+ 'cython2'
+ 'soundtouch'
+ 'glu'
+)
optdepends=('pyaudio: microphone support')
makedepends=('git')
install=${pkgname}.install
-source=('fofix-git.desktop' 'fofix-git.png' 'git+http://github.com/fofix/fofix.git')
-md5sums=('b7f141bb1045159e5075ecdb3f59adff' 'f886a7fdfa7592b50aa9f62901910e03' 'SKIP')
+source=(
+ 'fofix-git.desktop'
+ 'fofix-git.png'
+ 'git+http://github.com/fofix/fofix.git'
+)
+md5sums=('7ad2bde66aea003e1cc152b7650453ea'
+ 'f886a7fdfa7592b50aa9f62901910e03'
+ 'SKIP')
pkgver() {
- cd "$_gitname"
- git describe --always | sed 's|-|.|g'
- }
-
-_gitname="fofix"
+ cd "$_gitname"
+ git describe --always | sed 's|-|.|g'
+}
build() {
- cd "$srcdir/fofix"
-
-
-python2 setup.py build_ext --inplace --force
+ cd "$srcdir/fofix"
+ python2 setup.py build_ext --inplace --force
}
package() {
-install -d $pkgdir/usr/
-install -d $pkgdir/usr/share/
-install -d $pkgdir/usr/share/applications/
-install -d $pkgdir/usr/share/pixmaps/
-install -d $pkgdir/usr/bin/
-install -d $pkgdir/opt/
-cd ${srcdir}
-cp ${startdir}/fofix-git.desktop ${pkgdir}/usr/share/applications/
-cp ${startdir}/fofix-git.png ${pkgdir}/usr/share/pixmaps/
-mv ${srcdir}/fofix $pkgdir/opt/fofix-git
-cd $pkgdir/usr/bin/
-echo "#/bin/sh" > fofix-git
-echo "cd /opt/fofix-git/" >> fofix-git
-echo "python2 ./FoFiX.py" >> fofix-git
-chmod +x fofix-git
-chmod -R 777 $pkgdir/opt/fofix-git
+ install -d $pkgdir/usr/
+ install -d $pkgdir/usr/share/
+ install -d $pkgdir/usr/share/applications/
+ install -d $pkgdir/usr/share/pixmaps/
+ install -d $pkgdir/usr/bin/
+ install -d $pkgdir/opt/
+ cd ${srcdir}
+ cp ${startdir}/fofix-git.desktop ${pkgdir}/usr/share/applications/
+ cp ${startdir}/fofix-git.png ${pkgdir}/usr/share/pixmaps/
+ mv ${srcdir}/fofix $pkgdir/opt/fofix-git
+ cd $pkgdir/usr/bin/
+ echo "#/bin/sh" > fofix-git
+ echo "cd /opt/fofix-git/" >> fofix-git
+ echo "python2 ./FoFiX.py" >> fofix-git
+ chmod +x fofix-git
+ chmod -R 777 $pkgdir/opt/fofix-git
}
diff --git a/fofix-git.desktop b/fofix-git.desktop
index 300d395bda24..5c564efe993f 100755
--- a/fofix-git.desktop
+++ b/fofix-git.desktop
@@ -1,6 +1,6 @@
[Desktop Entry]
Type=Application
-Name=FoFiX (GIT)
+Name=FoFiX (Git)
Comment=A great Guitar Hero clone!
Exec=/usr/bin/fofix-git
Encoding=UTF-8
diff --git a/fofix-git.install b/fofix-git.install
index 9f82a0793da0..700668e04808 100755
--- a/fofix-git.install
+++ b/fofix-git.install
@@ -1,12 +1,8 @@
post_install() {
-
-
-echo
-echo "Run 'fofix-git' to start the game. To add songs to the game, add them to '/opt/fofix-git/data/songs' (I don't think it works in ~/.fofix/songs anymore)"
-echo
-echo "If it ever doesn't work, try removing ~/.fofix/fofix.ini"
-echo
-echo "3.020 and higher only include the Megalight themes by default. For more themes, go to http://www.fretsonfire.net/forums/viewtopic.php?f=32&t=24976 and add the themes to /opt/fofix-git/data/themes/"
+ echo
+ echo "Run 'fofix-git' to start the game. To add songs to the game, add them to '/opt/fofix-git/data/songs' (not in ~/.fofix/songs anymore)"
+ echo
+ echo "If it ever doesn't work, try removing ~/.fofix/fofix.ini"
+ echo
+ echo "3.020 and higher only include the Megalight themes by default. For more themes, go to http://www.fretsonfire.net/forums/viewtopic.php?f=32&t=24976 and add the themes to /opt/fofix-git/data/themes/"
}
-
-