summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD40
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..481ccc77f920
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = foliate-2
+ pkgdesc = Version 2 of Foliate: A simple and modern GTK eBook reader
+ pkgver = 2.6.4
+ pkgrel = 3
+ url = https://johnfactotum.github.io/foliate-2/
+ arch = x86_64
+ license = GPL3
+ makedepends = gettext
+ makedepends = meson
+ makedepends = ninja
+ depends = gjs
+ depends = iso-codes
+ depends = webkit2gtk
+ optdepends = dictd: Offline dictionary support
+ optdepends = espeak-ng: Text-to-speech support; also voice package needed
+ optdepends = festival: Text-to-speech support; also voice package needed
+ optdepends = gspell: Spell-checking support
+ optdepends = hyphen: Auto-hyphenation support
+ optdepends = tracker3
+ provides = foliate
+ conflicts = foliate
+ source = https://github.com/johnfactotum/foliate/archive/2.6.4/foliate-2-2.6.4.tar.gz
+ sha256sums = 4a4381bff6e398f6734e1695da23f1c593ba2a67e463e07021a089ffd0741776
+
+pkgname = foliate-2
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..299a400a463d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Archisman Panigrahi <apandada1@gmail.com>
+# Contributor: Caleb Maclennan <caleb@alerque.com>
+# Contributor: Jerome Leclanche <jerome@leclan.ch>
+
+pkgname=foliate-2
+pkgver=2.6.4
+pkgrel=3
+conflicts=('foliate')
+provides=('foliate')
+pkgdesc='Version 2 of Foliate: A simple and modern GTK eBook reader'
+arch=(x86_64)
+url="https://johnfactotum.github.io/$pkgname/"
+license=(GPL3)
+depends=(gjs
+ iso-codes
+ webkit2gtk)
+makedepends=(gettext
+ meson
+ ninja)
+optdepends=('dictd: Offline dictionary support'
+ 'espeak-ng: Text-to-speech support; also voice package needed'
+ 'festival: Text-to-speech support; also voice package needed'
+ 'gspell: Spell-checking support'
+ 'hyphen: Auto-hyphenation support'
+ 'tracker3')
+_archive="$pkgname-$pkgver"
+source=("https://github.com/johnfactotum/foliate/archive/$pkgver/$_archive.tar.gz")
+sha256sums=("4a4381bff6e398f6734e1695da23f1c593ba2a67e463e07021a089ffd0741776")
+
+build() {
+ cd "$_archive"
+ meson build --prefix=/usr
+ ninja -C build
+}
+
+package() {
+ cd "$_archive"
+ DESTDIR="$pkgdir" ninja -C build install
+ ln -sv com.github.johnfactotum.Foliate "$pkgdir/usr/bin/foliate"
+}