summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD51
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7bff537b068
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = folie
+ pkgdesc = Forth Live Explorer is a command-line utility to talk to a micro-controller via a serial port.
+ pkgver = 2.14
+ pkgrel = 4
+ url = https://github.com/jeelabs/folie
+ arch = i686
+ arch = x86_64
+ license = custom:UNLICENSE
+ makedepends = go
+ noextract = folie.tgz
+ noextract = serial.v1.tgz
+ noextract = readline.tgz
+ noextract = goselect.tgz
+ options = !strip
+ options = !emptydirs
+ source = folie.tgz::https://github.com/jeelabs/folie/archive/v2.14.tar.gz
+ source = serial.v1.tgz::https://github.com/bugst/go-serial/archive/eae1344f9f90101f887b08d13391c34399f97873.tar.gz
+ source = readline.tgz::https://github.com/chzyer/readline/archive/94eaec69a77412489ca2cc8916c6e0bc12c40bf1.tar.gz
+ source = goselect.tgz::https://github.com/creack/goselect/archive/528c74964609a58f7c17471525659c9b71cd499b.tar.gz
+ sha1sums = 07ece548fa5b9bc1837f45e6a5eb0b5696c071bb
+ sha1sums = 0aacc9a8c0d536776385216fe4a5e1f0a0e2a75b
+ sha1sums = e8ce5320ec02e6432d28189e02dfe2eb3a4b10a8
+ sha1sums = c5416088463b0f4bf7ceb7062bbd6bce50f4a8fa
+
+pkgname = folie
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7dccc70adc60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Mirko Scholz <mirko dot scholz nine at gmail dot com>
+pkgname=folie
+pkgver=2.14
+pkgrel=4
+pkgdesc="Forth Live Explorer is a command-line utility to talk to a micro-controller via a serial port."
+arch=('i686' 'x86_64')
+url="https://github.com/jeelabs/folie"
+license=('custom:UNLICENSE')
+makedepends=('go')
+options=('!strip' '!emptydirs')
+_serial_ver=eae1344f9f90101f887b08d13391c34399f97873
+_readline_ver=94eaec69a77412489ca2cc8916c6e0bc12c40bf1
+_select_ver=528c74964609a58f7c17471525659c9b71cd499b
+source=(
+folie.tgz::https://github.com/jeelabs/folie/archive/v$pkgver.tar.gz
+serial.v1.tgz::https://github.com/bugst/go-serial/archive/$_serial_ver.tar.gz
+readline.tgz::https://github.com/chzyer/readline/archive/$_readline_ver.tar.gz
+goselect.tgz::https://github.com/creack/goselect/archive/$_select_ver.tar.gz
+)
+noextract=("${source[@]%%::*}")
+sha1sums=('07ece548fa5b9bc1837f45e6a5eb0b5696c071bb'
+ '0aacc9a8c0d536776385216fe4a5e1f0a0e2a75b'
+ 'e8ce5320ec02e6432d28189e02dfe2eb3a4b10a8'
+ 'c5416088463b0f4bf7ceb7062bbd6bce50f4a8fa')
+
+prepare() {
+ cd "$srcdir"
+ [ -d src ] || mkdir src
+ for i in github.com/jeelabs/folie \
+ go.bug.st/serial.v1 \
+ github.com/chzyer/readline \
+ github.com/creack/goselect
+ do
+ cd "$srcdir/src"
+ rm -rf $i
+ mkdir -p $i
+ cd $i
+ bn=`basename $i`
+ tar xzf "$srcdir/$bn.tgz" --strip-components=1
+ done
+ GOPATH="$srcdir" go get -v golang.org/x/sys/unix
+}
+
+build() {
+ GOPATH="$srcdir" go build -v github.com/jeelabs/folie
+}
+
+package() {
+ install -Dm755 "$srcdir/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$srcdir/src/github.com/jeelabs/folie/UNLICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}