summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD13
-rw-r--r--fix-cmake-find-glog.patch18
-rw-r--r--fix-missing-include.patch12
-rw-r--r--fix-test-definitions.patch61
6 files changed, 47 insertions, 72 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36c0823a97d8..3914779ddbaa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = folly
pkgdesc = An open-source C++ library developed and used at Facebook
- pkgver = 2024.02.12.00
+ pkgver = 2024.02.19.00
pkgrel = 1
url = https://github.com/facebook/folly
arch = x86_64
@@ -31,9 +31,11 @@ pkgbase = folly
provides = libfolly_test_util.so
provides = libfollybenchmark.so
options = !lto
- source = folly-2024.02.12.00.tar.gz::https://github.com/facebook/folly/archive/v2024.02.12.00.tar.gz
- source = fix-test-definitions.patch
- sha256sums = 678db01d22e0525168dba33b4eb1c35f0e340f77cad5ee941c05eb25f173519d
- sha256sums = a7f15a6706d652e550bd415342c3027abd9afbb86ec04c764be3a96644efc46e
+ source = folly-2024.02.19.00.tar.gz::https://github.com/facebook/folly/archive/v2024.02.19.00.tar.gz
+ source = fix-cmake-find-glog.patch
+ source = fix-missing-include.patch
+ sha256sums = 4e59f3f95dcccb503f87e677a231c107e7595c610a3f4f2e81d768436e47012f
+ sha256sums = 7655b9d6fd926770dae4d26f67b6aedf8fb6ff03927782bcfeffa09b5138b87c
+ sha256sums = 19cc8b4190e3c7d4ef9d1d9842a2def99bb261711ae85cb03e63787c4995e286
pkgname = folly
diff --git a/.gitignore b/.gitignore
index 88203b7e8a48..8f90ebfc0d2f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,4 +3,5 @@
!.nvchecker.toml
!.SRCINFO
!PKGBUILD
-!fix-test-definitions.patch
+!fix-cmake-find-glog.patch
+!fix-missing-include.patch
diff --git a/PKGBUILD b/PKGBUILD
index e88aa252220c..ea0c1267ffe3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Daichi Shinozaki <dsdseg@gmail.com>
pkgname=folly
-pkgver=2024.02.12.00
+pkgver=2024.02.19.00
pkgrel=1
pkgdesc="An open-source C++ library developed and used at Facebook"
arch=(x86_64)
@@ -44,11 +44,13 @@ provides=(
options=(!lto)
source=(
"$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
- "fix-test-definitions.patch"
+ "fix-cmake-find-glog.patch"
+ "fix-missing-include.patch"
)
sha256sums=(
- '678db01d22e0525168dba33b4eb1c35f0e340f77cad5ee941c05eb25f173519d'
- 'a7f15a6706d652e550bd415342c3027abd9afbb86ec04c764be3a96644efc46e'
+ '4e59f3f95dcccb503f87e677a231c107e7595c610a3f4f2e81d768436e47012f'
+ '7655b9d6fd926770dae4d26f67b6aedf8fb6ff03927782bcfeffa09b5138b87c'
+ '19cc8b4190e3c7d4ef9d1d9842a2def99bb261711ae85cb03e63787c4995e286'
)
_archive="$pkgname-$pkgver"
@@ -56,7 +58,8 @@ _archive="$pkgname-$pkgver"
prepare() {
cd "$_archive"
- patch --forward --strip=1 --input="$srcdir/fix-test-definitions.patch"
+ patch --forward --strip=1 --input="$srcdir/fix-cmake-find-glog.patch"
+ patch --forward --strip=1 --input="$srcdir/fix-missing-include.patch"
}
build() {
diff --git a/fix-cmake-find-glog.patch b/fix-cmake-find-glog.patch
new file mode 100644
index 000000000000..4f03cf1541da
--- /dev/null
+++ b/fix-cmake-find-glog.patch
@@ -0,0 +1,18 @@
+diff --git a/CMake/folly-deps.cmake b/CMake/folly-deps.cmake
+index c72273a73..d0408f2b3 100644
+--- a/CMake/folly-deps.cmake
++++ b/CMake/folly-deps.cmake
+@@ -61,10 +61,9 @@ if(LIBGFLAGS_FOUND)
+ set(FOLLY_LIBGFLAGS_INCLUDE ${LIBGFLAGS_INCLUDE_DIR})
+ endif()
+
+-find_package(Glog MODULE)
+-set(FOLLY_HAVE_LIBGLOG ${GLOG_FOUND})
+-list(APPEND FOLLY_LINK_LIBRARIES ${GLOG_LIBRARY})
+-list(APPEND FOLLY_INCLUDE_DIRECTORIES ${GLOG_INCLUDE_DIR})
++find_package(Glog CONFIG REQUIRED)
++set(FOLLY_HAVE_LIBGLOG True)
++list(APPEND FOLLY_LINK_LIBRARIES glog::glog)
+
+ find_package(LibEvent MODULE REQUIRED)
+ list(APPEND FOLLY_LINK_LIBRARIES ${LIBEVENT_LIB})
diff --git a/fix-missing-include.patch b/fix-missing-include.patch
new file mode 100644
index 000000000000..b7d004d105aa
--- /dev/null
+++ b/fix-missing-include.patch
@@ -0,0 +1,12 @@
+diff --git a/folly/experimental/symbolizer/Elf.cpp b/folly/experimental/symbolizer/Elf.cpp
+index 6a7f74fa4..33b44b4dd 100644
+--- a/folly/experimental/symbolizer/Elf.cpp
++++ b/folly/experimental/symbolizer/Elf.cpp
+@@ -21,6 +21,7 @@
+ #include <sys/types.h>
+ #include <cstring>
+ #include <string>
++#include <unistd.h>
+
+ #include <glog/logging.h>
+
diff --git a/fix-test-definitions.patch b/fix-test-definitions.patch
deleted file mode 100644
index daedd6860f58..000000000000
--- a/fix-test-definitions.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-diff --unified --recursive --text --new-file folly-2024.02.12.00.orig/CMakeLists.txt folly-2024.02.12.00/CMakeLists.txt
---- folly-2024.02.12.00.orig/CMakeLists.txt 2024-02-12 20:17:11.089234762 +0100
-+++ folly-2024.02.12.00/CMakeLists.txt 2024-02-12 20:17:46.119143379 +0100
-@@ -706,14 +706,12 @@
- TEST autotimer_test SOURCES AutoTimerTest.cpp
- TEST bits_test_2 SOURCES BitsTest.cpp
- TEST bitvector_test SOURCES BitVectorCodingTest.cpp
-- TEST dynamic_parser_test SOURCES DynamicParserTest.cpp
- TEST eliasfano_test SOURCES EliasFanoCodingTest.cpp
- TEST event_count_test SOURCES EventCountTest.cpp
- # FunctionSchedulerTest has a lot of timing-dependent checks,
- # and tends to fail on heavily loaded systems.
- TEST function_scheduler_test BROKEN SOURCES FunctionSchedulerTest.cpp
- TEST future_dag_test SOURCES FutureDAGTest.cpp
-- TEST json_schema_test SOURCES JSONSchemaTest.cpp
- TEST lock_free_ring_buffer_test SOURCES LockFreeRingBufferTest.cpp
- #TEST nested_command_line_app_test SOURCES NestedCommandLineAppTest.cpp
- #TEST program_options_test SOURCES ProgramOptionsTest.cpp
-@@ -1005,9 +1003,6 @@
- TEST demangle_test SOURCES DemangleTest.cpp
- TEST deterministic_schedule_test SOURCES DeterministicScheduleTest.cpp
- TEST discriminated_ptr_test SOURCES DiscriminatedPtrTest.cpp
-- TEST dynamic_test SOURCES DynamicTest.cpp
-- TEST dynamic_converter_test SOURCES DynamicConverterTest.cpp
-- TEST dynamic_other_test SOURCES DynamicOtherTest.cpp
- TEST endian_test SOURCES EndianTest.cpp
- TEST exception_test SOURCES ExceptionTest.cpp
- BENCHMARK exception_wrapper_benchmark WINDOWS_DISABLED
-@@ -1045,12 +1040,6 @@
- TEST indestructible_test SOURCES IndestructibleTest.cpp
- TEST indexed_mem_pool_test BROKEN
- SOURCES IndexedMemPoolTest.cpp
-- # MSVC Preprocessor stringizing raw string literals bug
-- TEST json_test WINDOWS_DISABLED SOURCES JsonTest.cpp
-- BENCHMARK json_benchmark SOURCES JsonBenchmark.cpp
-- TEST json_pointer_test SOURCES json_pointer_test.cpp
-- TEST json_patch_test SOURCES json_patch_test.cpp
-- TEST json_other_test SOURCES JsonOtherTest.cpp
- TEST lazy_test SOURCES LazyTest.cpp
- TEST locks_test SOURCES SpinLockTest.cpp
- TEST math_test SOURCES MathTest.cpp
-@@ -1108,6 +1097,19 @@
- BENCHMARK uri_benchmark SOURCES UriBenchmark.cpp
- TEST uri_test SOURCES UriTest.cpp
- TEST varint_test SOURCES VarintTest.cpp
-+
-+ DIRECTORY json/test/
-+ TEST dynamic_converter_test SOURCES DynamicConverterTest.cpp
-+ TEST dynamic_other_test SOURCES DynamicOtherTest.cpp
-+ TEST dynamic_parser_test SOURCES DynamicParserTest.cpp
-+ TEST dynamic_test SOURCES DynamicTest.cpp
-+ # MSVC Preprocessor stringizing raw string literals bug
-+ TEST json_test WINDOWS_DISABLED SOURCES JsonTest.cpp
-+ BENCHMARK json_benchmark SOURCES JsonBenchmark.cpp
-+ TEST json_other_test SOURCES JsonOtherTest.cpp
-+ TEST json_patch_test SOURCES json_patch_test.cpp
-+ TEST json_pointer_test SOURCES json_pointer_test.cpp
-+ TEST json_schema_test SOURCES JSONSchemaTest.cpp
- )
-
- if (${LIBSODIUM_FOUND})