summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD31
-rw-r--r--fix-test-definitions.patch61
4 files changed, 90 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 856716b3daf1..36c0823a97d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = folly
pkgdesc = An open-source C++ library developed and used at Facebook
- pkgver = 2024.02.05.00
+ pkgver = 2024.02.12.00
pkgrel = 1
url = https://github.com/facebook/folly
arch = x86_64
@@ -31,7 +31,9 @@ pkgbase = folly
provides = libfolly_test_util.so
provides = libfollybenchmark.so
options = !lto
- source = folly-2024.02.05.00.tar.gz::https://github.com/facebook/folly/archive/v2024.02.05.00.tar.gz
- sha256sums = aad95c14b237ce489a9976e011f4ae7863716aa990227734b41b173fb6bfcfb3
+ source = folly-2024.02.12.00.tar.gz::https://github.com/facebook/folly/archive/v2024.02.12.00.tar.gz
+ source = fix-test-definitions.patch
+ sha256sums = 678db01d22e0525168dba33b4eb1c35f0e340f77cad5ee941c05eb25f173519d
+ sha256sums = a7f15a6706d652e550bd415342c3027abd9afbb86ec04c764be3a96644efc46e
pkgname = folly
diff --git a/.gitignore b/.gitignore
index 0df2b70016b9..88203b7e8a48 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@
!.nvchecker.toml
!.SRCINFO
!PKGBUILD
+!fix-test-definitions.patch
diff --git a/PKGBUILD b/PKGBUILD
index a819848564e6..e88aa252220c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Daichi Shinozaki <dsdseg@gmail.com>
pkgname=folly
-pkgver=2024.02.05.00
+pkgver=2024.02.12.00
pkgrel=1
pkgdesc="An open-source C++ library developed and used at Facebook"
arch=(x86_64)
@@ -42,12 +42,23 @@ provides=(
libfollybenchmark.so
)
options=(!lto)
-
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('aad95c14b237ce489a9976e011f4ae7863716aa990227734b41b173fb6bfcfb3')
+source=(
+ "$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+ "fix-test-definitions.patch"
+)
+sha256sums=(
+ '678db01d22e0525168dba33b4eb1c35f0e340f77cad5ee941c05eb25f173519d'
+ 'a7f15a6706d652e550bd415342c3027abd9afbb86ec04c764be3a96644efc46e'
+)
_archive="$pkgname-$pkgver"
+prepare() {
+ cd "$_archive"
+
+ patch --forward --strip=1 --input="$srcdir/fix-test-definitions.patch"
+}
+
build() {
cd "$_archive"
@@ -64,15 +75,19 @@ build() {
check() {
cd "$_archive"
- _skipped_tests=(
+ local skipped_tests=(
+ # These tests will fail (by design) if the test execution exceeds a
+ # pre-defined time limit (wall time). This is bound to be flaky in a
+ # package build process, disabling.
+ HHWheelTimerTest.HHWheelTimerTest
+
# Skip failing tests - not sure why they fail
- HHWheelTimerTest.HHWheelTimerTest.CancelTimeout
atomic_unordered_map_test.AtomicUnorderedInsertMap.DISABLEDMegaMap
fbvector_test
xlog_test.XlogTest.perFileCategoryHandling
)
- _skipped_tests_pattern="${_skipped_tests[0]}$(printf '|%s' "${_skipped_tests[@]:1}")"
- ctest --test-dir build --output-on-failure -E "$_skipped_tests_pattern"
+ local skipped_tests_pattern="${skipped_tests[0]}$(printf '|%s' "${skipped_tests[@]:1}")"
+ ctest --test-dir build --output-on-failure -E "$skipped_tests_pattern"
}
package() {
diff --git a/fix-test-definitions.patch b/fix-test-definitions.patch
new file mode 100644
index 000000000000..daedd6860f58
--- /dev/null
+++ b/fix-test-definitions.patch
@@ -0,0 +1,61 @@
+diff --unified --recursive --text --new-file folly-2024.02.12.00.orig/CMakeLists.txt folly-2024.02.12.00/CMakeLists.txt
+--- folly-2024.02.12.00.orig/CMakeLists.txt 2024-02-12 20:17:11.089234762 +0100
++++ folly-2024.02.12.00/CMakeLists.txt 2024-02-12 20:17:46.119143379 +0100
+@@ -706,14 +706,12 @@
+ TEST autotimer_test SOURCES AutoTimerTest.cpp
+ TEST bits_test_2 SOURCES BitsTest.cpp
+ TEST bitvector_test SOURCES BitVectorCodingTest.cpp
+- TEST dynamic_parser_test SOURCES DynamicParserTest.cpp
+ TEST eliasfano_test SOURCES EliasFanoCodingTest.cpp
+ TEST event_count_test SOURCES EventCountTest.cpp
+ # FunctionSchedulerTest has a lot of timing-dependent checks,
+ # and tends to fail on heavily loaded systems.
+ TEST function_scheduler_test BROKEN SOURCES FunctionSchedulerTest.cpp
+ TEST future_dag_test SOURCES FutureDAGTest.cpp
+- TEST json_schema_test SOURCES JSONSchemaTest.cpp
+ TEST lock_free_ring_buffer_test SOURCES LockFreeRingBufferTest.cpp
+ #TEST nested_command_line_app_test SOURCES NestedCommandLineAppTest.cpp
+ #TEST program_options_test SOURCES ProgramOptionsTest.cpp
+@@ -1005,9 +1003,6 @@
+ TEST demangle_test SOURCES DemangleTest.cpp
+ TEST deterministic_schedule_test SOURCES DeterministicScheduleTest.cpp
+ TEST discriminated_ptr_test SOURCES DiscriminatedPtrTest.cpp
+- TEST dynamic_test SOURCES DynamicTest.cpp
+- TEST dynamic_converter_test SOURCES DynamicConverterTest.cpp
+- TEST dynamic_other_test SOURCES DynamicOtherTest.cpp
+ TEST endian_test SOURCES EndianTest.cpp
+ TEST exception_test SOURCES ExceptionTest.cpp
+ BENCHMARK exception_wrapper_benchmark WINDOWS_DISABLED
+@@ -1045,12 +1040,6 @@
+ TEST indestructible_test SOURCES IndestructibleTest.cpp
+ TEST indexed_mem_pool_test BROKEN
+ SOURCES IndexedMemPoolTest.cpp
+- # MSVC Preprocessor stringizing raw string literals bug
+- TEST json_test WINDOWS_DISABLED SOURCES JsonTest.cpp
+- BENCHMARK json_benchmark SOURCES JsonBenchmark.cpp
+- TEST json_pointer_test SOURCES json_pointer_test.cpp
+- TEST json_patch_test SOURCES json_patch_test.cpp
+- TEST json_other_test SOURCES JsonOtherTest.cpp
+ TEST lazy_test SOURCES LazyTest.cpp
+ TEST locks_test SOURCES SpinLockTest.cpp
+ TEST math_test SOURCES MathTest.cpp
+@@ -1108,6 +1097,19 @@
+ BENCHMARK uri_benchmark SOURCES UriBenchmark.cpp
+ TEST uri_test SOURCES UriTest.cpp
+ TEST varint_test SOURCES VarintTest.cpp
++
++ DIRECTORY json/test/
++ TEST dynamic_converter_test SOURCES DynamicConverterTest.cpp
++ TEST dynamic_other_test SOURCES DynamicOtherTest.cpp
++ TEST dynamic_parser_test SOURCES DynamicParserTest.cpp
++ TEST dynamic_test SOURCES DynamicTest.cpp
++ # MSVC Preprocessor stringizing raw string literals bug
++ TEST json_test WINDOWS_DISABLED SOURCES JsonTest.cpp
++ BENCHMARK json_benchmark SOURCES JsonBenchmark.cpp
++ TEST json_other_test SOURCES JsonOtherTest.cpp
++ TEST json_patch_test SOURCES json_patch_test.cpp
++ TEST json_pointer_test SOURCES json_pointer_test.cpp
++ TEST json_schema_test SOURCES JSONSchemaTest.cpp
+ )
+
+ if (${LIBSODIUM_FOUND})