summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO26
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD27
3 files changed, 25 insertions, 53 deletions
diff --git a/.AURINFO b/.AURINFO
deleted file mode 100644
index 45009edd5bfa..000000000000
--- a/.AURINFO
+++ /dev/null
@@ -1,26 +0,0 @@
-pkgbase = folly-git
- pkgdesc = Folly is an open-source C++ library developed and used at Facebook
- pkgver = r1110.81e0e45
- pkgrel = 1
- url = https://github.com/facebook/folly
- arch = i686
- arch = x86_64
- license = Apache
- makedepends = git
- makedepends = boost
- makedepends = python2
- depends = google-glog
- depends = gflags
- depends = double-conversion
- depends = libevent
- depends = xz
- depends = boost-libs
- depends = jemalloc
- depends = lz4
- source = git+https://github.com/facebook/folly.git
- source = http://googletest.googlecode.com/files/gtest-1.6.0.zip
- md5sums = SKIP
- md5sums = 4577b49f2973c90bf9ba69aa8166b786
-
-pkgname = folly-git
-
diff --git a/.SRCINFO b/.SRCINFO
index 40ed20fb31a2..3129c97f28e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,33 @@
pkgbase = folly-git
- pkgdesc = C++ library developed and used at Facebook
- pkgver = 2019.06.17.00.r21.gefaea2394
+ pkgdesc = An open-source C++ library developed and used at Facebook
+ pkgver = 2021.05.31.00.r0.g99fbca1df
pkgrel = 1
url = https://github.com/facebook/folly
- arch = i686
arch = x86_64
license = Apache
+ makedepends = cmake
+ makedepends = gtest
+ makedepends = gmock
makedepends = git
- makedepends = boost
- makedepends = python2
- depends = google-glog
- depends = gflags
+ depends = snappy
+ depends = jemalloc
depends = double-conversion
+ depends = gflags
+ depends = google-glog
depends = libevent
+ depends = boost
depends = boost-libs
- depends = jemalloc
+ depends = fmt
+ depends = openssl
+ depends = zlib
+ depends = bzip2
depends = xz
depends = lz4
depends = zstd
- depends = snappy
+ depends = libsodium
provides = folly
conflicts = folly
source = git+https://github.com/facebook/folly.git
md5sums = SKIP
pkgname = folly-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 64cae47273aa..e4f448e32e16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Contributor: Anatol Pomozov <anatol.pomozov@gmail.com>
# Contributor: Joel Teichroeb <joel@teichroeb.net>
# Contributor: Jonas Heinrich <onny@project-insanity.org>
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=folly-git
-pkgver=2019.06.17.00.r21.gefaea2394
+pkgver=2021.05.31.00.r0.g99fbca1df
pkgrel=1
-pkgdesc='C++ library developed and used at Facebook'
-arch=('i686' 'x86_64')
+pkgdesc="An open-source C++ library developed and used at Facebook"
+arch=('x86_64')
url='https://github.com/facebook/folly'
license=('Apache')
conflicts=('folly')
provides=('folly')
-depends=('google-glog' 'gflags' 'double-conversion' 'libevent' 'boost-libs' 'jemalloc' 'xz' 'lz4' 'zstd' 'snappy')
-makedepends=('git' 'boost' 'python2')
+depends=('snappy' 'jemalloc' 'double-conversion' 'gflags' 'google-glog' 'libevent' 'boost'
+ 'boost-libs' 'fmt' 'openssl' 'zlib' 'bzip2' 'xz' 'lz4' 'zstd' 'libsodium')
+makedepends=('cmake' 'gtest' 'gmock' 'git')
source=(git+https://github.com/facebook/folly.git)
md5sums=('SKIP')
@@ -22,21 +23,13 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd folly/folly
- find -name '*.py' -exec sed -i 's|^#!/usr/bin/env python$|#!/usr/bin/env python2|' {} \;
-}
-
build() {
cd folly
- cmake . \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DBUILD_SHARED_LIBS=ON \
- -DCMAKE_CXX_FLAGS="$CXXFLAGS -fPIC"
+ cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo -DCMAKE_INSTALL_PREFIX=/usr -S . -B _build
+ cmake --build _build
}
package() {
cd folly
- make DESTDIR="$pkgdir" install
+ cmake --build _build --target install -- DESTDIR="$pkgdir/"
}