summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore8
-rw-r--r--CHANGELOG7
-rw-r--r--PKGBUILD71
-rw-r--r--elementary-theme.patch2
5 files changed, 59 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 060eee32fb63..045a80ada8de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,22 @@
pkgbase = fondo
pkgdesc = Wallpaper App for Linux
- pkgver = 1.3.8
- pkgrel = 1
+ pkgver = 1.6.1
+ pkgrel = 4
url = https://github.com/calo001/fondo
- changelog = CHANGELOG
arch = x86_64
- license = GPL3
+ license = AGPL-3.0-or-later
makedepends = git
makedepends = meson
makedepends = vala
+ depends = elementary-icon-theme
depends = granite
- depends = libsoup
- depends = json-glib
depends = gtk-theme-elementary
- depends = elementary-icon-theme
- conflicts = fondo-git
- source = git+https://github.com/calo001/fondo.git#tag=1.3.8
+ depends = json-glib
+ depends = libhandy
+ depends = libsoup
+ source = fondo::git+https://github.com/calo001/fondo.git#tag=1.6.1
source = elementary-theme.patch
sha256sums = SKIP
- sha256sums = 572d2b1e8bc3acac50dd43e8dee5982560d1c794561744ced69c9670c5243907
+ sha256sums = e2204425522f276d7604f7a3b6471d85cc8d11ede2b2d6b12d66a254f581ec9b
pkgname = fondo
-
diff --git a/.gitignore b/.gitignore
index a4b7ce508525..018a3de08144 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-/fondo
-/pkg
-/src
-*.tar.xz
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/CHANGELOG b/CHANGELOG
deleted file mode 100644
index 7f53c296f60d..000000000000
--- a/CHANGELOG
+++ /dev/null
@@ -1,7 +0,0 @@
-v1.3.8
-======
-- Back to the classic appearance.
-- Fix language codes.
-- Improve the way translations files are setting.
-- The width and height are shown in each photo.
-- Fix greeter don't getting wallpaper set via Fondo.
diff --git a/PKGBUILD b/PKGBUILD
index 16c9b0f38dc8..3f9e2aec1d4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,55 @@
-# Maintainer: Nahuel Gomez Castro <nahual_gomca@outlook.com.ar>
+# Maintainer:
+# Contributor: Tomoghno Sen <tomoghno@outlook.com>
-pkgname='fondo'
-pkgver=1.3.8
-pkgrel=1
+_pkgname="fondo"
+pkgname="$_pkgname"
+pkgver=1.6.1
+pkgrel=4
pkgdesc='Wallpaper App for Linux'
+url="https://github.com/calo001/fondo"
+license=('AGPL-3.0-or-later')
arch=('x86_64')
-changelog='CHANGELOG'
-url="https://github.com/calo001/${pkgname}"
-license=('GPL3')
-depends=('granite' 'libsoup' 'json-glib' 'gtk-theme-elementary' 'elementary-icon-theme')
-makedepends=('git' 'meson' 'vala')
-conflicts=("${pkgname}-git")
-source=("git+${url}.git#tag=${pkgver}"
- "elementary-theme.patch")
-sha256sums=('SKIP'
- '572d2b1e8bc3acac50dd43e8dee5982560d1c794561744ced69c9670c5243907')
-pkgver () {
- cd ${pkgname}
- git describe --tags | sed 's/-/.r/; s/-/./'
-}
+depends=(
+ 'elementary-icon-theme'
+ 'granite'
+ 'gtk-theme-elementary'
+ 'json-glib'
+ 'libhandy'
+ 'libsoup'
+
+ ## implicit
+ #dconf
+ #glib2
+ #gtk3
+ #hicolor-icon-theme
+ #libgee
+)
+makedepends=(
+ 'git'
+ 'meson'
+ 'vala'
+)
+
+source=(
+ "$_pkgname"::"git+$url.git#tag=$pkgver"
+ "elementary-theme.patch"
+)
+sha256sums=(
+ 'SKIP'
+ 'e2204425522f276d7604f7a3b6471d85cc8d11ede2b2d6b12d66a254f581ec9b'
+)
-prepare () {
- cd ${pkgname}
- patch -p1 < "${srcdir}/elementary-theme.patch"
+prepare() {
+ cd "$_pkgname"
+ patch -p1 -i "../elementary-theme.patch"
}
-build () {
- arch-meson ${pkgname} build
- ninja -C build
+build() {
+ arch-meson "$_pkgname" build
+ meson compile -C build
}
-package () {
- DESTDIR="${pkgdir}" ninja -C build install
+package() {
+ meson install -C build --destdir "$pkgdir"
}
diff --git a/elementary-theme.patch b/elementary-theme.patch
index 2b2ec8d0260a..74e38f3b6f65 100644
--- a/elementary-theme.patch
+++ b/elementary-theme.patch
@@ -6,7 +6,7 @@ index 026cad4..f521e73 100644
* @return {@code void}
*/
public override void activate () {
-+ Gtk.Settings.get_default ().gtk_theme_name = "elementary";
++ Gtk.Settings.get_default ().gtk_theme_name = "io.elementary.stylesheet.blueberry";
+ Gtk.Settings.get_default ().gtk_icon_theme_name = "elementary";
+
if (controller == null) {