summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--LICENSE33
-rw-r--r--PKGBUILD37
3 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d984634bb21f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = font-kurier
+ pkgdesc = Font Kurier by Malgorzata Budyta
+ pkgver = 0.995
+ pkgrel = 2
+ url = http://jmn.pl/kurier-i-iwona/
+ arch = any
+ license = custom:GUST
+ depends = fontconfig
+ source = http://jmn.pl/pliki/Kurier-ttf-0_995.zip
+ source = http://jmn.pl/pliki/Kurier-otf-0_995.zip
+ source = LICENSE
+ md5sums = 636124244664ec027493e74a89964745
+ md5sums = d2a927505d0597a251db384e51c7ff22
+ md5sums = 3eb34a8f035799bd0a2beef4626c314e
+ sha256sums = ef51e34af788a03528a982f2493983a468feb714341337fdb38711077becd833
+ sha256sums = 519a8dfec4446337f398646a243ef006c2b53ed9d7493b76e320b4205e1b39d0
+ sha256sums = 4b3359f51f8a203dca048088bc63acbb57f379e83bef9e0b0f294b9a47394725
+
+pkgname = ttf-kurier
+
+pkgname = otf-kurier
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..bf92ad673c4e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,33 @@
+%%% This is a preliminary version, barring acceptance from the
+%%% LaTeX Project Team and other feedback, of the GUST Font Nosource
+%%% License. This license is for use with free fonts distributed
+%%% without source code, e.g., fonts created with visual tools.
+%%%
+%%% For the most recent version of this license see
+%%% http://www.gust.org.pl/fonts/licenses/GUST-FONT-NOSOURCE-LICENSE.txt
+%%% or
+%%% http://tug.org/fonts/licenses/GUST-FONT-NOSOURCE-LICENSE.txt
+%
+% This work may be distributed and/or modified under the conditions
+% of the LaTeX Project Public License, either version 1.3a of this
+% license or (at your option) any later version, provided that the
+% following additional clauses are observed:
+%
+% 1) As there is no universally relevant concept of font source files,
+% no distinction is made between "Work" and "Compiled Work"; hence,
+% the relevant clauses of the LaTeX Project Public License should
+% be interpreted accordingly.
+% 2) Due to the nature of fonts, clause 6a of the LaTeX Project Public
+% License, version 1.3a, does not apply. A later version of the
+% LaTeX Project Public License may number or word this clause
+% differently; it is the substance that is important.
+% 3) It is requested, but not legally required, that derived works be
+% distributed only after changing the names of the fonts comprising
+% this work and given in the accompanying file MANIFEST.txt, and
+% that the files comprising the Work, as listed in MANIFEST.txt also
+% be given new names. Any exceptions to this request are also given
+% in MANIFEST.txt.
+%
+% The latest version of the LaTeX Project Public License is in
+% http://www.latex-project.org/lppl.txt and version 1.3a or later
+% is part of all distributions of LaTeX version 2004/10/01 or later. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5134e126ab0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributor: Vladimir Navrat <vn158 at seznam dot cz>
+
+pkgbase=font-kurier
+pkgname=(ttf-kurier otf-kurier)
+pkgver=0.995
+pkgrel=2
+pkgdesc="Font Kurier by Malgorzata Budyta"
+arch=(any)
+license=('custom:GUST')
+url="http://jmn.pl/kurier-i-iwona/"
+depends=(fontconfig)
+source=("http://jmn.pl/pliki/Kurier-ttf-0_995.zip" "http://jmn.pl/pliki/Kurier-otf-0_995.zip" LICENSE)
+
+md5sums=('636124244664ec027493e74a89964745'
+ 'd2a927505d0597a251db384e51c7ff22'
+ '3eb34a8f035799bd0a2beef4626c314e')
+sha256sums=('ef51e34af788a03528a982f2493983a468feb714341337fdb38711077becd833'
+ '519a8dfec4446337f398646a243ef006c2b53ed9d7493b76e320b4205e1b39d0'
+ '4b3359f51f8a203dca048088bc63acbb57f379e83bef9e0b0f294b9a47394725')
+
+package_ttf-kurier() {
+ cd ${startdir}
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+ cd ${startdir}/src
+ install -d "$pkgdir/usr/share/fonts/TTF"
+ install -m644 *.ttf "$pkgdir/usr/share/fonts/TTF"
+}
+
+package_otf-kurier() {
+ cd ${startdir}
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+ cd ${startdir}/src
+ install -d "$pkgdir/usr/share/fonts/OTF"
+ install -m644 otf/*.otf "$pkgdir/usr/share/fonts/OTF"
+}