summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore15
-rw-r--r--29-replace-bitmap-fonts.conf43
-rw-r--r--PKGBUILD78
-rw-r--r--fontconfig-git.install39
5 files changed, 198 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75e0ce7cd938
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = fontconfig-git
+ pkgdesc = A library for configuring and customizing font access
+ pkgver = 2.11.94.r1772
+ pkgrel = 1
+ url = http://www.fontconfig.org/release/
+ install = fontconfig-git.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = gperf
+ makedepends = python
+ depends = expat
+ depends = freetype2
+ provides = fontconfig
+ conflicts = fontconfig
+ options = !libtool
+ source = fontconfig-git::git://anongit.freedesktop.org/fontconfig
+ source = 29-replace-bitmap-fonts.conf
+ sha256sums = SKIP
+ sha256sums = 00911ca1b6e15bb57eb11a5ca5c4f45b721e5bd7a0f57ec2d05091702ae36cde
+
+pkgname = fontconfig-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d4d9f6c48346
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,15 @@
+*~
+pkg/
+src/
+*.gz
+*.bz2
+*.xz
+*.lzo
+*.xz4
+*.tgz
+*.tbz
+*.txz
+*.tar
+*.jar
+*.zip
+fontconfig-git
diff --git a/29-replace-bitmap-fonts.conf b/29-replace-bitmap-fonts.conf
new file mode 100644
index 000000000000..c22bee6212d6
--- /dev/null
+++ b/29-replace-bitmap-fonts.conf
@@ -0,0 +1,43 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+ <!-- Replace generic bitmap font names by generic font families.
+ These font-families will get replaced by other rules and
+ default to scaled ones. -->
+ <match target="pattern">
+ <test name="family" qual="any">
+ <string>Helvetica</string>
+ </test>
+ <edit mode="assign" name="family">
+ <string>Helvetica Std</string>
+ <string>Arial</string>
+ <string>Liberation Sans</string>
+ <string>Nimbus Sans</string>
+ <string>sans-serif</string>
+ </edit>
+ </match>
+ <match target="pattern">
+ <test name="family" qual="any">
+ <string>Courier</string>
+ </test>
+ <edit mode="assign" name="family">
+ <string>Courier Std</string>
+ <string>Courier New</string>
+ <string>Liberation Mono</string>
+ <string>Nimbus Mono</string>
+ <string>monospace</string>
+ </edit>
+ </match>
+ <match target="pattern">
+ <test name="family" qual="any">
+ <string>Times</string>
+ </test>
+ <edit mode="assign" name="family">
+ <string>Times Std</string>
+ <string>Times New Roman</string>
+ <string>Liberation Serif</string>
+ <string>Nimbus Roman</string>
+ <string>serif</string>
+ </edit>
+ </match>
+</fontconfig>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d812d094026
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,78 @@
+# Maintainer: See AUR page for current maintainer.
+# Contributor: Yichao Yu <yyc1992@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgname=fontconfig-git
+pkgver=2.11.94.r1772
+pkgrel=1
+pkgdesc="A library for configuring and customizing font access"
+arch=(i686 x86_64)
+url="http://www.fontconfig.org/release/"
+license=('custom')
+depends=('expat' 'freetype2')
+# You need to pick your python poison here and below in the prepare
+# section untill I get around to create the python packages.
+makedepends=('gperf' 'python')
+options=('!libtool')
+conflicts=('fontconfig')
+provides=('fontconfig')
+install=$pkgname.install
+source=("$pkgname::git://anongit.freedesktop.org/fontconfig"
+ '29-replace-bitmap-fonts.conf')
+sha256sums=('SKIP'
+ '00911ca1b6e15bb57eb11a5ca5c4f45b721e5bd7a0f57ec2d05091702ae36cde')
+
+pkgver() {
+ cd "$pkgname"
+ printf "%s.r%s" \
+ "$(git describe --abbrev=0 | sed 's/^v//')" \
+ "$(git rev-list --count HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ # #$&$%&@! upstream forced python extension compiling down our
+ # throats, be cursed. No flags to turn that off.
+
+ # If you want to use Python 2 you know what to do (lots of sed are
+ # involved).
+ PYTHON=/usr/bin/python
+
+ # I doubt it is smart to change the dependency from expat to lxml2.
+ # I don't like breaking away from upstream packaging
+ # too much, unless really needed.
+ # As is, expat works fine; otherwise you are on your own.
+ ./autogen.sh --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-templatedir=/etc/fonts/conf.avail \
+ --with-xmldir=/etc/fonts \
+ --localstatedir=/var \
+ --disable-static \
+ --with-default-fonts=/usr/share/fonts \
+ --with-add-fonts=/usr/share/fonts
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir" install
+
+ # Not in upstream, not in FC and not in Gentoo, although this probably should.
+ # This satisfies pages like
+ # http://zipcon.net/~swhite/docs/computers/browsers/fonttest.html
+ #
+ install -dm755 "$pkgdir"/etc/fonts/{conf.d,conf.avail}
+ install -m644 "$srcdir/29-replace-bitmap-fonts.conf" \
+ "$pkgdir/etc/fonts/conf.avail"
+ #
+ #
+ # Enable configuration below if you want...
+ #
+ #ln -s /etc/fonts/conf.avail/29-replace-bitmap-fonts.conf \
+ # "$pkgdir/etc/fonts/conf.d"
+
+ #Install license
+ install -m755 -d "$pkgdir/usr/share/licenses/$pkgname"
+ install -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname"
+}
diff --git a/fontconfig-git.install b/fontconfig-git.install
new file mode 100644
index 000000000000..3a0ca573b8f6
--- /dev/null
+++ b/fontconfig-git.install
@@ -0,0 +1,39 @@
+post_install() {
+ cat << _EOF
+
+ Fontconfig configuration is done via /etc/fonts/conf.avail and conf.d.
+ Read /etc/fonts/conf.d/README for more information.
+
+ Configuration via /etc/fonts/local.conf is still possible,
+ but is no longer recommended for options available in conf.avail.
+
+ Main systemwide configuration should be done by symlinks
+ (especially for autohinting, sub-pixel and lcdfilter):
+
+ cd /etc/fonts/conf.d
+ ln -s ../conf.avail/XX-foo.conf
+
+ Check also https://wiki.archlinux.org/index.php/Font_Configuration
+ and https://wiki.archlinux.org/index.php/Fonts.
+
+_EOF
+
+ echo -n "updating font cache... "
+ /usr/bin/fc-cache -f
+ echo "done."
+}
+
+post_upgrade() {
+ echo -n "updating font cache... "
+ /usr/bin/fc-cache -f
+ echo "done."
+}
+
+post_remove() {
+ cat << _EOF
+
+ Check for dead symlinks and leftover files
+ in /etc/fonts/conf.d/
+
+_EOF
+}