summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD101
-rw-r--r--fontconfig-git.hook11
-rw-r--r--fontconfig-git.install6
4 files changed, 67 insertions, 70 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75e0ce7cd938..3a117b8eb88a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,22 +2,27 @@ pkgbase = fontconfig-git
pkgdesc = A library for configuring and customizing font access
pkgver = 2.11.94.r1772
pkgrel = 1
- url = http://www.fontconfig.org/release/
+ url = https://www.freedesktop.org/wiki/Software/fontconfig/
install = fontconfig-git.install
- arch = i686
arch = x86_64
license = custom
+ makedepends = git
+ makedepends = autoconf-archive
makedepends = gperf
- makedepends = python
+ makedepends = python-lxml
+ makedepends = python-six
+ makedepends = docbook-utils
+ makedepends = docbook-sgml
+ makedepends = perl-sgmls
+ makedepends = texlive-formatextra
+ makedepends = json-c
depends = expat
depends = freetype2
provides = fontconfig
conflicts = fontconfig
- options = !libtool
- source = fontconfig-git::git://anongit.freedesktop.org/fontconfig
- source = 29-replace-bitmap-fonts.conf
+ source = git+https://anongit.freedesktop.org/git/fontconfig
+ source = fontconfig-git.hook
sha256sums = SKIP
- sha256sums = 00911ca1b6e15bb57eb11a5ca5c4f45b721e5bd7a0f57ec2d05091702ae36cde
pkgname = fontconfig-git
diff --git a/PKGBUILD b/PKGBUILD
index 0d812d094026..3ec600338100 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,78 +1,61 @@
-# Maintainer: See AUR page for current maintainer.
+# Maintainer: Vincent Grande <shoober420@gmail.com>
# Contributor: Yichao Yu <yyc1992@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=fontconfig-git
pkgver=2.11.94.r1772
pkgrel=1
pkgdesc="A library for configuring and customizing font access"
-arch=(i686 x86_64)
-url="http://www.fontconfig.org/release/"
-license=('custom')
-depends=('expat' 'freetype2')
-# You need to pick your python poison here and below in the prepare
-# section untill I get around to create the python packages.
-makedepends=('gperf' 'python')
-options=('!libtool')
-conflicts=('fontconfig')
-provides=('fontconfig')
-install=$pkgname.install
-source=("$pkgname::git://anongit.freedesktop.org/fontconfig"
- '29-replace-bitmap-fonts.conf')
-sha256sums=('SKIP'
- '00911ca1b6e15bb57eb11a5ca5c4f45b721e5bd7a0f57ec2d05091702ae36cde')
+arch=(x86_64)
+url="https://www.freedesktop.org/wiki/Software/fontconfig/"
+license=(custom)
+depends=(expat freetype2)
+makedepends=(git autoconf-archive gperf python-lxml python-six docbook-utils docbook-sgml
+ perl-sgmls texlive-formatextra json-c)
+conflicts=(fontconfig)
+provides=(fontconfig)
+install=fontconfig-git.install
+source=("git+https://anongit.freedesktop.org/git/fontconfig"
+ fontconfig-git.hook)
+sha256sums=(SKIP)
pkgver() {
- cd "$pkgname"
- printf "%s.r%s" \
- "$(git describe --abbrev=0 | sed 's/^v//')" \
- "$(git rev-list --count HEAD)"
+ cd fontconfig
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd fontconfig
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd "$srcdir/$pkgname"
-
- # #$&$%&@! upstream forced python extension compiling down our
- # throats, be cursed. No flags to turn that off.
+ cd fontconfig
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-templatedir=/etc/fonts/conf.avail \
+ --with-xmldir=/etc/fonts \
+ --localstatedir=/var \
+ --disable-static \
+ --with-default-fonts=/usr/share/fonts \
+ --with-add-fonts=/usr/local/share/fonts
+ make
+}
- # If you want to use Python 2 you know what to do (lots of sed are
- # involved).
- PYTHON=/usr/bin/python
+check() {
+ cd fontconfig
+ make -k check
+}
- # I doubt it is smart to change the dependency from expat to lxml2.
- # I don't like breaking away from upstream packaging
- # too much, unless really needed.
- # As is, expat works fine; otherwise you are on your own.
- ./autogen.sh --prefix=/usr \
- --sysconfdir=/etc \
- --with-templatedir=/etc/fonts/conf.avail \
- --with-xmldir=/etc/fonts \
- --localstatedir=/var \
- --disable-static \
- --with-default-fonts=/usr/share/fonts \
- --with-add-fonts=/usr/share/fonts
- make
+_install_conf() {
+ install -m644 "$1" "$pkgdir/etc/fonts/conf.avail"
+ ln -s "../conf.avail/${1##*/}" "$pkgdir/etc/fonts/conf.d"
}
package() {
- cd "$srcdir/$pkgname"
+ cd fontconfig
make DESTDIR="$pkgdir" install
-
- # Not in upstream, not in FC and not in Gentoo, although this probably should.
- # This satisfies pages like
- # http://zipcon.net/~swhite/docs/computers/browsers/fonttest.html
- #
- install -dm755 "$pkgdir"/etc/fonts/{conf.d,conf.avail}
- install -m644 "$srcdir/29-replace-bitmap-fonts.conf" \
- "$pkgdir/etc/fonts/conf.avail"
- #
- #
- # Enable configuration below if you want...
- #
- #ln -s /etc/fonts/conf.avail/29-replace-bitmap-fonts.conf \
- # "$pkgdir/etc/fonts/conf.d"
-
- #Install license
- install -m755 -d "$pkgdir/usr/share/licenses/$pkgname"
- install -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/fontconfig/COPYING"
+ install -Dm644 ../fontconfig-git.hook "$pkgdir/usr/share/libalpm/hooks/fontconfig-git.hook"
}
diff --git a/fontconfig-git.hook b/fontconfig-git.hook
new file mode 100644
index 000000000000..0f24bc4e86f2
--- /dev/null
+++ b/fontconfig-git.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/share/fonts/*
+
+[Action]
+Description = Updating fontconfig cache...
+When = PostTransaction
+Exec = /usr/bin/fc-cache -s
diff --git a/fontconfig-git.install b/fontconfig-git.install
index 3a0ca573b8f6..cc7341f128f7 100644
--- a/fontconfig-git.install
+++ b/fontconfig-git.install
@@ -18,14 +18,12 @@ post_install() {
_EOF
- echo -n "updating font cache... "
- /usr/bin/fc-cache -f
- echo "done."
+ post_upgrade $1
}
post_upgrade() {
echo -n "updating font cache... "
- /usr/bin/fc-cache -f
+ /usr/bin/fc-cache -rs
echo "done."
}