summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--0001-glibc-2.25-Avoid-conflicts-with-integer-width-macros-from-TS-18.patch72
-rw-r--r--PKGBUILD23
3 files changed, 89 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbd23bad0ca1..7417b56c01f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,9 +17,11 @@ pkgbase = fontconfig-ubuntu
source = https://launchpad.net/ubuntu/+archive/primary/+files/fontconfig_2.11.94.orig.tar.bz2
source = https://launchpad.net/ubuntu/+archive/primary/+files/fontconfig_2.11.94-0ubuntu2.debian.tar.xz
source = 53-monospace-lcd-filter.patch
+ source = 0001-glibc-2.25-Avoid-conflicts-with-integer-width-macros-from-TS-18.patch
md5sums = c988ea12f4117330246e041109152b4a
md5sums = 1527bc9abef9c13eef6178b4369dda2e
md5sums = a17e48be6a06bc056574be6756cb9738
+ md5sums = eb0c6e936a485de81dafcd7a55088fe1
pkgname = fontconfig-ubuntu
diff --git a/0001-glibc-2.25-Avoid-conflicts-with-integer-width-macros-from-TS-18.patch b/0001-glibc-2.25-Avoid-conflicts-with-integer-width-macros-from-TS-18.patch
new file mode 100644
index 000000000000..cad71707adc0
--- /dev/null
+++ b/0001-glibc-2.25-Avoid-conflicts-with-integer-width-macros-from-TS-18.patch
@@ -0,0 +1,72 @@
+From 20cddc824c6501c2082cac41b162c34cd5fcc530 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 11 Dec 2016 14:32:00 -0800
+Subject: [PATCH] Avoid conflicts with integer width macros from TS
+ 18661-1:2014
+
+glibc 2.25+ has now defined these macros in <limits.h>
+https://sourceware.org/git/?p=glibc.git;a=commit;h=5b17fd0da62bf923cb61d1bb7b08cf2e1f1f9c1a
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Submitted
+
+ fontconfig/fontconfig.h | 2 +-
+ src/fcobjs.h | 2 +-
+ src/fcobjshash.gperf | 2 +-
+ src/fcobjshash.h | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+Index: fontconfig-2.12.1/fontconfig/fontconfig.h
+===================================================================
+--- fontconfig-2.12.1.orig/fontconfig/fontconfig.h
++++ fontconfig-2.12.1/fontconfig/fontconfig.h
+@@ -128,7 +128,8 @@ typedef int FcBool;
+ #define FC_USER_CACHE_FILE ".fonts.cache-" FC_CACHE_VERSION
+
+ /* Adjust outline rasterizer */
+-#define FC_CHAR_WIDTH "charwidth" /* Int */
++#define FC_CHARWIDTH "charwidth" /* Int */
++#define FC_CHAR_WIDTH FC_CHARWIDTH
+ #define FC_CHAR_HEIGHT "charheight"/* Int */
+ #define FC_MATRIX "matrix" /* FcMatrix */
+
+Index: fontconfig-2.12.1/src/fcobjs.h
+===================================================================
+--- fontconfig-2.12.1.orig/src/fcobjs.h
++++ fontconfig-2.12.1/src/fcobjs.h
+@@ -51,7 +51,7 @@ FC_OBJECT (DPI, FcTypeDouble, NULL)
+ FC_OBJECT (RGBA, FcTypeInteger, NULL)
+ FC_OBJECT (SCALE, FcTypeDouble, NULL)
+ FC_OBJECT (MINSPACE, FcTypeBool, NULL)
+-FC_OBJECT (CHAR_WIDTH, FcTypeInteger, NULL)
++FC_OBJECT (CHARWIDTH, FcTypeInteger, NULL)
+ FC_OBJECT (CHAR_HEIGHT, FcTypeInteger, NULL)
+ FC_OBJECT (MATRIX, FcTypeMatrix, NULL)
+ FC_OBJECT (CHARSET, FcTypeCharSet, FcCompareCharSet)
+Index: fontconfig-2.12.1/src/fcobjshash.gperf
+===================================================================
+--- fontconfig-2.12.1.orig/src/fcobjshash.gperf
++++ fontconfig-2.12.1/src/fcobjshash.gperf
+@@ -44,7 +44,7 @@ int id;
+ "rgba",FC_RGBA_OBJECT
+ "scale",FC_SCALE_OBJECT
+ "minspace",FC_MINSPACE_OBJECT
+-"charwidth",FC_CHAR_WIDTH_OBJECT
++"charwidth",FC_CHARWIDTH_OBJECT
+ "charheight",FC_CHAR_HEIGHT_OBJECT
+ "matrix",FC_MATRIX_OBJECT
+ "charset",FC_CHARSET_OBJECT
+Index: fontconfig-2.12.1/src/fcobjshash.h
+===================================================================
+--- fontconfig-2.12.1.orig/src/fcobjshash.h
++++ fontconfig-2.12.1/src/fcobjshash.h
+@@ -284,7 +284,7 @@ FcObjectTypeLookup (register const char
+ {(int)(long)&((struct FcObjectTypeNamePool_t *)0)->FcObjectTypeNamePool_str43,FC_CHARSET_OBJECT},
+ {-1},
+ #line 47 "fcobjshash.gperf"
+- {(int)(long)&((struct FcObjectTypeNamePool_t *)0)->FcObjectTypeNamePool_str45,FC_CHAR_WIDTH_OBJECT},
++ {(int)(long)&((struct FcObjectTypeNamePool_t *)0)->FcObjectTypeNamePool_str45,FC_CHARWIDTH_OBJECT},
+ #line 48 "fcobjshash.gperf"
+ {(int)(long)&((struct FcObjectTypeNamePool_t *)0)->FcObjectTypeNamePool_str46,FC_CHAR_HEIGHT_OBJECT},
+ #line 55 "fcobjshash.gperf"
diff --git a/PKGBUILD b/PKGBUILD
index 0957475b3e24..9a5bfab4cab9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Det
# Contributors: Joris Steyn, Florian Dejonckheere, Tevin Zhang, Andrea Fagiani, Biru Ionut, Paul Bredbury
-# Installation order: freetype2-ubuntu → fontconfig-ubuntu → cairo-ubuntu
+# Installation order: freetype2 → fontconfig-ubuntu → cairo-ubuntu
pkgname=fontconfig-ubuntu
pkgver=2.11.94
@@ -18,30 +18,37 @@ options=('!libtool')
install=$pkgname.install
source=("https://launchpad.net/ubuntu/+archive/primary/+files/fontconfig_$pkgver.orig.tar.bz2"
"https://launchpad.net/ubuntu/+archive/primary/+files/fontconfig_$pkgver-$_ubver.debian.tar.xz"
- '53-monospace-lcd-filter.patch')
+ '53-monospace-lcd-filter.patch'
+ '0001-glibc-2.25-Avoid-conflicts-with-integer-width-macros-from-TS-18.patch')
md5sums=('c988ea12f4117330246e041109152b4a'
'1527bc9abef9c13eef6178b4369dda2e'
- 'a17e48be6a06bc056574be6756cb9738')
+ 'a17e48be6a06bc056574be6756cb9738'
+ 'eb0c6e936a485de81dafcd7a55088fe1')
-# a nice page to test font matching:
+# nice pages to test font matching:
# http://zipcon.net/~swhite/docs/computers/browsers/fonttest.html
# http://getemoji.com/
prepare() {
cd fontconfig-$pkgver
- # loop debian patches
+ # Loop Debian patches
for _f in $(cat ../debian/patches/series); do
+ msg2 "Applying Debian patch: $_f"
patch -Np1 -i "../debian/patches/$_f"
done
+ # Glibc 2.25
+ msg2 "Applying Glibc 2.25 fix"
+ patch -Np1 -i "$srcdir"/0001-glibc-2.25-Avoid-conflicts-with-integer-width-macros-from-TS-18.patch
+
## patch
#patch -u conf.d/53-monospace-lcd-filter.conf ../53-monospace-lcd-filter.patch
}
build() {
cd fontconfig-$pkgver
-
+
msg2 "Running ./configure.."
./configure --prefix=/usr \
--sysconfdir=/etc \
@@ -51,14 +58,14 @@ build() {
--disable-static \
--with-default-fonts=/usr/share/fonts \
--with-add-fonts=/usr/share/fonts
-
+
msg2 "Running make.."
make
}
package() {
cd fontconfig-$pkgver
-
+
msg2 "Running 'make install'.."
make DESTDIR="$pkgdir" install