summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO42
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD58
3 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4c4a5c16d0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = foo-yc20
+ pkgdesc = This is a Faust implementation of a 1969 designed Yamaha combo organ, the YC-20. Available on the web, as a VST and LV2 plugins and a standalone version.
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/sampov2/foo-yc20
+ arch = x86_64
+ arch = i686
+ license = BSD
+ depends = atk
+ depends = cairo
+ depends = fontconfig
+ depends = freetype2
+ depends = gdk-pixbuf2
+ depends = graphite
+ depends = gtk2
+ depends = harfbuzz
+ depends = jack
+ depends = libdatrie
+ depends = libglvnd
+ depends = libpng
+ depends = libthai
+ depends = libx11
+ depends = libxau
+ depends = libxcb
+ depends = libxcomposite
+ depends = libxcursor
+ depends = libxdamage
+ depends = libxdmcp
+ depends = libxext
+ depends = libxfixes
+ depends = libxi
+ depends = libxinerama
+ depends = libxrandr
+ depends = libxrender
+ depends = pango
+ depends = pixman
+ provides = foo-yc20
+ source = https://github.com/sampov2/foo-yc20/archive/1.3.0.tar.gz
+ md5sums = c37dda7d5fee4a134f1ec7c5994c890f
+
+pkgname = foo-yc20
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9917406ea45d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.pkg.tar.xz
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b00e3e12176
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=foo-yc20
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="This is a Faust implementation of a 1969 designed Yamaha combo organ, the YC-20. Available on the web, as a VST and LV2 plugins and a standalone version."
+arch=("x86_64" "i686")
+url="https://github.com/sampov2/foo-yc20"
+license=('BSD')
+depends=(
+ 'atk'
+ 'cairo'
+ 'fontconfig'
+ 'freetype2'
+ 'gdk-pixbuf2'
+ 'graphite'
+ 'gtk2'
+ 'harfbuzz'
+ 'jack'
+ 'libdatrie'
+ 'libglvnd'
+ 'libpng'
+ 'libthai'
+ 'libx11'
+ 'libxau'
+ 'libxcb'
+ 'libxcomposite'
+ 'libxcursor'
+ 'libxdamage'
+ 'libxdmcp'
+ 'libxext'
+ 'libxfixes'
+ 'libxi'
+ 'libxinerama'
+ 'libxrandr'
+ 'libxrender'
+ 'pango'
+ 'pixman'
+)
+provides=('foo-yc20')
+source=("https://github.com/sampov2/foo-yc20/archive/1.3.0.tar.gz")
+md5sums=('c37dda7d5fee4a134f1ec7c5994c890f')
+
+
+
+build() {
+ cd "$pkgname-$pkgver"
+ make $BUILD_FLAGS PREFIX="/usr"
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" PREFIX="/usr" install
+}