summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO45
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD36
-rw-r--r--foobnix.install11
4 files changed, 50 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dfaade669036..7284b087b843 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,35 @@
-# Generated by mksrcinfo v8
-# Thu Feb 4 22:05:01 UTC 2016
pkgbase = foobnix
- pkgdesc = Music player for Linux
- pkgver = 3.1
+ pkgdesc = GTK+ music player
+ pkgver = 3.2.1
pkgrel = 1
- url = http://www.foobnix.com/
- install = foobnix.install
+ url = http://www.foobnix.com
arch = i686
arch = x86_64
license = GPL3
- depends = desktop-file-utils
- depends = gettext
- depends = gst-plugins-bad
- depends = gst-plugins-base
+ makedepends = python-setuptools
+ depends = python-chardet
+ depends = python-simplejson
+ depends = python-mutagen
depends = gst-plugins-good
+ depends = gst-plugins-base
depends = gst-plugins-ugly
- depends = gst-plugins-base-libs
- depends = gst-python2
- depends = mutagen
- depends = python2-chardet
- depends = python2-gobject
- depends = python2-keybinder2
- depends = python2-notify
- depends = python2-simplejson
- source = https://github.com/foobnix/foobnix/archive/3.1.tar.gz
- md5sums = 0602df86c4027d7ef36b0224c92553ed
+ depends = gst-plugins-bad
+ depends = gst-libav
+ depends = gst-python
+ depends = webkit2gtk
+ depends = libkeybinder3
+ depends = fuseiso
+ depends = python-notify2
+ depends = python3-keybinder
+ depends = lame
+ depends = faac
+ depends = ffmpeg
+ depends = python-dbus
+ depends = python-pylast
+ provides = foobnix
+ conflicts = foobnix
+ source = foobnix-3.2.1.tar.gz::https://github.com/foobnix/foobnix/archive/3.2.1.tar.gz
+ sha512sums = 072a28a5b26b3977a607957187d2cf7b2368c6a5ad4dd8db78712d19f607f85185e97c198425f3084e52c348ac7f566cb150f6e6a6b59188068855d0ef4feca6
pkgname = foobnix
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 294098a42769..260d1fe5504e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
-# Maintainer: Brenton Horne <brentonhorne77 at gmail dot com>
-
+# Maintainer: Alex Tharp <toastercup at gmail dot com>
+# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: Brenton Horne <brentonhorne77 at gmail dot com>
pkgname=foobnix
-pkgver=3.1
+pkgver=3.2.1
pkgrel=1
-pkgdesc="Music player for Linux"
+pkgdesc="GTK+ music player"
arch=('i686' 'x86_64')
-url="http://www.foobnix.com/"
+url="http://www.foobnix.com"
license=('GPL3')
-source=("https://github.com/foobnix/foobnix/archive/${pkgver}.tar.gz")
-md5sums=('0602df86c4027d7ef36b0224c92553ed')
-depends=('desktop-file-utils' 'gettext' 'gst-plugins-bad' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-ugly'
-'gst-plugins-base-libs' 'gst-python2' 'mutagen' 'python2-chardet' 'python2-gobject' 'python2-keybinder2' 'python2-notify'
-'python2-simplejson')
-install=foobnix.install
-
-build() {
- cd ${pkgname}-${pkgver}
- python2 setup.py build
-}
+depends=('python-chardet' 'python-simplejson' 'python-mutagen'
+ 'gst-plugins-good' 'gst-plugins-base' 'gst-plugins-ugly'
+ 'gst-plugins-bad' 'gst-libav' 'gst-python' 'webkit2gtk'
+ 'libkeybinder3' 'fuseiso' 'python-notify2' 'python3-keybinder'
+ 'lame' 'faac' 'ffmpeg' 'python-dbus' 'python-pylast')
+makedepends=('python-setuptools')
+provides=('foobnix')
+conflicts=('foobnix')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz")
+sha512sums=('072a28a5b26b3977a607957187d2cf7b2368c6a5ad4dd8db78712d19f607f85185e97c198425f3084e52c348ac7f566cb150f6e6a6b59188068855d0ef4feca6')
package() {
- cd ${pkgname}-${pkgver}
- python2 setup.py install --root=${pkgdir}
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
}
diff --git a/foobnix.install b/foobnix.install
deleted file mode 100644
index e111ef946053..000000000000
--- a/foobnix.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}