summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO37
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD25
-rw-r--r--foobnix.install11
4 files changed, 41 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 469fae9262e4..5c743ec21c40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,34 @@
-# Generated by mksrcinfo v8
-# Wed Aug 23 09:31:51 UTC 2017
pkgbase = foobnix
pkgdesc = Music player for Linux
pkgver = 3.1
- pkgrel = 1
- url = http://www.foobnix.com/
- install = foobnix.install
+ pkgrel = 2
+ url = http://www.foobnix.com
arch = i686
arch = x86_64
license = GPL3
- depends = desktop-file-utils
+ makedepends = python2-setuptools
+ depends = python2-chardet
+ depends = python2-gobject
+ depends = python2-simplejson
+ depends = python2-mutagen
+ depends = gst-plugins-good
+ depends = gst-plugins-base
+ depends = gst-python2
+ depends = webkitgtk
+ depends = libkeybinder3
+ depends = libnotify
depends = gettext
depends = gst-plugins-bad
- depends = gst-plugins-base
- depends = gst-plugins-good
depends = gst-plugins-ugly
- depends = webkitgtk
- depends = gst-plugins-base-libs
- depends = gst-python2
- depends = mutagen
- depends = python2-chardet
- depends = python2-gobject
- depends = python2-keybinder2
+ depends = gst-libav
+ depends = fuseiso
depends = python2-notify
- depends = python2-simplejson
+ depends = lame
+ depends = faac
+ depends = python2-keybinder2
+ depends = ffmpeg
source = https://github.com/foobnix/foobnix/archive/3.1.tar.gz
- md5sums = 0602df86c4027d7ef36b0224c92553ed
+ sha256sums = a4fb20d1a015eeb07fe7611c577aea7290e71e4eff10f6e458d8c987353f97dd
pkgname = foobnix
diff --git a/.gitignore b/.gitignore
index 9fed1d3877d3..4dab8d6386e3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,7 @@
-src
-pkg
-*.pkg.tar.xz
-*.gz
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 7ae230718ca8..e5b75e919b97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
-# Maintainer: Brenton Horne <brentonhorne77 at gmail dot com>
-
+# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
+# Contributor: Brenton Horne <brentonhorne77 at gmail dot com>
pkgname=foobnix
pkgver=3.1
-pkgrel=1
+pkgrel=2
pkgdesc="Music player for Linux"
arch=('i686' 'x86_64')
-url="http://www.foobnix.com/"
+url="http://www.foobnix.com"
license=('GPL3')
-source=("https://github.com/foobnix/foobnix/archive/${pkgver}.tar.gz")
-md5sums=('0602df86c4027d7ef36b0224c92553ed')
-depends=('desktop-file-utils' 'gettext' 'gst-plugins-bad' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-ugly' 'webkitgtk' 'gst-plugins-base-libs' 'gst-python2' 'mutagen' 'python2-chardet' 'python2-gobject' 'python2-keybinder2' 'python2-notify' 'python2-simplejson')
-install=foobnix.install
+source=("https://github.com/foobnix/foobnix/archive/$pkgver.tar.gz")
+sha256sums=('a4fb20d1a015eeb07fe7611c577aea7290e71e4eff10f6e458d8c987353f97dd')
+depends=('python2-chardet' 'python2-gobject' 'python2-simplejson' 'python2-mutagen' 'gst-plugins-good'
+ 'gst-plugins-base' 'gst-python2' 'webkitgtk' 'libkeybinder3' 'libnotify' 'gettext'
+ 'gst-plugins-bad' 'gst-plugins-ugly' 'gst-libav' 'fuseiso' 'python2-notify' 'lame' 'faac'
+ 'python2-keybinder2' 'ffmpeg')
+makedepends=('python2-setuptools')
build() {
- cd ${pkgname}-${pkgver}
+ cd $pkgname-$pkgver
python2 setup.py build
}
package() {
- cd ${pkgname}-${pkgver}
- python2 setup.py install --root=${pkgdir}
+ cd $pkgname-$pkgver
+ python2 setup.py install --root="$pkgdir/" --optimize=1
}
diff --git a/foobnix.install b/foobnix.install
deleted file mode 100644
index e111ef946053..000000000000
--- a/foobnix.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}