summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD25
-rw-r--r--foobnix.install11
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dfaade669036
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Thu Feb 4 22:05:01 UTC 2016
+pkgbase = foobnix
+ pkgdesc = Music player for Linux
+ pkgver = 3.1
+ pkgrel = 1
+ url = http://www.foobnix.com/
+ install = foobnix.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = desktop-file-utils
+ depends = gettext
+ depends = gst-plugins-bad
+ depends = gst-plugins-base
+ depends = gst-plugins-good
+ depends = gst-plugins-ugly
+ depends = gst-plugins-base-libs
+ depends = gst-python2
+ depends = mutagen
+ depends = python2-chardet
+ depends = python2-gobject
+ depends = python2-keybinder2
+ depends = python2-notify
+ depends = python2-simplejson
+ source = https://github.com/foobnix/foobnix/archive/3.1.tar.gz
+ md5sums = 0602df86c4027d7ef36b0224c92553ed
+
+pkgname = foobnix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..294098a42769
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Brenton Horne <brentonhorne77 at gmail dot com>
+
+pkgname=foobnix
+pkgver=3.1
+pkgrel=1
+pkgdesc="Music player for Linux"
+arch=('i686' 'x86_64')
+url="http://www.foobnix.com/"
+license=('GPL3')
+source=("https://github.com/foobnix/foobnix/archive/${pkgver}.tar.gz")
+md5sums=('0602df86c4027d7ef36b0224c92553ed')
+depends=('desktop-file-utils' 'gettext' 'gst-plugins-bad' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-ugly'
+'gst-plugins-base-libs' 'gst-python2' 'mutagen' 'python2-chardet' 'python2-gobject' 'python2-keybinder2' 'python2-notify'
+'python2-simplejson')
+install=foobnix.install
+
+build() {
+ cd ${pkgname}-${pkgver}
+ python2 setup.py build
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ python2 setup.py install --root=${pkgdir}
+}
diff --git a/foobnix.install b/foobnix.install
new file mode 100644
index 000000000000..e111ef946053
--- /dev/null
+++ b/foobnix.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}