summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 11 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4061d778692a..b5b6d5aa1bde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = foonathan_memory
pkgdesc = STL compatible C++ memory allocator library using a new RawAllocator concept that is similar to an Allocator but easier to use and write.
- pkgver = 0.6.2
+ pkgver = 0.7.0
pkgrel = 1
url = http://foonathan.net/memory
arch = x86_64
license = ZLIB
makedepends = cmake
makedepends = git
- source = foonathan_memory-0.6.2.tar.gz::https://github.com/foonathan/memory/archive/v0.6-2.tar.gz
- source = git+https://github.com/foonathan/compatibility.git#commit=cd14212
- sha256sums = cf302578f3b6721707b8428fd9b97182ada1970ce56f8881ea0b3390b97e66e3
- sha256sums = SKIP
+ source = foonathan_memory-0.7.0.tar.gz::https://github.com/foonathan/memory/archive/v0.7.tar.gz
+ sha256sums = 01a7cc5a5ebddbd71bec69c89562a4a2ecd7c29334c0a29d38d83e7f7f66eb53
pkgname = foonathan_memory
diff --git a/PKGBUILD b/PKGBUILD
index 18c731fe2619..de13caa598b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,23 @@
# Maintainer: Jens Carl <jc [dot] archlinux [at] jens-carl [dot] de>
pkgname=foonathan_memory
-pkgver=0.6.2
-_pkgver=0.6-2
+pkgver=0.7.0
+_pkgver=0.7
pkgrel=1
pkgdesc="STL compatible C++ memory allocator library using a new RawAllocator concept that is similar to an Allocator but easier to use and write."
url="http://foonathan.net/memory"
arch=('x86_64')
license=('ZLIB')
makedepends=('cmake' 'git')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/foonathan/memory/archive/v${_pkgver}.tar.gz"
- 'git+https://github.com/foonathan/compatibility.git#commit=cd14212')
-sha256sums=('cf302578f3b6721707b8428fd9b97182ada1970ce56f8881ea0b3390b97e66e3' 'SKIP')
-
-prepare() {
- cd "${srcdir}/memory-${_pkgver}/"
- rm -rf build && mkdir build
-
- cd cmake/comp
- ln -sf "${srcdir}/compatibility/comp_base.cmake"
-}
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/foonathan/memory/archive/v${_pkgver}.tar.gz")
+sha256sums=('01a7cc5a5ebddbd71bec69c89562a4a2ecd7c29334c0a29d38d83e7f7f66eb53')
build() {
cd "${srcdir}/memory-${_pkgver}"
+ if [ -d build ]; then
+ rm -rf build
+ fi
+ mkdir build
cd build
cmake .. \