summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d6157d78cc8..f27d9a373894 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = foosynth-plugin-neo_minideen-git
pkgdesc = Plugin for Vapoursynth/Avisynth: neo_minideen (Dual interface for Vapoursynth/Avisynth) (GIT version)
- pkgver = r11.0.g0342ed5
+ pkgver = 11.0.g0342ed5
pkgrel = 1
url = https://forum.doom9.org/showthread.php?t=176554
arch = x86_64
@@ -10,6 +10,7 @@ pkgbase = foosynth-plugin-neo_minideen-git
makedepends = cmake
makedepends = avisynthplus
makedepends = vapoursynth
+ options = debug
source = neo_minideen::git+https://github.com/HomeOfAviSynthPlusEvolution/minideen.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 7090ce231694..496926cba2d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
_plug=neo_minideen
pkgbase="foosynth-plugin-${_plug}-git"
pkgname=("avisynth-plugin-${_plug}-git"
"vapoursynth-plugin-${_plug}-git"
)
-pkgver=r11.0.g0342ed5
+pkgver=11.0.g0342ed5
pkgrel=1
pkgdesc="Plugin for Vapoursynth/Avisynth: ${_plug} (Dual interface for Vapoursynth/Avisynth) (GIT version)"
arch=('x86_64')
@@ -18,20 +18,20 @@ makedepends=('git'
)
source=("${_plug}::git+https://github.com/HomeOfAviSynthPlusEvolution/minideen.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d r)"
}
prepare() {
- cd "${_plug}"
- mkdir -p build
+ mkdir -p "${_plug}/build"
}
build() {
cd "${_plug}/build"
- cmake .. \
+ cmake -S .. -B . \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr