summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rw-r--r--minecraft-server.install6
-rwxr-xr-xminecraftd.sh7
4 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7846b8aef65..36d77ffd5657 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Jan 23 11:45:46 UTC 2016
+# Mon Jan 25 23:18:20 UTC 2016
pkgbase = minecraft-server
pkgdesc = Minecraft server unit files, script, and jar
pkgver = 1.8.9
@@ -29,7 +29,7 @@ pkgbase = minecraft-server
md5sums = c644abdf293c2f98033a64d732a4945c
md5sums = 5ed78e366146e47f8498347e93ad5423
md5sums = 8088e2b05ef4d85049dea41585a9070d
- md5sums = 36962e5da95c9f8a2beb910f312f96c6
+ md5sums = 4b9ee8074249619c01ca6e3672fc329e
pkgname = minecraft-server
diff --git a/PKGBUILD b/PKGBUILD
index 536a69a7289a..338bd18db665 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,7 +26,7 @@ md5sums=('3acbaef956308c805e8e2d0a03a737e9'
'c644abdf293c2f98033a64d732a4945c'
'5ed78e366146e47f8498347e93ad5423'
'8088e2b05ef4d85049dea41585a9070d'
- '36962e5da95c9f8a2beb910f312f96c6')
+ '4b9ee8074249619c01ca6e3672fc329e')
package() {
install -Dm644 minecraftd.conf "${pkgdir}/etc/conf.d/minecraft"
diff --git a/minecraft-server.install b/minecraft-server.install
index fc4635c71153..961988caa3b8 100644
--- a/minecraft-server.install
+++ b/minecraft-server.install
@@ -28,8 +28,10 @@ post_upgrade() {
chown -R ${USER}:${USER} "${SERVER_ROOT}"
if [[ -f /etc/conf.d/minecraft.pacnew ]]; then
- echo -e "\e[34;1m==>\e[39;1m NOTE: There was a new change on how backup files are handled! Please merge the new \e[0m"
- echo -e "\e[34;1m==>\e[39;1m configuration file into /etc/conf.d/minecraft by e.g. pacdiff. \e[0m"
+ echo -e "\e[34;1m==>\e[39;1m NOTE: There was a new change on how backup files are handled! Unfortunately this makes \e[0m"
+ echo -e "\e[34;1m==>\e[39;1m old backups incompatible with the newly implemeted restore feature. Bare in mind that no data is lost \e[0m"
+ echo -e "\e[34;1m==>\e[39;1m neither are those backups useless. They just will not work with the restore capability of the management script. \e[0m"
+ echo -e "\e[34;1m==>\e[39;1m NOTE: Please merge the new configuration file into /etc/conf.d/minecraft by e.g. using pacdiff. \e[0m"
fi
}
diff --git a/minecraftd.sh b/minecraftd.sh
index 212accd68fb6..cad4fb7fbc55 100755
--- a/minecraftd.sh
+++ b/minecraftd.sh
@@ -18,6 +18,9 @@ MAXHEAP="${MAXHEAP:-1024M}"
THREADS="${THREADS:-1}"
JAVA_PARMS="${JAVA_PARMS:-"-Xmx${MAXHEAP} -Xms${MINHEAP} -XX:ParallelGCThreads=${THREADS}"}"
+# The actual program name
+declare -r myname="minecraftd"
+
# Check for sudo rigths
if [ $(sudo whoami) != "root" ]; then
echo "You must have sudo access in order to use this script."
@@ -222,11 +225,11 @@ server_console() {
# Help function, no arguments required
help() {
- cat <<- 'EOF'
+ cat <<-EOF
This script was design to easily control any minecraft server. Quite every parameter for a given
minecraft server derivative can be altered by editing the variables in the configuration file.
- Usage: minecraftd {start|stop|status|backup|command <command>|console}
+ Usage: $myname {start|stop|status|backup|restore|command <command>|console}
start Start the minecraft server
stop Stop the minecraft server
restart Restart the minecraft server