summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD43
2 files changed, 40 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e81473fdc9f5..53dd2d7781cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = fortran-fpm-bin
- pkgdesc = A package manager and build system for Fortran.
- pkgver = 0.2.0
+ pkgdesc = A Fortran package manager and build system
+ pkgver = 0.10.1
pkgrel = 1
url = https://fpm.fortran-lang.org/
arch = x86_64
license = MIT
+ depends = git
conflicts = fpm
- source = https://github.com/fortran-lang/fpm/releases/download/v0.2.0/fpm-0.2.0-linux-x86_64
- sha256sums = c4282998c83bb91a7949d23723a06dc4769a75f8d2c3dcc761794a1b65e8004f
+ conflicts = fortran-fpm
+ source = https://github.com/fortran-lang/fpm/releases/download/v0.10.1/fpm-0.10.1-linux-x86_64
+ source = https://raw.githubusercontent.com/fortran-lang/fpm/main/LICENSE
+ sha256sums = 2c0759e349fb8c91fc6d4cbc1c355f52cfd1dd15589273550327daf6e7f9932c
+ sha256sums = b7e33601c0130d1a674fcc772ed9b7804460d1896469a5b219ba4062efcd9fb9
pkgname = fortran-fpm-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index c4766bcf93e9..b10fc37f8f13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,39 @@
-# Maintainer: proofconstruction <source@proof.construction>
+# Maintainer: banana-bred <j.forer@posteo.net>
-pkgname=('fortran-fpm-bin')
-_pkgname='fpm'
-pkgver=0.2.0
-revision=799fcacee02e60a1679116765c4c3669d31e7201
+pkgname=fortran-fpm-bin
+_name=fpm
+pkgver=0.10.1
pkgrel=1
-pkgdesc="A package manager and build system for Fortran."
+epoch=
+pkgdesc='A Fortran package manager and build system'
arch=('x86_64')
-url="https://fpm.fortran-lang.org/"
+url='https://fpm.fortran-lang.org/'
license=('MIT')
-conflicts=('fpm')
-source=("https://github.com/fortran-lang/fpm/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-${arch}")
-sha256sums=('c4282998c83bb91a7949d23723a06dc4769a75f8d2c3dcc761794a1b65e8004f')
+groups=()
+depends=('git')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=("${_name}" "${pkgname%-bin}")
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+noextract=()
+source=(
+ "https://github.com/fortran-lang/fpm/releases/download/v${pkgver}/${_name}-${pkgver}-linux-${arch}"
+ "https://raw.githubusercontent.com/fortran-lang/fpm/main/LICENSE"
+)
+sha256sums=(
+ 2c0759e349fb8c91fc6d4cbc1c355f52cfd1dd15589273550327daf6e7f9932c
+ 'b7e33601c0130d1a674fcc772ed9b7804460d1896469a5b219ba4062efcd9fb9'
+)
package() {
- install -Dm 755 "${srcdir}/${_pkgname}-${pkgver}-linux-${arch}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm 755 "${srcdir}/${_name}-${pkgver}-linux-${arch}" "${pkgdir}/usr/bin/${_name}"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
+
+# vim: ts=2 sw=2 et :