summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD41
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f8b5eb84d13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fortune-mod-zh-git
+ pkgdesc = Chinese poems for fortune-mod
+ pkgver = 1.8.r38.g3a06c3c
+ pkgrel = 1
+ url = http://packages.qa.debian.org/f/fortune-zh.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = fortune-mod
+ conflicts = fortune-mod-zh
+ source = git+https://anonscm.debian.org/git/chinese/fortune-zh.git#branch=master
+ md5sums = SKIP
+
+pkgname = fortune-mod-zh-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01ad77b801a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Gadget3000 <gadget3000 at msn dot com>
+# Contributor: sssslang <xofyarg at gmail dot com>
+# Contributor: Rick W. Chen <stuffcorpse@archlinux.us>
+
+# Change to yanyu for experimental content
+_branch=master
+
+pkgname=fortune-mod-zh-git
+pkgver=1.8.r38.g3a06c3c
+pkgrel=1
+pkgdesc="Chinese poems for fortune-mod"
+url="http://packages.qa.debian.org/f/fortune-zh.html"
+license="GPL"
+depends=('fortune-mod')
+makedepends=('git')
+conflicts=('fortune-mod-zh')
+source=("git+https://anonscm.debian.org/git/chinese/fortune-zh.git#branch=$_branch")
+md5sums=('SKIP')
+arch=('i686' 'x86_64')
+
+pkgver() {
+ cd fortune-zh
+ git describe --long | sed 's#^debian/##;s/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ # Fix path in fortune-zh executable
+ cd fortune-zh
+ sed -i "s|/usr/games/fortune|/usr/bin/fortune|" fortune-zh
+}
+
+build() {
+ cd fortune-zh
+ make
+}
+
+package() {
+ cd fortune-zh
+ make DESTDIR="$pkgdir" FORTUNES=/usr/share/fortune GAMES=/usr/bin install
+}